<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head profile="http://gmpg.org/xfn/11"><link rel="stylesheet" href="//fonts.googleapis.com/css?family=Open+Sans%3A400%2C300" /><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><title> &#8216;Due process not followed&#8217; | Barbados Today</title><link rel="stylesheet" type="text/css" media="all" href="https://16f6e5e6d2.site.internapcdn.net/wp-content/themes/barbadostoday/style.css" /><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://www.barbadostoday.bb/feed/" /><link rel="pingback" href="https://www.barbadostoday.bb/xmlrpc.php" /><meta name="robots" content="noodp,noydir" /><meta name="description" content="&#8216;Due process not followed&#8217; | Embattled West Indies left-hander Darren Bravo has accused Cricket West Indies of not affording him due process, in the decision&#8230;" /><link rel="canonical" href="https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/" /><link rel='dns-prefetch' href='//cdn.broadstreetads.com' /><link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel='dns-prefetch' href='//16f6e5e6d2.site.internapcdn.net' /><link rel="alternate" type="application/rss+xml" title="Barbados Today &raquo; Feed" href="https://www.barbadostoday.bb/feed/" /><link rel="alternate" type="application/rss+xml" title="Barbados Today &raquo; Comments Feed" href="https://www.barbadostoday.bb/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Barbados Today &raquo; &#8216;Due process not followed&#8217; Comments Feed" href="https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/16f6e5e6d2.site.internapcdn.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link rel='stylesheet' id='awesome-weather-css'  href='https://16f6e5e6d2.site.internapcdn.net/wp-content/plugins/awesome-weather/awesome-weather.css?ver=4.8' type='text/css' media='all' /><style id='awesome-weather-inline-css' type='text/css'>.awesome-weather-wrap{font-family:'Open Sans',sans-serif;font-weight:400;font-size:14px;line-height:14px}</style><link rel='stylesheet' id='gabfire-widget-css-css'  href='https://16f6e5e6d2.site.internapcdn.net/wp-content/plugins/gabfire-widget-pack/css/style.css?ver=4.8' type='text/css' media='all' /><link rel='stylesheet' id='popular-widget-css'  href='https://16f6e5e6d2.site.internapcdn.net/wp-content/plugins/popular-widget/_css/pop-widget.css?ver=1.7.0' type='text/css' media='all' /><link rel='stylesheet' id='wpsso_ssb_sharing_css-css'  href='https://16f6e5e6d2.site.internapcdn.net/wp-content/plugins/wpsso/cache/ssb-styles-id-1.min.css?ver=3.45.0' type='text/css' media='all' /> <script type='text/javascript' data-cfasync='false' src='https://cdn.broadstreetads.com/init-2.min.js?ver=4.8'></script> <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js?ver=4.8'></script> <script type='text/javascript' src='https://16f6e5e6d2.site.internapcdn.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript' src='https://16f6e5e6d2.site.internapcdn.net/wp-content/themes/city-desk/inc/js/jquery.cycle.all.min.js?ver=4.8'></script> <script type='text/javascript' src='https://16f6e5e6d2.site.internapcdn.net/wp-content/themes/city-desk/inc/js/slides.min.jquery.js?ver=4.8'></script> <script type='text/javascript' src='https://16f6e5e6d2.site.internapcdn.net/wp-content/themes/city-desk/inc/js/jCarouselLite.js?ver=4.8'></script> <script type='text/javascript' src='https://16f6e5e6d2.site.internapcdn.net/wp-content/themes/city-desk/inc/js/flowplayer/flowplayer-3.2.6.min.js?ver=4.8'></script> <link rel='https://api.w.org/' href='https://www.barbadostoday.bb/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.barbadostoday.bb/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.barbadostoday.bb/wp-includes/wlwmanifest.xml" /><link rel="alternate" type="application/json+oembed" href="https://www.barbadostoday.bb/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.barbadostoday.bb%2F2017%2F06%2F23%2Fdue-process-not-followed%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.barbadostoday.bb/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.barbadostoday.bb%2F2017%2F06%2F23%2Fdue-process-not-followed%2F&#038;format=xml" /><link href="https://www.barbadostoday.bb/wp-content/themes/city-desk/styles/default.css" rel="stylesheet" type="text/css" /> <style type="text/css">.ad728{height:90px}.mastheadnav{width:580px;margin-top:10px}#gabfire_social_widget-2.widget.gabfire_social_widget{width:165px;height:53px}.gabfire_social_widget
a{margin:3px
3px}#content .single-default
p{line-height:1.5;margin-bottom:1.7em}#foo_widget1{font-size:12px}.news_wrapper{margin-bottom:15px}#mainmenu{display:block;background:#27aae1;border-top:1px solid #082133}#footer{background:#17478E}#footer
.widgettitle{border-bottom:1px dotted #fff}.newsblock .right .posttitle
a{color:#1282C4}#respond .form-submit
#submit{height:30px}#footer-left-side{display:none}#footer-right-side{display:none}div.pop-inside ul li .pop-summary{color:#555}.wp-caption-text{line-height:1.2;margin-top:7px}</style> <script type='text/javascript'>(function($) {
		$(document).ready(function() { 
			
			$('a[href="#top"]').click(function(){	$('html, body').animate({scrollTop:0}, 'slow');	return false; });
			
						$('#slides').slides({
								autoHeight: true
			});
						$("ul.tabs").tabs("div.panes > div");
			$("ul.sc_tabs").tabs("div.sc_tabs-content > div");
		});
	})(jQuery);</script> <meta name="wpsso:mark:begin" content="wpsso meta tags begin"/><meta name="generator" content="WPSSO Pro 3.45.0/L"/><meta name="generator" content="WPSSO SSB Pro 2.4.2/L"/><meta name="generator" content="WPSSO UM 1.6.4/G"/><link rel="publisher" href="https://plus.google.com/+barbadostoday/"/><link rel="shortlink" href="https://www.barbadostoday.bb/?p=204696"/><meta property="fb:app_id" content="613718815307708"/><meta property="og:url" content="https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/"/><meta property="og:type" content="article"/><meta property="og:locale" content="en_US"/><meta property="og:site_name" content="Barbados Today"/><meta property="og:title" content="&lsquo;Due process not followed&rsquo;"/><meta property="og:description" content="Embattled West Indies left-hander Darren Bravo has accused Cricket West Indies of not affording him due process, in the decision to axe him from the Tri-Series tour of Zimbabwe last November. Breaking..."/><meta property="og:image" content="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies.-600x315.jpg"/><meta property="og:image:width" content="600"/><meta property="og:image:height" content="315"/><meta property="article:publisher" content="https://www.facebook.com/BarbadosToday"/><meta property="article:published_time" content="2017-06-23T04:51:50+00:00"/><meta property="article:modified_time" content="2017-06-23T01:59:35+00:00"/><meta property="og:updated_time" content="2017-06-23T01:59:35+00:00"/><meta name="weibo:article:create_at" content="2017-06-23 04:51:50"/><meta name="weibo:article:update_at" content="2017-06-23 01:59:35"/><meta name="twitter:domain" content="www.barbadostoday.bb"/><meta name="twitter:site" content="@barbadostoday"/><meta name="twitter:title" content="&lsquo;Due process not followed&rsquo;"/><meta name="twitter:description" content="Embattled West Indies left-hander Darren Bravo has accused Cricket West Indies of not affording him due process, in the decision to axe him from the Tri-Series tour of Zimbabwe last November..."/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies..jpg"/><link itemprop="url" href="https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/"/><meta itemprop="name" content="&lsquo;Due process not followed&rsquo;"/><meta itemprop="description" content="Embattled West Indies left-hander Darren Bravo has accused Cricket West Indies of not affording him due process, in the decision to axe him from the Tri-Series tour of Zimbabwe last November. Breaking..."/><meta itemprop="datePublished" content="2017-06-23T04:51:50+00:00"/><meta itemprop="dateModified" content="2017-06-23T01:59:35+00:00"/><meta name="author" content="Barbados Today"/> <noscript itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Barbados Today"/><meta itemprop="description" content="Barbados Today is the leading news service in Barbados. Founded in January 2010, with the mission to keep you informed, we aim to share news on matters of national interest, raise the level of public debate and help our readers make informed decisions in their daily lives. We do this by building confidence in our content through consistency. We strive for accuracy, accountability and maturity in our reporting at all times."/> </noscript> <noscript itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><link itemprop="url" href="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies..jpg"/><meta itemprop="width" content="700"/><meta itemprop="height" content="400"/> </noscript><meta name="wpsso:mark:end" content="wpsso meta tags end"/> <script type="text/javascript" id="wpssossb-header-script">window.___gcfg = { lang: "en-US" };
	function wpsso_insert_js( script_id, url, async ) {
		if ( document.getElementById( script_id + "-js" ) ) return;
		var async = typeof async !== "undefined" ? async : true;
		var script_pos = document.getElementById( script_id );
		var js = document.createElement( "script" );
		js.id = script_id + "-js";
		js.async = async;
		js.type = "text/javascript";
		js.language = "JavaScript";
		js.src = url;
		script_pos.parentNode.insertBefore( js, script_pos );
	};</script> 
 <script type="text/javascript" id="fb-script-header">/*<![CDATA[*/wpsso_insert_js( "fb-script-header", "https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=613718815307708" );/*]]>*/</script> <script type="text/javascript" id="gplus-script-header">wpsso_insert_js( "gplus-script-header", "https://apis.google.com/js/plusone.js" );</script> <script type="text/javascript" id="linkedin-script-header">wpsso_insert_js( "linkedin-script-header", "https://platform.linkedin.com/in.js" );</script> <script type="text/javascript" id="twitter-script-header">wpsso_insert_js( "twitter-script-header", "https://platform.twitter.com/widgets.js" );</script> <link rel="shortcut icon" href="https://www.barbadostoday.bb/wp-content/uploads/2011/12/favicon.gif"/> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-13210981-3', 'auto');
  ga('send', 'pageview');</script> <script data-no-minify="1" data-cfasync="false">(function(w,d){function a(){var b=d.createElement("script");b.async=!0;b.src="https://16f6e5e6d2.site.internapcdn.net/wp-content/plugins/wp-rocket/inc/front/js/lazyload.1.0.5.min.js";var a=d.getElementsByTagName("script")[0];a.parentNode.insertBefore(b,a)}w.attachEvent?w.attachEvent("onload",a):w.addEventListener("load",a,!1)})(window,document);</script> <style type="text/css" media="screen">body{font-size:14px;font-family:arial;font-weight:normal;color:#555}a{color:#27aae1}h2.posttitle{font-size:18px;font-family:arial;font-weight:normal;color:#555}h2.posttitle
a{color:#034693}.widgettitle{font-size:14px;font-family:arial;font-weight:normal;color:#555}.catname
span{font-size:22px;font-family:arial;font-weight:normal;color:#555}</style><broadstreet-zone zone-id="54052"></broadstreet-zone> <broadstreet-zone zone-id="51273"></broadstreet-zone> <broadstreet-zone zone-id="51634"></broadstreet-zone> <broadstreet-zone zone-id="51320"></broadstreet-zone></head><body class="post-template-default single single-post postid-204696 single-format-standard"><div class="ad728"> <script>broadstreet.zone(50028);</script> </div><div class="wrapper"><div id="masthead"><ul class="mastheadnav dropdown"><li class="first"><a href="https://www.barbadostoday.bb/" title="News you can trust.">Home</a></li><li id="menu-item-50433" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50433"><a title="Our Print-Style Publication" href="http://epaper.barbadostoday.bb">ePaper</a></li><li id="menu-item-142207" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142207"><a href="https://www.barbadostoday.bb/download-todays-news-app/">Mobile App</a></li><li id="menu-item-142206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142206"><a href="https://www.barbadostoday.bb/newsletters/">Newsletters</a></li><li id="menu-item-142202" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142202"><a href="https://www.facebook.com/barbadostoday">Facebook</a></li><li id="menu-item-142205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142205"><a href="https://www.youtube.com/user/barbadostoday?&#038;ab_channel=BarbadosToday">YouTube</a></li><li id="menu-item-142203" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142203"><a href="https://twitter.com/barbadostoday">Twitter</a></li><li id="menu-item-142201" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142201"><a href="https://instagram.com/barbadostoday/">Instagram</a></li></ul><div class="search"><form class="gabfire_search_style1" action="https://www.barbadostoday.bb/"><fieldset> <input type="text" class="gab_search_text" name="s" value="Search in site..." onfocus="if (this.value == 'Search in site...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search in site...';}" /> <input type="submit"  value="" class="submit_style1" /><div class="clearfix"></div></fieldset></form></div></div><div id="header"> <a href="https://www.barbadostoday.bb/" title="News you can trust."> <img  src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/09/BT-7th-ANn-Website-Header-2017-01-1.jpg" id="header_banner" alt="Barbados Today" title="Barbados Today"/> </a></div><div id="mainmenu"><ul class="mainnav dropdown"><li class="first"><a href="https://www.barbadostoday.bb/" title="News you can trust.">Home</a></li><li id="menu-item-157940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157940"><a href="https://www.barbadostoday.bb/category/local-news/">Local News</a><ul  class="sub-menu"><li id="menu-item-157948" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157948"><a href="https://www.barbadostoday.bb/category/local-news/agriculture/">Agriculture</a></li><li id="menu-item-157949" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157949"><a href="https://www.barbadostoday.bb/category/local-news/church/">Church</a></li><li id="menu-item-157951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157951"><a href="https://www.barbadostoday.bb/category/court/">Court</a></li><li id="menu-item-157952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157952"><a href="https://www.barbadostoday.bb/category/local-news/crime/">Crime</a></li><li id="menu-item-157953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157953"><a href="https://www.barbadostoday.bb/category/local-news/culture/">Culture</a></li><li id="menu-item-157954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157954"><a href="https://www.barbadostoday.bb/category/local-news/economy/">Economy</a></li><li id="menu-item-157955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157955"><a href="https://www.barbadostoday.bb/category/local-news/education/">Education</a></li><li id="menu-item-157957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157957"><a href="https://www.barbadostoday.bb/category/local-news/energy/">Energy</a></li><li id="menu-item-157958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157958"><a href="https://www.barbadostoday.bb/category/local-news/environment/">Environment</a></li><li id="menu-item-157959" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157959"><a href="https://www.barbadostoday.bb/category/local-news/health-care/">Health Care</a></li><li id="menu-item-157961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157961"><a href="https://www.barbadostoday.bb/category/local-news/transportation/">Transportation</a></li></ul></li><li id="menu-item-157941" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-157941"><a href="https://www.barbadostoday.bb/category/sports/">Sports</a><ul  class="sub-menu"><li id="menu-item-157962" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-157962"><a href="https://www.barbadostoday.bb/category/sports/cricket/">Cricket</a></li><li id="menu-item-157963" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157963"><a href="https://www.barbadostoday.bb/category/sports/athletics/">Athletics</a></li><li id="menu-item-157964" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157964"><a href="https://www.barbadostoday.bb/category/sports/basketball/">Basketball</a></li><li id="menu-item-157965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157965"><a href="https://www.barbadostoday.bb/category/sports/football/">Football</a></li><li id="menu-item-157966" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157966"><a href="https://www.barbadostoday.bb/category/sports/motor-sport/">Motor Sport</a></li><li id="menu-item-157967" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157967"><a href="https://www.barbadostoday.bb/category/sports/netball/">Netball</a></li><li id="menu-item-157968" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157968"><a href="https://www.barbadostoday.bb/category/sports/school/">School</a></li><li id="menu-item-157969" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157969"><a href="https://www.barbadostoday.bb/category/sports/tennis/">Tennis</a></li><li id="menu-item-157970" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157970"><a href="https://www.barbadostoday.bb/category/sports/road-tennis/">Road Tennis</a></li><li id="menu-item-157971" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157971"><a href="https://www.barbadostoday.bb/category/sports/track-and-field/">Track and Field</a></li></ul></li><li id="menu-item-157944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157944"><a href="https://www.barbadostoday.bb/category/business/">Business</a><ul  class="sub-menu"><li id="menu-item-157978" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157978"><a href="https://www.barbadostoday.bb/category/business/banking/">Banking</a></li><li id="menu-item-157975" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157975"><a href="https://www.barbadostoday.bb/category/business/entrepreneurship/">Entrepreneurship</a></li><li id="menu-item-157974" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157974"><a href="https://www.barbadostoday.bb/category/business/industrial-relations/">Indus. Relations</a></li><li id="menu-item-157976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157976"><a href="https://www.barbadostoday.bb/category/business/international-business/">Int&#8217;l Business</a></li><li id="menu-item-157973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157973"><a href="https://www.barbadostoday.bb/category/business/social-partnership/">Social Partnership</a></li><li id="menu-item-157977" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157977"><a href="https://www.barbadostoday.bb/category/business/stock-exchange/">Stock Exchange</a></li><li id="menu-item-157979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157979"><a href="https://www.barbadostoday.bb/category/local-news/telecommunications/">Telecommunications</a></li><li id="menu-item-157972" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157972"><a href="https://www.barbadostoday.bb/category/business/tourism/">Tourism</a></li></ul></li><li id="menu-item-158027" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-158027"><a href="https://www.barbadostoday.bb/category/leisure/entertainment/">Entertainment</a><ul  class="sub-menu"><li id="menu-item-158029" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158029"><a href="https://www.barbadostoday.bb/category/leisure/entertainment/music/">Music</a></li><li id="menu-item-158005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-158005"><a href="https://www.barbadostoday.bb/category/leisure/cropover/">Crop Over</a><ul  class="sub-menu"><li id="menu-item-158010" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158010"><a href="https://www.barbadostoday.bb/category/leisure/cropover/kadooment-day/">Kadooment Day</a></li><li id="menu-item-158006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158006"><a href="https://www.barbadostoday.bb/category/leisure/cropover/foreday-mornin/">Foreday Mornin&#8217;</a></li><li id="menu-item-158009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158009"><a href="https://www.barbadostoday.bb/category/leisure/cropover/pic-o-de-crop/">Pic-O-De-Crop</a></li><li id="menu-item-158007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158007"><a href="https://www.barbadostoday.bb/category/leisure/cropover/junior-kadooment/">Junior Kadooment</a></li><li id="menu-item-158008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158008"><a href="https://www.barbadostoday.bb/category/leisure/cropover/junior-monarch/">Junior Monarch</a></li></ul></li><li id="menu-item-157945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157945"><a href="https://www.barbadostoday.bb/category/leisure/">Leisure</a><ul  class="sub-menu"><li id="menu-item-158002" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158002"><a href="https://www.barbadostoday.bb/category/lifestyle/recipes/">Recipes</a></li></ul></li><li id="menu-item-158028" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158028"><a href="https://www.barbadostoday.bb/category/lifestyle/">Lifestyle</a></li></ul></li><li id="menu-item-157946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157946"><a href="https://www.barbadostoday.bb/category/politics/">Politics</a><ul  class="sub-menu"><li id="menu-item-157981" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157981"><a href="https://www.barbadostoday.bb/category/politics/house-of-assembly/">House of Assembly</a></li><li id="menu-item-157980" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157980"><a href="https://www.barbadostoday.bb/category/politics/senate/">Senate</a></li><li id="menu-item-157982" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157982"><a href="https://www.barbadostoday.bb/category/politics/elections-2013/">Elections 2013</a></li></ul></li><li id="menu-item-157942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157942"><a href="https://www.barbadostoday.bb/category/regional/">Regional</a><ul  class="sub-menu"><li id="menu-item-157997" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157997"><a href="https://www.barbadostoday.bb/category/regional/bahamas/">Bahamas</a></li><li id="menu-item-157996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157996"><a href="https://www.barbadostoday.bb/category/regional/ccj/">CCJ</a></li><li id="menu-item-157985" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157985"><a href="https://www.barbadostoday.bb/category/regional/grenada/">Grenada</a></li><li id="menu-item-157986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157986"><a href="https://www.barbadostoday.bb/category/regional/haiti/">Haiti</a></li><li id="menu-item-157998" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157998"><a href="https://www.barbadostoday.bb/category/regional/liat/">LIAT</a></li><li id="menu-item-157988" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157988"><a href="https://www.barbadostoday.bb/category/regional/st-kitts-nevis/">St Kitts &#038; Nevis</a></li><li id="menu-item-157989" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157989"><a href="https://www.barbadostoday.bb/category/regional/st-lucia/">St Lucia</a></li><li id="menu-item-157990" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157990"><a href="https://www.barbadostoday.bb/category/regional/st-vincent/">St Vincent</a></li><li id="menu-item-157991" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157991"><a href="https://www.barbadostoday.bb/category/regional/trinidad-and-tobago/">Trinidad &#038; Tobago</a></li><li id="menu-item-157992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157992"><a href="https://www.barbadostoday.bb/category/regional/uwi/">UWI</a></li></ul></li><li id="menu-item-157943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157943"><a href="https://www.barbadostoday.bb/category/world/">World</a><ul  class="sub-menu"><li id="menu-item-158011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158011"><a href="https://www.barbadostoday.bb/category/world/africa/">Africa</a></li><li id="menu-item-158012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158012"><a href="https://www.barbadostoday.bb/category/world/asia/">Asia</a></li><li id="menu-item-158013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158013"><a href="https://www.barbadostoday.bb/category/world/australia/">Australia</a></li><li id="menu-item-158014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158014"><a href="https://www.barbadostoday.bb/category/world/canada/">Canada</a></li><li id="menu-item-158015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158015"><a href="https://www.barbadostoday.bb/category/world/europe/">Europe</a></li><li id="menu-item-158016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158016"><a href="https://www.barbadostoday.bb/category/world/india/">India</a></li><li id="menu-item-158017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158017"><a href="https://www.barbadostoday.bb/category/world/latin-america/">Latin America</a></li><li id="menu-item-158018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158018"><a href="https://www.barbadostoday.bb/category/world/middle-east/">Middle East</a></li><li id="menu-item-158019" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158019"><a href="https://www.barbadostoday.bb/category/world/uk/">United Kingdom</a></li><li id="menu-item-158020" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158020"><a href="https://www.barbadostoday.bb/category/world/usa/">USA</a></li></ul></li></ul><div class="clear"></div></div><div id="submenu"><ul class="subnav dropdown"><li id="menu-item-84876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84876"><a href="https://www.barbadostoday.bb/gallery-cats/news-updates/">Video News</a></li><li id="menu-item-84877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84877"><a href="https://www.barbadostoday.bb/gallery-cats/entertainment-weekly/">Entertainment Weekly</a></li><li id="menu-item-84878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84878"><a href="https://www.barbadostoday.bb/gallery-cats/business-minute/">Business Minute</a></li><li id="menu-item-21347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21347"><a href="https://www.barbadostoday.bb/category/editorial/">Editorial</a></li><li id="menu-item-6520" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6520"><a href="https://www.barbadostoday.bb/category/column/">Columns</a></li><li id="menu-item-21349" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21349"><a href="https://www.barbadostoday.bb/category/letters/">Letters</a></li><li class="date right"> <script type="text/javascript">/*<![CDATA[*/var mydate=new Date()
						var year=mydate.getYear()
						if (year < 1000)
						year+=1900
						var day=mydate.getDay()
						var month=mydate.getMonth()
						var daym=mydate.getDate()
						if (daym<10)
						daym="0"+daym
						var dayarray=new Array("Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday")
						var montharray=new Array("January","February","March","April","May","June","July","August","September","October","November","December")
						document.write(""+dayarray[day]+", "+montharray[month]+" "+daym+", "+year+"")/*]]>*/</script> </li></ul><div class="clear"></div></div><div id="container"><div id="content"><div id="post-204696" class="entry single-default post-204696 post type-post status-publish format-standard has-post-thumbnail hentry category-cricket category-sports"><h1 class="entry_title"> &#8216;Due process not followed&#8217;</h1><div class="single_postmeta"> <span class="left"> Added by <a href="https://www.barbadostoday.bb/author/bteditor/">Barbados Today</a> on June 23, 2017.<br />Saved under <a href="https://www.barbadostoday.bb/category/sports/cricket/" rel="category tag">Cricket</a>, <a href="https://www.barbadostoday.bb/category/sports/" rel="category tag">Sports</a><br /> </span> <span class="right"><div id="text-11" class="widget widget_text"><div class="widgetinner"><div class="textwidget"><div class="wpsso-ssb wpsso-ssb-shortcode"><div class="ssb-buttons en_US"><div class="fb-like facebook-ssb-shortcode" id="facebook-button-post-204696"><fb:like href="https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/" send="true" layout="button_count" show_faces="false" font="arial" colorscheme="light" action="like"></fb:like></div><div class="gplusone-ssb-shortcode" id="gplusone-button-post-204696"><span class="g-plusone" data-size="medium" data-annotation="bubble" data-href="https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/"></span></div><div class="pinterest-ssb-shortcode" id="pinterest-button-post-204696"><a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.barbadostoday.bb%2F2017%2F06%2F23%2Fdue-process-not-followed%2F&amp;media=https%3A%2F%2F16f6e5e6d2.site.internapcdn.net%2Fwp-content%2Fuploads%2F2017%2F06%2FDarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies..jpg&amp;description=Embattled%20West%20Indies%20left-hander%20Darren%20Bravo%20has%20accused%20Cricket%20West%20Indies%20of%20not%20affording%20him%20due%20process%2C%20in%20the%20decision%20to%20axe%20him%20from%20the%20Tri-Series%20tour%20of%20Zimbabwe%20last%20November.%20Breaking..." data-pin-do="buttonPin" data-pin-zero="true" data-pin-lang="en" data-pin-shape="rect" data-pin-color="gray" data-pin-height="20" data-pin-config="beside"><img border="0" alt="Pin It" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" width="40" height="20" /><noscript><img border="0" alt="Pin It" src="https://assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" width="40" height="20" /></noscript></a></div><div class="twitter-ssb-shortcode" id="twitter-button-post-204696"><a href="https://twitter.com/share" class="twitter-share-button" data-lang="en" data-url="https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/" data-counturl="https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/" data-text="&lsquo;Due process not followed&rsquo;" data-via="barbadostoday" data-related="" data-hashtags="" data-size="medium" data-dnt="true"></a></div></div></div> <script type="text/javascript" id="pinterest-script-shortcode-footer">wpsso_insert_js( "pinterest-script-shortcode-footer", "https://assets.pinterest.com/js/pinit.js" );</script> </div></div></div> </span><div class="clear"></div></div><div class="wpsso-schema-image-for-pinterest" style="display:none;"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies..jpg" width="0" height="0" style="width:0;height:0;" data-pin-description="Embattled West Indies left-hander Darren Bravo has accused Cricket West Indies of not affording him due process, in the decision to axe him from the Tri-Series tour of Zimbabwe last November. Breaking..."/><noscript><img src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies..jpg" width="0" height="0" style="width:0;height:0;" data-pin-description="Embattled West Indies left-hander Darren Bravo has accused Cricket West Indies of not affording him due process, in the decision to axe him from the Tri-Series tour of Zimbabwe last November. Breaking..."/></noscript></div><p>Embattled West Indies left-hander Darren Bravo has accused Cricket West Indies of not affording him due process, in the decision to axe him from the Tri-Series tour of Zimbabwe last November.</p><p>Breaking his silence for the first time since the controversy erupted eight months ago, the 28-year-old said CWI&#8217;s only communication with him was to indicate that his contract had been terminated and to inform him of flight details home.</p><p>He said no CWI official had sought to engage him on the matter and he found this particularly disappointing since in the past he had committed his future to West Indies cricket.<br /> &#8220;Even though you saw a tweet on my <strong>Twitter</strong> account, no one actually asked me if I did that,&#8221; Bravo told Massy United Insurance&#8217;s Line &amp; Length Network in an exclusive interview set to be aired this weekend.</p><p>&#8220;I went to sleep the day after the tweet, woke up at 6:30 a.m. trying to get myself ready to head to Zimbabwe for the Tri-Series and all of a sudden I saw two emails &#8211; one from Roland Holder (CWI cricket operations manager) and one from Richard Pybus (former CWI director of cricket) stating that my contract has been terminated and I was being sent home.</p><p>&#8220;The other email was from Roland Holder with my flight details but no one actually asked me anything.&#8221;</p><p>He continued: &#8220;I was also given an ultimatum, after being sent home, to take down the tweet by 4 p.m. and apologise on twitter but at the end of the day no one can prove if Darren Bravo actually went on his Twitter account and tweeted that.</p><p>&#8220;There was no due process, there wasn&#8217;t anything. No one asked me anything. Up to this day, no one called me and asked me so it has been very disappointing.</p><p>&#8220;Yes I want to play cricket for West Indies again but at the end of the day when I step back onto the field, I want to be able to be happy, I want to be able to enjoy my cricket once more and that is probably something I have been lacking for the last year playing for West Indies.&#8221;</p><p>The impasse arose last November after Bravo rejected a downgraded central contract from CWI and president Dave Cameron subsequently said in a television interview that the player had not merited an enhanced retainer because of his &#8220;declining averages&#8221;.</p><p>Cameron mistakenly inferred that Bravo had previous held a Grade A contract prompting a Twitter rant from the Trinidadian in which he labelled the Jamaican administrator &#8220;a big idiot&#8221;.</p><p>Barbadian lawyer Donna Symmonds, a member of Bravo&#8217;s legal team, said her client&#8217;s rights had been breached and said subsequent attempts to negotiate with CWI had ended in frustration.</p><p>&#8220;Darren had no due process. As far as we are concerned his contractual rights were breached. There has been a rush to judgement, there has been action taken,&#8221; she contended.</p><p>&#8220;We have tried to negotiate this matter with them [Cricket West Indies] &#8230; we had actually come to an understanding about a number of things where both sides could say they have resolved and reached an area or position where they could live with it and Darren could be reintegrated into the West Indies team.</p><p>&#8220;Then something happened &#8211; I would have to say a breach of good faith &#8211; and it caused the negotiations to break down so we&#8217;re no longer there. But at this stage we&#8217;re not going to be making any comment on that part (removal of the tweet) because due process has not been given and Darren has not had the chance to put his case to anyone.&#8221;</p><p>Since being sent home from the tour, Bravo has been barred from taking part in domestic cricket and only last week, his presence for Trinidad and Tobago in a practice match against West Indies, reportedly drew protests from CWI.</p><p>Last week, Cameron said that Bravo would remain ignored for selection until the offending tweet was removed but Symmonds, questioned the basis for the &#8220;continued ban&#8221;.</p><p>&#8220;Up to now, Cricket West Indies has not explained their authority for this continued ban,&#8221; Symmonds argued.</p><p>&#8220;They terminated Darren&#8217;s contract, they punished him by doing that for what they perceived to be a breach by him and yet this ban continues and up to now we have not been told the authority by which they are doing this.</p><p>&#8220;He&#8217;s not even been informed. He only hears if he&#8217;s picked to play a game and then he&#8217;s told he can&#8217;t play because Cricket West Indies says you can&#8217;t play. They have never even engaged Darren directly or his lawyers directly to say &#8216;this is why we are doing this and it is for X, Y period. We hear &#8230; via the media.&#8221;</p><p>Bravo is West Indies&#8217; premier Test batsman, with 3400 runs from 49 Tests at an average of 40, including eight centuries and 16 half-centuries.</p><div class="wpsso-ssb wpsso-ssb-content"><div class="ssb-buttons en_US"><div class="css-button email-button"> <a href="mailto:?subject=Share:%20%26%238216%3BDue%20process%20not%20followed%26%238217%3B&body=Embattled%20West%20Indies%20left-hander%20Darren%20Bravo%20has%20accused%20Cricket%20West%20Indies%20of%20not%20affording%20him%20due%20process%2C%20in%20the%20decision%20to%20axe%20him%20from%20the%20Tri-Series%20tour%20of%20Zimbabwe%20last%20November.%20Breaking...%0D%0A%0D%0AShared%20from%20https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/%0D%0A"> <span class="ssb-icon"> <svg xmlns="http://www.w3.org/2000/svg" width="9" height="9" viewBox="0 0 28 28"> <path d="M20.11 26.147c-2.335 1.05-4.36 1.4-7.124 1.4C6.524 27.548.84 22.916.84 15.284.84 7.343 6.602.45 15.4.45c6.854 0 11.8 4.7 11.8 11.252 0 5.684-3.193 9.265-7.398 9.3-1.83 0-3.153-.934-3.347-2.997h-.077c-1.208 1.986-2.96 2.997-5.023 2.997-2.532 0-4.36-1.868-4.36-5.062 0-4.75 3.503-9.07 9.11-9.07 1.713 0 3.7.4 4.6.972l-1.17 7.203c-.387 2.298-.115 3.3 1 3.4 1.674 0 3.774-2.102 3.774-6.58 0-5.06-3.27-8.994-9.304-8.994C9.05 2.87 3.83 7.545 3.83 14.97c0 6.5 4.2 10.2 10 10.202 1.987 0 4.09-.43 5.647-1.245l.634 2.22zM16.647 10.1c-.31-.078-.7-.155-1.207-.155-2.572 0-4.596 2.53-4.596 5.53 0 1.5.7 2.4 1.9 2.4 1.44 0 2.96-1.83 3.31-4.088l.592-3.72z" /> </svg> </span> <span class="ssb-text"></span> </a></div><div class="twitter-button" id="twitter-ssb-content-post-204696"><a href="https://twitter.com/share" class="twitter-share-button" data-lang="en" data-url="https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/" data-counturl="https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/" data-text="&lsquo;Due process not followed&rsquo;" data-via="barbadostoday" data-related="" data-hashtags="" data-size="medium" data-dnt="true"></a></div><div class="fb-like facebook-button" id="facebook-ssb-content-post-204696"><fb:like href="https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/" send="true" layout="button_count" show_faces="false" font="arial" colorscheme="light" action="like"></fb:like></div><div class="gplusone-button" id="gplusone-ssb-content-post-204696"><span class="g-plusone" data-size="medium" data-annotation="bubble" data-href="https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/"></span></div><div class="linkedin-button" id="linkedin-ssb-content-post-204696"><script type="IN/Share" data-url="https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/" data-counter="right" data-showzero="true"></script></div></div></div><div class="postcredit"><strong>Source</strong>: (CMC)</div><div class="clear"></div></div><div id="comments"><h3 id="comments-title"> 6 Responses to <em>&#8216;Due process not followed&#8217;</em></h3><ol class="commentlist"><li class="comment even thread-even depth-1" id="li-comment-171262"><div class="comment-inner" id="comment-171262"><div class="comment-top"><div class="comment-avatar"> <img alt='Angus Benn' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/210250762689314/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Angus Benn' src='https://graph.facebook.com/v2.3/210250762689314/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/210250762689314' rel='external nofollow' class='url'>Angus Benn</a></cite> June 23, 2017 at 6:27 am</div></div><p>Why we black people like to followed so much. I know about cricket Australia. Now it&#8217;s cricket westindies. I will never call it cricket westindies. I think Bravo should take down the tweet. Although he is a big Idiot. As a the CEO of the westindies team he should come with  proof before he talk.</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/?replytocom=171262#respond' onclick='return addComment.moveForm( "comment-171262", "171262", "respond", "204696" )' aria-label='Reply to Angus Benn'>Reply</a></span></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="li-comment-171293"><div class="comment-inner" id="comment-171293"><div class="comment-top"><div class="comment-avatar"> <img alt='Ali Baba' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/129578780867041/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Ali Baba' src='https://graph.facebook.com/v2.3/129578780867041/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/129578780867041' rel='external nofollow' class='url'>Ali Baba</a></cite> June 23, 2017 at 7:59 am</div></div><p>MR BRAVO U AINT JUST GET AH 70,000.00 USD CONTRACT IN THE IPL? ALONG WID OTHER PERK?&#8230;TELL cameron&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/?replytocom=171293#respond' onclick='return addComment.moveForm( "comment-171293", "171293", "respond", "204696" )' aria-label='Reply to Ali Baba'>Reply</a></span></div></li><li class="comment even thread-even depth-1" id="li-comment-171286"><div class="comment-inner" id="comment-171286"><div class="comment-top"><div class="comment-avatar"> <img alt='' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://secure.gravatar.com/avatar/4d0e916c8815c56f80edd109db41ebfc?s=40&#038;d=mm&#038;r=g' data-lazy-srcset='https://secure.gravatar.com/avatar/4d0e916c8815c56f80edd109db41ebfc?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /><noscript><img alt='' src='https://secure.gravatar.com/avatar/4d0e916c8815c56f80edd109db41ebfc?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/4d0e916c8815c56f80edd109db41ebfc?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn">Alex Alleyne</cite> June 23, 2017 at 8:00 am</div></div><p>Bravo just found out that he is a &#8220;small fish&#8221; and should not swim in big fish waters. He try to follow the &#8220;rude boy posse&#8221; and got left out on a limb to dry.<br /> Simple , a small idiot calling out to a big idiot.<br /> LIL FISH BRAVO, TELL THE WORLD WHO IS HURTING NOW.</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/?replytocom=171286#respond' onclick='return addComment.moveForm( "comment-171286", "171286", "respond", "204696" )' aria-label='Reply to Alex Alleyne'>Reply</a></span></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="li-comment-171287"><div class="comment-inner" id="comment-171287"><div class="comment-top"><div class="comment-avatar"> <img alt='' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://secure.gravatar.com/avatar/f40d7c4bd3513e0bce55c1c3b34f1d74?s=40&#038;d=mm&#038;r=g' data-lazy-srcset='https://secure.gravatar.com/avatar/f40d7c4bd3513e0bce55c1c3b34f1d74?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /><noscript><img alt='' src='https://secure.gravatar.com/avatar/f40d7c4bd3513e0bce55c1c3b34f1d74?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f40d7c4bd3513e0bce55c1c3b34f1d74?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn">KS</cite> June 23, 2017 at 8:04 am</div></div><p>Maybe the CEO is a &#8220;big idiot&#8221; as Mr. Bravo tweeted but he did the &#8216;right ting&#8217; &#8230;.. too many of our cricketers reach a stage where they believe they have &#8216;arrived&#8217; &amp; the team can&#8217;t do without them&#8230;&#8230; wake up guys, lots of young talent waiting in the wings&#8230;.they only need a chance &#8230;.. did Pakistan not just &#8216;discover&#8217; a 19-year old match winner? Maybe we have a few in the wings!!</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/?replytocom=171287#respond' onclick='return addComment.moveForm( "comment-171287", "171287", "respond", "204696" )' aria-label='Reply to KS'>Reply</a></span></div></li><li class="comment even thread-even depth-1" id="li-comment-171318"><div class="comment-inner" id="comment-171318"><div class="comment-top"><div class="comment-avatar"> <img alt='' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://secure.gravatar.com/avatar/db6936c51281c9e8fbfbdcc7ad8cab76?s=40&#038;d=mm&#038;r=g' data-lazy-srcset='https://secure.gravatar.com/avatar/db6936c51281c9e8fbfbdcc7ad8cab76?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /><noscript><img alt='' src='https://secure.gravatar.com/avatar/db6936c51281c9e8fbfbdcc7ad8cab76?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/db6936c51281c9e8fbfbdcc7ad8cab76?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn">Leroy</cite> June 23, 2017 at 9:07 am</div></div><p>Is there no one around Bravo to tell him he is acting immature?</p><p>Bravo take down the damn tweet and apologize and go play cricket for WI or leave up the tweet and play cricket elsewhere and stop the back and forth, ya aint getting no younger fool.</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/?replytocom=171318#respond' onclick='return addComment.moveForm( "comment-171318", "171318", "respond", "204696" )' aria-label='Reply to Leroy'>Reply</a></span></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="li-comment-171320"><div class="comment-inner" id="comment-171320"><div class="comment-top"><div class="comment-avatar"> <img alt='' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://secure.gravatar.com/avatar/f4aac65cb13db34f821bab4ea766ee76?s=40&#038;d=mm&#038;r=g' data-lazy-srcset='https://secure.gravatar.com/avatar/f4aac65cb13db34f821bab4ea766ee76?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /><noscript><img alt='' src='https://secure.gravatar.com/avatar/f4aac65cb13db34f821bab4ea766ee76?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f4aac65cb13db34f821bab4ea766ee76?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn">orlando</cite> June 23, 2017 at 9:27 am</div></div><p>mr. Bravo is saying that the tweet maynot  be of his doing  lol. so he is not taking it down till cwi talk to him.BOY stop letting donna simmons and co. take your money while giving you some very bad advice. we the cricketing public need you in west indies cricket,  like alex say you are a small idiot fish in a big idiot pond . and angus benn even if you dont call it cwi it will still be cwi. floyd patterson didnt want to call ali  ALI but in the end it was still ALI.</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/?replytocom=171320#respond' onclick='return addComment.moveForm( "comment-171320", "171320", "respond", "204696" )' aria-label='Reply to orlando'>Reply</a></span></div></li></ol><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/06/23/due-process-not-followed/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.barbadostoday.bb/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p> <script>document.write(String.fromCharCode(60,105,110,112,117,116,32,116,121,112,101,61,104,105,100,100,101,110,32,110,97,109,101,61,34,90,109,78,115,55,73,56,104,34,32,118,97,108,117,101,61,34,49,54,57,51,58,98,98,48,49,55,102,52,48,53,101,97,99,52,98,49,55,52,100,101,56,51,57,48,57,102,57,102,48,56,97,97,57,98,53,52,55,48,51,55,55,34,62));</script><noscript><strong><font color=red>Please enable JavaScript</font></strong></noscript><div style="display:none;"><input type="text" name="Wuu2y" value="" /></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='204696' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2eb00cd5ac" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="183"/></p></form></div></div></div><div id="sidebar"><div class="sidebarinner"><div class="widget"> <script>broadstreet.zone(50041);</script> <br> <br> <script>broadstreet.zone(51631);</script></div><div id="popular-widget-5" class="widget popular-widget"><div class="widgetinner"><h3 class="widgettitle">Popular (Last 7 Days)</h3><div class="pop-layout-v"><ul id="pop-widget-tabs-5" class="pop-widget-tabs pop-widget-tabs-3" ><li><a href="#recent" rel="nofollow">Recent Posts</a></li><li><a href="#commented" rel="nofollow">Most Commented</a></li><li><a href="#viewed" rel="nofollow">Most Viewed</a></li></ul><div class="pop-inside-5 pop-inside"><ul id="pop-widget-recent-5"><li><a href="https://www.barbadostoday.bb/2017/06/23/a-plea-for-the-oppressed-american-people/" title="A plea for the oppressed American People" rel="bookmark"><img width="940" height="460" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0.jpg 940w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0-650x318.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0-768x376.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0-160x78.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0-305x150.jpg 305w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0-640x313.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0-800x391.jpg 800w" data-lazy-sizes="(max-width: 940px) 100vw, 940px" data-wp-pid="202783" nopin="nopin" /><noscript><img width="940" height="460" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0.jpg 940w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0-650x318.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0-768x376.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0-160x78.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0-305x150.jpg 305w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0-640x313.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/donald_trump_gi_0-800x391.jpg 800w" sizes="(max-width: 940px) 100vw, 940px" data-wp-pid="202783" nopin="nopin" /></noscript><span class="pop-overlay"><span class="pop-title">A plea for the oppressed American People</span> <span class="pop-summary">“Last year I promised to be a voice against repression…and...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/06/23/a-need-to-restore-balance/" title="A need to restore balance" rel="bookmark"><span class="pop-overlay"><span class="pop-title">A need to restore balance</span> <span class="pop-summary">Permit me to offer some reflections on three areas which...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/06/23/grenfell-tower-fire-started-in-hotpoint-fridge-freezer-say-police/" title="Grenfell Tower: Fire started in Hotpoint fridge freezer, say police" rel="bookmark"><img width="660" height="371" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/grenfell.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/grenfell.jpg 660w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/grenfell-650x365.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/grenfell-160x90.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/grenfell-480x270.jpg 480w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/grenfell-640x360.jpg 640w" data-lazy-sizes="(max-width: 660px) 100vw, 660px" data-wp-pid="204719" nopin="nopin" /><noscript><img width="660" height="371" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/grenfell.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/grenfell.jpg 660w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/grenfell-650x365.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/grenfell-160x90.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/grenfell-480x270.jpg 480w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/grenfell-640x360.jpg 640w" sizes="(max-width: 660px) 100vw, 660px" data-wp-pid="204719" nopin="nopin" /></noscript><span class="pop-overlay"><span class="pop-title">Grenfell Tower: Fire started in Hotpoint fridge freezer, say police</span> <span class="pop-summary">The Grenfell Tower fire in London started in a fridge...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/06/23/due-process-not-followed/" title="&#039;Due process not followed&#039;" rel="bookmark"><img width="700" height="400" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies..jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies..jpg 700w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies.-650x371.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies.-160x91.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies.-640x366.jpg 640w" data-lazy-sizes="(max-width: 700px) 100vw, 700px" data-wp-pid="204290" nopin="nopin" /><noscript><img width="700" height="400" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies..jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies..jpg 700w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies.-650x371.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies.-160x91.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/DarrenXBravoXwasXscheduledXtoXplayXinXtheXpracticeXmatchXagainstXtheXWestXIndies.-640x366.jpg 640w" sizes="(max-width: 700px) 100vw, 700px" data-wp-pid="204290" nopin="nopin" /></noscript><span class="pop-overlay"><span class="pop-title">'Due process not followed'</span> <span class="pop-summary">Embattled West Indies left-hander Darren Bravo has accused Cricket West...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/06/23/suspended-sentence-for-cocaine-apparatus/" title="Suspended sentence for cocaine apparatus" rel="bookmark"><img width="50" height="50" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/06/CourtXTodayXwithXFern-01-50x50.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/06/CourtXTodayXwithXFern-01-50x50.png 50w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/06/CourtXTodayXwithXFern-01-150x150.png 150w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/06/CourtXTodayXwithXFern-01-30x30.png 30w" data-lazy-sizes="(max-width: 50px) 100vw, 50px" data-wp-pid="162786" nopin="nopin" /><noscript><img width="50" height="50" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/06/CourtXTodayXwithXFern-01-50x50.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/06/CourtXTodayXwithXFern-01-50x50.png 50w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/06/CourtXTodayXwithXFern-01-150x150.png 150w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/06/CourtXTodayXwithXFern-01-30x30.png 30w" sizes="(max-width: 50px) 100vw, 50px" data-wp-pid="162786" nopin="nopin" /></noscript><span class="pop-overlay"><span class="pop-title">Suspended sentence for cocaine apparatus</span> <span class="pop-summary">A Bridgetown magistrate recently imposed a six-month suspended sentence on...</span></span></a><br class="pop-cl" /></li></ul><ul id="pop-widget-commented-5"><li><a href="https://www.barbadostoday.bb/2017/06/19/kicked-down/" title="Kicked down" rel="bookmark"><img width="900" height="400" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-650x289.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-768x341.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-160x71.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-640x284.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-800x356.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="204334" nopin="nopin" /><noscript><img width="900" height="400" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-650x289.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-768x341.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-160x71.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-640x284.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-800x356.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="204334" nopin="nopin" /></noscript><span class="pop-overlay"><span class="pop-title">Kicked down</span> <span class="pop-summary">The reputation of the Royal Barbados Police Force (RBPF) is...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/06/17/dog-owner-charged-with-manslaughter/" title="Dog owner charged with manslaughter" rel="bookmark"><img width="1600" height="900" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004.jpg 1600w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-650x366.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-768x432.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-960x540.jpg 960w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-160x90.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-480x270.jpg 480w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-640x360.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-800x450.jpg 800w" data-lazy-sizes="(max-width: 1600px) 100vw, 1600px" data-wp-pid="188667" nopin="nopin" /><noscript><img width="1600" height="900" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004.jpg 1600w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-650x366.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-768x432.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-960x540.jpg 960w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-160x90.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-480x270.jpg 480w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-640x360.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-800x450.jpg 800w" sizes="(max-width: 1600px) 100vw, 1600px" data-wp-pid="188667" nopin="nopin" /></noscript><span class="pop-overlay"><span class="pop-title">Dog owner charged with manslaughter</span> <span class="pop-summary">A 48-year-old dog owner has been arrested and charged with...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/06/19/police-shut-down-waiki-jam/" title="Police shut down Waiki jam" rel="bookmark"><img width="750" height="414" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1.jpg 750w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-650x359.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-93x50.jpg 93w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-160x88.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-225x123.jpg 225w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-640x353.jpg 640w" data-lazy-sizes="(max-width: 750px) 100vw, 750px" data-wp-pid="204210" nopin="nopin" /><noscript><img width="750" height="414" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1.jpg 750w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-650x359.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-93x50.jpg 93w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-160x88.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-225x123.jpg 225w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-640x353.jpg 640w" sizes="(max-width: 750px) 100vw, 750px" data-wp-pid="204210" nopin="nopin" /></noscript><span class="pop-overlay"><span class="pop-title">Police shut down Waiki jam</span> <span class="pop-summary">Task Force officers were called in to restore order at...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/06/17/barbadians-urged-to-quench-their-appetite-for-foreign-foods/" title="Barbadians urged to quench their appetite for foreign foods" rel="bookmark"><img width="640" height="480" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/unnamed-27.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/unnamed-27.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/unnamed-27-80x60.jpg 80w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/unnamed-27-118x88.jpg 118w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/unnamed-27-160x120.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/unnamed-27-600x450.jpg 600w" data-lazy-sizes="(max-width: 640px) 100vw, 640px" data-wp-pid="204171" nopin="nopin" /><noscript><img width="640" height="480" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/unnamed-27.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/unnamed-27.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/unnamed-27-80x60.jpg 80w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/unnamed-27-118x88.jpg 118w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/unnamed-27-160x120.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/unnamed-27-600x450.jpg 600w" sizes="(max-width: 640px) 100vw, 640px" data-wp-pid="204171" nopin="nopin" /></noscript><span class="pop-overlay"><span class="pop-title">Barbadians urged to quench their appetite for foreign foods</span> <span class="pop-summary">Minister of Sports, Youth and Culture Stephen Lashley believes Barbadians...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/06/17/bravo-sidelined-unless-tweet-goes-says-cameron/" title="Bravo sidelined unless tweet goes, says Cameron" rel="bookmark"><img width="50" height="50" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2015/08/WICBXpresidentXDaveXCameron-e1473552776133-50x50.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2015/08/WICBXpresidentXDaveXCameron-e1473552776133-50x50.jpg 50w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2015/08/WICBXpresidentXDaveXCameron-e1473552776133-150x150.jpg 150w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2015/08/WICBXpresidentXDaveXCameron-e1473552776133-30x30.jpg 30w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2015/08/WICBXpresidentXDaveXCameron-e1473552776133-600x600.jpg 600w" data-lazy-sizes="(max-width: 50px) 100vw, 50px" data-wp-pid="134743" nopin="nopin" /><noscript><img width="50" height="50" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2015/08/WICBXpresidentXDaveXCameron-e1473552776133-50x50.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2015/08/WICBXpresidentXDaveXCameron-e1473552776133-50x50.jpg 50w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2015/08/WICBXpresidentXDaveXCameron-e1473552776133-150x150.jpg 150w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2015/08/WICBXpresidentXDaveXCameron-e1473552776133-30x30.jpg 30w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2015/08/WICBXpresidentXDaveXCameron-e1473552776133-600x600.jpg 600w" sizes="(max-width: 50px) 100vw, 50px" data-wp-pid="134743" nopin="nopin" /></noscript><span class="pop-overlay"><span class="pop-title">Bravo sidelined unless tweet goes, says Cameron</span> <span class="pop-summary">BRIDGETOWN, Barbados, CMC – Cricket West Indies (CWI) president Dave...</span></span></a><br class="pop-cl" /></li></ul><ul id="pop-widget-viewed-5"><li><a href="https://www.barbadostoday.bb/2017/06/18/severe-weather-alert-for-barbados/" title="Severe weather alert for Barbados" rel="bookmark"><img width="50" height="50" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/07/WeatherGraphic-50x50.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/07/WeatherGraphic-50x50.jpg 50w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/07/WeatherGraphic-150x150.jpg 150w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/07/WeatherGraphic-30x30.jpg 30w" data-lazy-sizes="(max-width: 50px) 100vw, 50px" data-wp-pid="165949" nopin="nopin" /><noscript><img width="50" height="50" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/07/WeatherGraphic-50x50.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/07/WeatherGraphic-50x50.jpg 50w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/07/WeatherGraphic-150x150.jpg 150w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/07/WeatherGraphic-30x30.jpg 30w" sizes="(max-width: 50px) 100vw, 50px" data-wp-pid="165949" nopin="nopin" /></noscript><span class="pop-overlay"><span class="pop-title">Severe weather alert for Barbados</span> <span class="pop-summary">The Barbados Met Office says an approaching tropical wave is...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/06/19/police-shut-down-waiki-jam/" title="Police shut down Waiki jam" rel="bookmark"><img width="750" height="414" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1.jpg 750w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-650x359.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-93x50.jpg 93w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-160x88.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-225x123.jpg 225w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-640x353.jpg 640w" data-lazy-sizes="(max-width: 750px) 100vw, 750px" data-wp-pid="204210" nopin="nopin" /><noscript><img width="750" height="414" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1.jpg 750w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-650x359.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-93x50.jpg 93w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-160x88.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-225x123.jpg 225w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/IMG_6121-1-640x353.jpg 640w" sizes="(max-width: 750px) 100vw, 750px" data-wp-pid="204210" nopin="nopin" /></noscript><span class="pop-overlay"><span class="pop-title">Police shut down Waiki jam</span> <span class="pop-summary">Task Force officers were called in to restore order at...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/06/17/dog-owner-charged-with-manslaughter/" title="Dog owner charged with manslaughter" rel="bookmark"><img width="1600" height="900" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004.jpg 1600w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-650x366.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-768x432.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-960x540.jpg 960w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-160x90.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-480x270.jpg 480w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-640x360.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-800x450.jpg 800w" data-lazy-sizes="(max-width: 1600px) 100vw, 1600px" data-wp-pid="188667" nopin="nopin" /><noscript><img width="1600" height="900" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004.jpg 1600w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-650x366.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-768x432.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-960x540.jpg 960w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-160x90.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-480x270.jpg 480w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-640x360.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/01/IMG-20170128-WA0004-800x450.jpg 800w" sizes="(max-width: 1600px) 100vw, 1600px" data-wp-pid="188667" nopin="nopin" /></noscript><span class="pop-overlay"><span class="pop-title">Dog owner charged with manslaughter</span> <span class="pop-summary">A 48-year-old dog owner has been arrested and charged with...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/06/19/kicked-down/" title="Kicked down" rel="bookmark"><img width="900" height="400" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-650x289.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-768x341.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-160x71.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-640x284.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-800x356.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="204334" nopin="nopin" /><noscript><img width="900" height="400" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-650x289.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-768x341.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-160x71.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-640x284.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/20170619_145219Xcopy-800x356.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="204334" nopin="nopin" /></noscript><span class="pop-overlay"><span class="pop-title">Kicked down</span> <span class="pop-summary">The reputation of the Royal Barbados Police Force (RBPF) is...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/06/18/tropical-storm-warning-issued-for-barbados/" title="Tropical storm warning issued for Barbados" rel="bookmark"><img width="656" height="369" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/TropicalXStorm5.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/TropicalXStorm5.jpg 656w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/TropicalXStorm5-650x366.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/TropicalXStorm5-160x90.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/TropicalXStorm5-480x270.jpg 480w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/TropicalXStorm5-640x360.jpg 640w" data-lazy-sizes="(max-width: 656px) 100vw, 656px" data-wp-pid="204199" nopin="nopin" /><noscript><img width="656" height="369" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/TropicalXStorm5.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/TropicalXStorm5.jpg 656w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/TropicalXStorm5-650x366.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/TropicalXStorm5-160x90.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/TropicalXStorm5-480x270.jpg 480w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/06/TropicalXStorm5-640x360.jpg 640w" sizes="(max-width: 656px) 100vw, 656px" data-wp-pid="204199" nopin="nopin" /></noscript><span class="pop-overlay"><span class="pop-title">Tropical storm warning issued for Barbados</span> <span class="pop-summary">Barbados is now under a tropical storm warning.The Met Office...</span></span></a><br class="pop-cl" /></li></ul></div></div></div></div><div id="gabfire_archive_widget-3" class="widget gabfire_archive_widget"><div class="widgetinner"><h3 class="widgettitle">Search in Archive</h3><div style="background:transparent"><form action="https://www.barbadostoday.bb/"  method="get" > <label>Select a Month</label> <select name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'><option value="">Click to Select</option><option value='https://www.barbadostoday.bb/2017/06/'> June 2017</option><option value='https://www.barbadostoday.bb/2017/05/'> May 2017</option><option value='https://www.barbadostoday.bb/2017/04/'> April 2017</option><option value='https://www.barbadostoday.bb/2017/03/'> March 2017</option><option value='https://www.barbadostoday.bb/2017/02/'> February 2017</option><option value='https://www.barbadostoday.bb/2017/01/'> January 2017</option><option value='https://www.barbadostoday.bb/2016/12/'> December 2016</option><option value='https://www.barbadostoday.bb/2016/11/'> November 2016</option><option value='https://www.barbadostoday.bb/2016/10/'> October 2016</option><option value='https://www.barbadostoday.bb/2016/09/'> September 2016</option><option value='https://www.barbadostoday.bb/2016/08/'> August 2016</option><option value='https://www.barbadostoday.bb/2016/07/'> July 2016</option><option value='https://www.barbadostoday.bb/2016/06/'> June 2016</option><option value='https://www.barbadostoday.bb/2016/05/'> May 2016</option><option value='https://www.barbadostoday.bb/2016/04/'> April 2016</option><option value='https://www.barbadostoday.bb/2016/03/'> March 2016</option><option value='https://www.barbadostoday.bb/2016/02/'> February 2016</option><option value='https://www.barbadostoday.bb/2016/01/'> January 2016</option><option value='https://www.barbadostoday.bb/2015/12/'> December 2015</option><option value='https://www.barbadostoday.bb/2015/11/'> November 2015</option><option value='https://www.barbadostoday.bb/2015/10/'> October 2015</option><option value='https://www.barbadostoday.bb/2015/09/'> September 2015</option><option value='https://www.barbadostoday.bb/2015/08/'> August 2015</option><option value='https://www.barbadostoday.bb/2015/07/'> July 2015</option><option value='https://www.barbadostoday.bb/2015/06/'> June 2015</option><option value='https://www.barbadostoday.bb/2015/05/'> May 2015</option><option value='https://www.barbadostoday.bb/2015/04/'> April 2015</option><option value='https://www.barbadostoday.bb/2015/03/'> March 2015</option><option value='https://www.barbadostoday.bb/2015/02/'> February 2015</option><option value='https://www.barbadostoday.bb/2015/01/'> January 2015</option><option value='https://www.barbadostoday.bb/2014/12/'> December 2014</option><option value='https://www.barbadostoday.bb/2014/11/'> November 2014</option><option value='https://www.barbadostoday.bb/2014/10/'> October 2014</option><option value='https://www.barbadostoday.bb/2014/09/'> September 2014</option><option value='https://www.barbadostoday.bb/2014/08/'> August 2014</option><option value='https://www.barbadostoday.bb/2014/07/'> July 2014</option><option value='https://www.barbadostoday.bb/2014/06/'> June 2014</option><option value='https://www.barbadostoday.bb/2014/05/'> May 2014</option><option value='https://www.barbadostoday.bb/2014/04/'> April 2014</option><option value='https://www.barbadostoday.bb/2014/03/'> March 2014</option><option value='https://www.barbadostoday.bb/2014/02/'> February 2014</option><option value='https://www.barbadostoday.bb/2014/01/'> January 2014</option><option value='https://www.barbadostoday.bb/2013/12/'> December 2013</option><option value='https://www.barbadostoday.bb/2013/11/'> November 2013</option><option value='https://www.barbadostoday.bb/2013/10/'> October 2013</option><option value='https://www.barbadostoday.bb/2013/09/'> September 2013</option><option value='https://www.barbadostoday.bb/2013/08/'> August 2013</option><option value='https://www.barbadostoday.bb/2013/07/'> July 2013</option><option value='https://www.barbadostoday.bb/2013/06/'> June 2013</option><option value='https://www.barbadostoday.bb/2013/05/'> May 2013</option><option value='https://www.barbadostoday.bb/2013/04/'> April 2013</option><option value='https://www.barbadostoday.bb/2013/03/'> March 2013</option><option value='https://www.barbadostoday.bb/2013/02/'> February 2013</option><option value='https://www.barbadostoday.bb/2013/01/'> January 2013</option><option value='https://www.barbadostoday.bb/2012/12/'> December 2012</option><option value='https://www.barbadostoday.bb/2012/11/'> November 2012</option><option value='https://www.barbadostoday.bb/2012/10/'> October 2012</option><option value='https://www.barbadostoday.bb/2012/09/'> September 2012</option><option value='https://www.barbadostoday.bb/2012/08/'> August 2012</option><option value='https://www.barbadostoday.bb/2012/07/'> July 2012</option> </select></form><form action="https://www.barbadostoday.bb/"  method="get" > <label>Select a Category</label> <select  name='cat' id='cat' class='postform' ><option value='-1'>Click to Select</option><option class="level-0" value="1166">Baseball</option><option class="level-0" value="91">Business</option><option class="level-1" value="1152">&nbsp;&nbsp;&nbsp;Banking</option><option class="level-1" value="204">&nbsp;&nbsp;&nbsp;Entrepreneurship</option><option class="level-1" value="231">&nbsp;&nbsp;&nbsp;Indus. Relations</option><option class="level-1" value="159">&nbsp;&nbsp;&nbsp;Int&#8217;l Business</option><option class="level-1" value="1124">&nbsp;&nbsp;&nbsp;Real Estate</option><option class="level-1" value="160">&nbsp;&nbsp;&nbsp;Social Partnership</option><option class="level-1" value="161">&nbsp;&nbsp;&nbsp;Stock Exchange</option><option class="level-1" value="162">&nbsp;&nbsp;&nbsp;Tourism</option><option class="level-0" value="1221">CARICOM</option><option class="level-0" value="92">Column</option><option class="level-0" value="1171">Court</option><option class="level-0" value="1234">Cricket</option><option class="level-0" value="1238">Crime</option><option class="level-0" value="1213">Culture</option><option class="level-0" value="1240">Dominica</option><option class="level-0" value="93">Editorial</option><option class="level-0" value="1231">Entertainment</option><option class="level-0" value="1225">Feature</option><option class="level-0" value="96">Features</option><option class="level-0" value="825">Focus</option><option class="level-0" value="1245">Football</option><option class="level-0" value="1226">Global</option><option class="level-0" value="1243">Health</option><option class="level-0" value="1172">Independence Feature</option><option class="level-0" value="1227">International</option><option class="level-0" value="1222">Jamaica</option><option class="level-0" value="94">Leisure</option><option class="level-1" value="192">&nbsp;&nbsp;&nbsp;Crop Over</option><option class="level-2" value="223">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Foreday Mornin&#8217;</option><option class="level-2" value="221">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Junior Kadooment</option><option class="level-2" value="1119">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Junior Monarch</option><option class="level-2" value="220">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Kadooment Day</option><option class="level-2" value="222">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Pic-O-De-Crop</option><option class="level-1" value="107">&nbsp;&nbsp;&nbsp;Entertainment</option><option class="level-2" value="1193">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Music</option><option class="level-1" value="912">&nbsp;&nbsp;&nbsp;NIFCA</option><option class="level-0" value="97">Letters</option><option class="level-0" value="98">Lifestyle</option><option class="level-1" value="179">&nbsp;&nbsp;&nbsp;Body</option><option class="level-1" value="195">&nbsp;&nbsp;&nbsp;Food</option><option class="level-1" value="189">&nbsp;&nbsp;&nbsp;Mind</option><option class="level-1" value="163">&nbsp;&nbsp;&nbsp;Recipes</option><option class="level-1" value="190">&nbsp;&nbsp;&nbsp;Spirit</option><option class="level-0" value="99">Local News</option><option class="level-1" value="440">&nbsp;&nbsp;&nbsp;Agriculture</option><option class="level-1" value="920">&nbsp;&nbsp;&nbsp;Church</option><option class="level-1" value="1118">&nbsp;&nbsp;&nbsp;CLICO</option><option class="level-1" value="205">&nbsp;&nbsp;&nbsp;Crime</option><option class="level-1" value="571">&nbsp;&nbsp;&nbsp;Culture</option><option class="level-1" value="233">&nbsp;&nbsp;&nbsp;Economy</option><option class="level-1" value="206">&nbsp;&nbsp;&nbsp;Education</option><option class="level-1" value="809">&nbsp;&nbsp;&nbsp;Emergency</option><option class="level-1" value="226">&nbsp;&nbsp;&nbsp;Energy</option><option class="level-1" value="227">&nbsp;&nbsp;&nbsp;Environment</option><option class="level-1" value="977">&nbsp;&nbsp;&nbsp;Foreign Affairs</option><option class="level-1" value="207">&nbsp;&nbsp;&nbsp;Health Care</option><option class="level-1" value="214">&nbsp;&nbsp;&nbsp;Housing</option><option class="level-1" value="1220">&nbsp;&nbsp;&nbsp;Immigration</option><option class="level-1" value="869">&nbsp;&nbsp;&nbsp;Judicial</option><option class="level-1" value="1126">&nbsp;&nbsp;&nbsp;Legistlature</option><option class="level-1" value="1117">&nbsp;&nbsp;&nbsp;National Insurance</option><option class="level-1" value="1153">&nbsp;&nbsp;&nbsp;Social Care</option><option class="level-1" value="658">&nbsp;&nbsp;&nbsp;Technology</option><option class="level-1" value="913">&nbsp;&nbsp;&nbsp;Telecommunications</option><option class="level-1" value="213">&nbsp;&nbsp;&nbsp;Transportation</option><option class="level-1" value="441">&nbsp;&nbsp;&nbsp;Work force</option><option class="level-0" value="883">Off-beat</option><option class="level-0" value="102">Politics</option><option class="level-1" value="1219">&nbsp;&nbsp;&nbsp;Budget</option><option class="level-1" value="212">&nbsp;&nbsp;&nbsp;Elections 2013</option><option class="level-1" value="211">&nbsp;&nbsp;&nbsp;House of Assembly</option><option class="level-1" value="210">&nbsp;&nbsp;&nbsp;Senate</option><option class="level-0" value="430">Public Relations</option><option class="level-0" value="1202">Region</option><option class="level-0" value="103">Regional</option><option class="level-1" value="180">&nbsp;&nbsp;&nbsp;Antigua</option><option class="level-1" value="184">&nbsp;&nbsp;&nbsp;Bahamas</option><option class="level-1" value="657">&nbsp;&nbsp;&nbsp;Bermuda</option><option class="level-1" value="1165">&nbsp;&nbsp;&nbsp;British Virgin Islands</option><option class="level-1" value="187">&nbsp;&nbsp;&nbsp;CARICOM</option><option class="level-1" value="846">&nbsp;&nbsp;&nbsp;Cayman Islands</option><option class="level-1" value="188">&nbsp;&nbsp;&nbsp;CCJ</option><option class="level-1" value="1157">&nbsp;&nbsp;&nbsp;Cuba</option><option class="level-1" value="845">&nbsp;&nbsp;&nbsp;Dominica</option><option class="level-1" value="907">&nbsp;&nbsp;&nbsp;Grenada</option><option class="level-1" value="804">&nbsp;&nbsp;&nbsp;Guyana</option><option class="level-1" value="829">&nbsp;&nbsp;&nbsp;Haiti</option><option class="level-1" value="183">&nbsp;&nbsp;&nbsp;Jamaica</option><option class="level-1" value="186">&nbsp;&nbsp;&nbsp;LIAT</option><option class="level-1" value="1102">&nbsp;&nbsp;&nbsp;St Kitts &amp; Nevis</option><option class="level-1" value="741">&nbsp;&nbsp;&nbsp;St Lucia</option><option class="level-1" value="659">&nbsp;&nbsp;&nbsp;St Vincent</option><option class="level-1" value="182">&nbsp;&nbsp;&nbsp;Trinidad &amp; Tobago</option><option class="level-1" value="185">&nbsp;&nbsp;&nbsp;UWI</option><option class="level-1" value="1246">&nbsp;&nbsp;&nbsp;Venezuela</option><option class="level-0" value="104">Slider</option><option class="level-0" value="95">Special Events</option><option class="level-0" value="1244">Sport</option><option class="level-0" value="105">Sports</option><option class="level-1" value="837">&nbsp;&nbsp;&nbsp;Athletics</option><option class="level-1" value="842">&nbsp;&nbsp;&nbsp;Badminton</option><option class="level-1" value="717">&nbsp;&nbsp;&nbsp;Basketball</option><option class="level-1" value="1120">&nbsp;&nbsp;&nbsp;Beach Soccer</option><option class="level-1" value="858">&nbsp;&nbsp;&nbsp;Body building</option><option class="level-1" value="616">&nbsp;&nbsp;&nbsp;Boxing</option><option class="level-1" value="1169">&nbsp;&nbsp;&nbsp;Chess</option><option class="level-1" value="164">&nbsp;&nbsp;&nbsp;Cricket</option><option class="level-1" value="916">&nbsp;&nbsp;&nbsp;Cycling</option><option class="level-1" value="1164">&nbsp;&nbsp;&nbsp;Draughts</option><option class="level-1" value="165">&nbsp;&nbsp;&nbsp;Field Hockey</option><option class="level-1" value="442">&nbsp;&nbsp;&nbsp;Fishing</option><option class="level-1" value="577">&nbsp;&nbsp;&nbsp;Fitness</option><option class="level-1" value="166">&nbsp;&nbsp;&nbsp;Football</option><option class="level-1" value="470">&nbsp;&nbsp;&nbsp;Golf</option><option class="level-1" value="1170">&nbsp;&nbsp;&nbsp;Gymnastics</option><option class="level-1" value="919">&nbsp;&nbsp;&nbsp;Hockey</option><option class="level-1" value="196">&nbsp;&nbsp;&nbsp;Horse Racing</option><option class="level-1" value="617">&nbsp;&nbsp;&nbsp;Martial Arts</option><option class="level-1" value="167">&nbsp;&nbsp;&nbsp;Motor Sport</option><option class="level-1" value="168">&nbsp;&nbsp;&nbsp;Netball</option><option class="level-1" value="1217">&nbsp;&nbsp;&nbsp;Olympics</option><option class="level-1" value="432">&nbsp;&nbsp;&nbsp;Polo</option><option class="level-1" value="169">&nbsp;&nbsp;&nbsp;Road Tennis</option><option class="level-1" value="554">&nbsp;&nbsp;&nbsp;Rugby</option><option class="level-1" value="848">&nbsp;&nbsp;&nbsp;Sailing</option><option class="level-1" value="922">&nbsp;&nbsp;&nbsp;School</option><option class="level-1" value="1167">&nbsp;&nbsp;&nbsp;Shooting</option><option class="level-1" value="863">&nbsp;&nbsp;&nbsp;Squash</option><option class="level-1" value="917">&nbsp;&nbsp;&nbsp;Surfing</option><option class="level-1" value="433">&nbsp;&nbsp;&nbsp;Swimming</option><option class="level-1" value="651">&nbsp;&nbsp;&nbsp;Tennis</option><option class="level-1" value="170">&nbsp;&nbsp;&nbsp;Track and Field</option><option class="level-1" value="921">&nbsp;&nbsp;&nbsp;Volleyball</option><option class="level-1" value="718">&nbsp;&nbsp;&nbsp;Weightlifting</option><option class="level-1" value="826">&nbsp;&nbsp;&nbsp;Yachting</option><option class="level-0" value="1223">St Vincent</option><option class="level-0" value="1233">Trinidad</option><option class="level-0" value="1214">UK</option><option class="level-0" value="1">Uncategorized</option><option class="level-0" value="1205">Venezuela</option><option class="level-0" value="106">World</option><option class="level-1" value="203">&nbsp;&nbsp;&nbsp;Africa</option><option class="level-1" value="201">&nbsp;&nbsp;&nbsp;Asia</option><option class="level-1" value="1188">&nbsp;&nbsp;&nbsp;Australia</option><option class="level-1" value="198">&nbsp;&nbsp;&nbsp;Canada</option><option class="level-1" value="200">&nbsp;&nbsp;&nbsp;Europe</option><option class="level-1" value="805">&nbsp;&nbsp;&nbsp;India</option><option class="level-1" value="1125">&nbsp;&nbsp;&nbsp;Latin America</option><option class="level-1" value="1121">&nbsp;&nbsp;&nbsp;Middle East</option><option class="level-1" value="202">&nbsp;&nbsp;&nbsp;United Kingdom</option><option class="level-1" value="199">&nbsp;&nbsp;&nbsp;USA</option> </select></form> <script type="text/javascript">var dropdown = document.getElementById("cat");
						function onCatChange() {
							if ( dropdown.options[dropdown.selectedIndex].value > 0 ) {
								location.href = "https://www.barbadostoday.bb/?cat="+dropdown.options[dropdown.selectedIndex].value;
							}
						}
						dropdown.onchange = onCatChange;</script> <form method="get" action="//www.google.com/search"> <label>Search with Google</label> <input name="q" class="google" value="Write keyword and hit return" onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;" /> <input type="hidden" name="sitesearch" value="https://www.barbadostoday.bb/" /></form></div><div class='clear'></div></div></div><div class="widget"> <script>broadstreet.zone(51860);</script> <br> <br> <script>broadstreet.zone(50036);</script> </div></div></div></div></div><div id="footer"><div id="foo_widget1"><div id="gab_about_widget-2" class="widget gab_about_widget"><div class="widgetinner"><h3 class="widgettitle">Barbados Today</h3><p>Our <a href="/about-us">mission</a> is to keep you informed. Do you have news, know of an event or a personality deserving of coverage? <a href="/contact-us">Contact us</a> today! Nothing or no one is too big or too small for us at Barbados Today to highlight. You can also take your own good quality photographs of community events <a href="/contact-us/">and drop us a note</a> with the details.</p><div class="clear clearfix"></div><div class='clear'></div></div></div><div id="text-6" class="widget widget_text"><div class="widgetinner"><div class="textwidget"><p>Mr Peter Harris<br /> Chairman</p><p>Ms Kaymar Jordan<br /> Chief Executive Officer & Editor-in-Chief<br /> Tel:(246) 417- 1000</p><p>Mrs Sandy Deane<br /> Editorial Coordinator<br /> Tel:(246) 417- 1000</p><p>Mr Wade Gibbons<br /> Sports Coordinator<br /> Tel:(246) 417- 1000</p><p>Mr David Williams<br /> Advertising / Sales Manager<br /> Tel:(246) 417- 1005</p><p>Mr Henry Richards<br /> Creative / Technical Manager<br /> Tel:(246) 417- 1032</p></div></div></div></div><div id="foo_widget2"><div id="gabfire_social_widget-3" class="widget gabfire_social_widget"><div class="widgetinner"><h3 class="widgettitle">Connect</h3> <a target="_blank" class="facebook" href="https://www.facebook.com/BarbadosToday" rel="nofollow">Facebook</a><a target="_blank" class="twitter" href="https://twitter.com/barbadostoday" rel="nofollow">Twitter</a><a target="_blank" class="feed" href="https://www.barbadostoday.bb/feed" rel="nofollow">RSS Feed</a><a target="_blank" class="instagram" href="https://www.instagram.com/barbadostoday" rel="nofollow">instagram</a><a target="_blank" class="plus1" href="https://plus.google.com/+barbadostoday" rel="nofollow">Google +1</a><a target="_blank" class="youtube" href="https://www.youtube.com/user/barbadostoday" rel="nofollow">Youtube</a><div class="clear clearfix"></div><div class='clear'></div></div></div><div id="text-8" class="widget widget_text"><div class="widgetinner"><div class="textwidget">Barbados Today<br> Suite F3, Building 3,<br> Manor Lodge Complex,<br> Lodge Hill, St. Michael.<br> +1 (246) 417-1000<br> editor@barbadostoday.bb</div></div></div></div></div><div id="footer_data"><ul class="footerpages"><li class="first"><a href="https://www.barbadostoday.bb/" title="News you can trust.">Home</a></li><li id="menu-item-49906" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49906"><a href="https://www.barbadostoday.bb/about-us/">About Us</a></li><li id="menu-item-49907" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49907"><a href="https://www.barbadostoday.bb/contact-us/">Contact Us</a></li><li id="menu-item-49908" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49908"><a href="https://www.barbadostoday.bb/privacy-policy/">Privacy Policy</a></li><li id="menu-item-49909" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49909"><a href="https://www.barbadostoday.bb/terms-of-service/">Terms of Service</a></li><li id="menu-item-152108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152108"><a href="https://www.barbadostoday.bb/advertising/">Advertising</a></li><li><a rel="nofollow" href="https://www.barbadostoday.bb/feed/">RSS</a></li><li class="right"><a href="#top" title="Barbados Today" rel="home"><strong>&uarr;</strong> Barbados Today</a></li></ul><div class="clear"></div><p id="footer-left-side"> <a href="https://www.barbadostoday.bb/" title="Barbados Today" rel="home">Barbados Today</a></p><p id="footer-right-side"> <a href="https://www.barbadostoday.bb/wp-login.php">Log in</a> - <a href="http://wordpress.org/" title="Semantic Personal Publishing Platform" rel="generator">Powered by WordPress</a> -
Designed by <a href="http://www.gabfirethemes.com/" title="Premium WordPress Themes">Gabfire Themes</a> <script>broadstreet.watch({})</script> <div id="fb-root"></div> <script type='text/javascript'>(function(d, s, id) {
	  var js, fjs = d.getElementsByTagName(s)[0];
	  if (d.getElementById(id)) return;
	  js = d.createElement(s); js.id = id;
	  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
	  fjs.parentNode.insertBefore(js, fjs);
	}(document, 'script', 'facebook-jssdk'));</script><script type='text/javascript' src='https://16f6e5e6d2.site.internapcdn.net/wp-content/plugins/akismet/_inc/form.js?ver=3.3.2'></script> <script type='text/javascript' src='https://16f6e5e6d2.site.internapcdn.net/wp-includes/js/comment-reply.min.js?ver=4.8'></script> <script type='text/javascript' src='https://16f6e5e6d2.site.internapcdn.net/wp-content/plugins/gabfire-widget-pack/js/jquery.tools.min.js?ver=4.8'></script> <script type='text/javascript'>/*  */
var popwid = {"postid":"204696","ajaxurl":"https:\/\/www.barbadostoday.bb\/wp-admin\/admin-ajax.php"};
/*  */</script> <script type='text/javascript' src='https://16f6e5e6d2.site.internapcdn.net/wp-content/plugins/popular-widget/_js/pop-widget.js?ver=1.7.0'></script> <script type='text/javascript' src='https://16f6e5e6d2.site.internapcdn.net/wp-includes/js/wp-embed.min.js?ver=4.8'></script> </p></div></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1498228313 -->