<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head profile="http://gmpg.org/xfn/11"><link rel="stylesheet" href="//fonts.googleapis.com/css?family=Open+Sans%3A400%2C300" /><link rel="stylesheet" href="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/d24ce6e35fda1deb76128d6d192e7348.css" data-minify="1"/><link rel="stylesheet" href="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/7a26329767cf585c809b15a0ac895d35.css" data-minify="1"/><script type='text/javascript' data-cfasync='false' src='https://cdn.broadstreetads.com/init-2.min.js?ver=4.7.4'></script><script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js?ver=4.7.4'></script><script src="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/800281c99935d9aafd7b39f99cedda03.js" data-minify="1"></script><script src="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/b78ab7ebe977a13d37f848a6a272837f.js" data-minify="1"></script><script src="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/fd6a7471b5afebabb860d1e638e3e040.js" data-minify="1"></script> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><title> Patel remanded on firearm and other serious charges | Barbados Today</title><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://www.barbadostoday.bb/feed/" /><link rel="pingback" href="https://www.barbadostoday.bb/xmlrpc.php" /> <script type="text/javascript">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</script> <meta name="robots" content="noodp,noydir" /><meta name="description" content="Patel remanded on firearm and other serious charges | Sharaz O’Brian Patel is the latest young man to be remanded to Her Majesty’s Prison Dodds on firearm&#8230;" /><link rel="canonical" href="https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/" /><link rel='dns-prefetch' href='//cdn.broadstreetads.com' /><link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel='dns-prefetch' href='//16f6e5e6d2.site.internapcdn.net' /><link rel="alternate" type="application/rss+xml" title="Barbados Today &raquo; Feed" href="https://www.barbadostoday.bb/feed/" /><link rel="alternate" type="application/rss+xml" title="Barbados Today &raquo; Comments Feed" href="https://www.barbadostoday.bb/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Barbados Today &raquo; Patel remanded on firearm and other serious charges Comments Feed" href="https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/16f6e5e6d2.site.internapcdn.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.4"}};!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><style id='awesome-weather-inline-css' type='text/css'>.awesome-weather-wrap{font-family:'Open Sans',sans-serif;font-weight:400;font-size:14px;line-height:14px}</style> <script type="text/javascript">/*<![CDATA[*/!function(){var analytics=window.analytics=window.analytics||[];if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.0.0";window.analytics.load("vky0x5mb1o");window.analytics.page();}}();/*]]>*/</script> <link rel='https://api.w.org/' href='https://www.barbadostoday.bb/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.barbadostoday.bb/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.barbadostoday.bb/wp-includes/wlwmanifest.xml" /><link rel="alternate" type="application/json+oembed" href="https://www.barbadostoday.bb/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.barbadostoday.bb%2F2017%2F04%2F25%2Fpatel-remanded-on-firearm-and-other-serious-charges%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.barbadostoday.bb/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.barbadostoday.bb%2F2017%2F04%2F25%2Fpatel-remanded-on-firearm-and-other-serious-charges%2F&#038;format=xml" /><style type="text/css">.ad728{height:90px}.mastheadnav{width:580px;margin-top:10px}#gabfire_social_widget-2.widget.gabfire_social_widget{width:165px;height:53px}.gabfire_social_widget
a{margin:3px
3px}#content .single-default
p{line-height:1.5;margin-bottom:1.7em}#foo_widget1{font-size:12px}.news_wrapper{margin-bottom:15px}#mainmenu{display:block;background:#27aae1;border-top:1px solid #082133}#footer{background:#17478E}#footer
.widgettitle{border-bottom:1px dotted #fff}.newsblock .right .posttitle
a{color:#1282C4}#respond .form-submit
#submit{height:30px}#footer-left-side{display:none}#footer-right-side{display:none}div.pop-inside ul li .pop-summary{color:#555}.wp-caption-text{line-height:1.2;margin-top:7px}</style> <script type='text/javascript'>(function($){$(document).ready(function(){$('a[href="#top"]').click(function(){$('html, body').animate({scrollTop:0},'slow');return false;});$('#slides').slides({autoHeight:true});$("ul.tabs").tabs("div.panes > div");$("ul.sc_tabs").tabs("div.sc_tabs-content > div");});})(jQuery);</script> <meta name="wpsso:mark:begin" content="wpsso meta tags begin"/><meta name="generator" content="WPSSO Pro 3.41.0/L"/><meta name="generator" content="WPSSO SSB Pro 2.3.17/L"/><meta name="generator" content="WPSSO UM 1.6.2/G"/><link rel="publisher" href="https://plus.google.com/+barbadostoday/"/><link rel="shortlink" href="https://www.barbadostoday.bb/?p=198202"/><meta property="fb:app_id" content="613718815307708"/><meta property="og:url" content="https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/"/><meta property="og:type" content="article"/><meta property="og:locale" content="en_US"/><meta property="og:site_name" content="Barbados Today"/><meta property="og:title" content="Patel remanded on firearm and other serious charges"/><meta property="og:description" content="Sharaz O&rsquo;Brian Patel is the latest young man to be remanded to Her Majesty&rsquo;s Prison Dodds on firearm and other charges. The Wavell Avenue, Black Rock, St Michael resident began his first 28 days at..."/><meta property="og:image" content="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel-600x315.jpg"/><meta property="og:image:width" content="600"/><meta property="og:image:height" content="315"/><meta property="article:publisher" content="https://www.facebook.com/BarbadosToday"/><meta property="article:published_time" content="2017-04-25T13:00:19+00:00"/><meta property="article:modified_time" content="2017-04-25T03:10:27+00:00"/><meta property="og:updated_time" content="2017-04-25T03:10:27+00:00"/><meta name="weibo:article:create_at" content="2017-04-25 13:00:19"/><meta name="weibo:article:update_at" content="2017-04-25 03:10:27"/><meta name="twitter:domain" content="www.barbadostoday.bb"/><meta name="twitter:site" content="@barbadostoday"/><meta name="twitter:title" content="Patel remanded on firearm and other serious charges"/><meta name="twitter:description" content="Sharaz O&rsquo;Brian Patel is the latest young man to be remanded to Her Majesty&rsquo;s Prison Dodds on firearm and other charges. The Wavell Avenue, Black Rock, St Michael resident began his first 28 days at..."/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel-800x405.jpg"/><meta itemprop="url" content="https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/"/><meta itemprop="name" content="Patel remanded on firearm and other serious charges"/><meta itemprop="description" content="Sharaz O&rsquo;Brian Patel is the latest young man to be remanded to Her Majesty&rsquo;s Prison Dodds on firearm and other charges. The Wavell Avenue, Black Rock, St Michael resident began his first 28 days at..."/><meta name="author" content="Barbados Today"/> <noscript itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Barbados Today"/><meta itemprop="description" content="Barbados Today is the leading news service in Barbados. Founded in January 2010, with the mission to keep you informed, we aim to share news on matters of national interest, raise the level of public debate and help our readers make informed decisions in their daily lives. We do this by building confidence in our content through consistency. We strive for accuracy, accountability and maturity in our reporting at all times."/> </noscript> <noscript itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel-800x405.jpg"/><meta itemprop="width" content="800"/><meta itemprop="height" content="405"/> </noscript><meta name="wpsso:mark:end" content="wpsso meta tags end"/> <script type="text/javascript" id="wpssossb-header-script">window.___gcfg={lang:"en-US"};function wpsso_insert_js(script_id,url,async){if(document.getElementById(script_id+"-js"))return;var async=typeof async!=="undefined"?async:true;var script_pos=document.getElementById(script_id);var js=document.createElement("script");js.id=script_id+"-js";js.async=async;js.type="text/javascript";js.language="JavaScript";js.src=url;script_pos.parentNode.insertBefore(js,script_pos);};</script> 
 <script type="text/javascript" id="fb-script-header">/*<![CDATA[*/wpsso_insert_js("fb-script-header","https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=613718815307708");/*]]>*/</script> <script type="text/javascript" id="gplus-script-header">wpsso_insert_js("gplus-script-header","https://apis.google.com/js/plusone.js");</script> <script type="text/javascript" id="linkedin-script-header">wpsso_insert_js("linkedin-script-header","https://platform.linkedin.com/in.js");</script> <script type="text/javascript" id="twitter-script-header">wpsso_insert_js("twitter-script-header","https://platform.twitter.com/widgets.js");</script> <link rel="shortcut icon" href="https://www.barbadostoday.bb/wp-content/uploads/2011/12/favicon.gif"/> <script data-no-minify="1" data-cfasync="false">(function(w,d){function a(){var b=d.createElement("script");b.async=!0;b.src="https://16f6e5e6d2.site.internapcdn.net/wp-content/plugins/wp-rocket/inc/front/js/lazyload.1.0.5.min.js";var a=d.getElementsByTagName("script")[0];a.parentNode.insertBefore(b,a)}w.attachEvent?w.attachEvent("onload",a):w.addEventListener("load",a,!1)})(window,document);</script> <style type="text/css" media="screen">body{font-size:14px;font-family:arial;font-weight:normal;color:#555}a{color:#27aae1}h2.posttitle{font-size:18px;font-family:arial;font-weight:normal;color:#555}h2.posttitle
a{color:#034693}.widgettitle{font-size:14px;font-family:arial;font-weight:normal;color:#555}.catname
span{font-size:22px;font-family:arial;font-weight:normal;color:#555}</style><broadstreet-zone zone-id="54052"></broadstreet-zone> <broadstreet-zone zone-id="51273"></broadstreet-zone> <broadstreet-zone zone-id="51634"></broadstreet-zone> <broadstreet-zone zone-id="51320"></broadstreet-zone></head><body class="post-template-default single single-post postid-198202 single-format-standard"><div class="ad728"> <script>broadstreet.zone(50028);</script> </div><div class="wrapper"><div id="masthead"><ul class="mastheadnav dropdown"><li class="first"><a href="https://www.barbadostoday.bb/" title="News you can trust.">Home</a></li><li id="menu-item-50433" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50433"><a title="Our Print-Style Publication" href="http://epaper.barbadostoday.bb">ePaper</a></li><li id="menu-item-142207" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142207"><a href="https://www.barbadostoday.bb/download-todays-news-app/">Mobile App</a></li><li id="menu-item-142206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142206"><a href="https://www.barbadostoday.bb/newsletters/">Newsletters</a></li><li id="menu-item-142202" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142202"><a href="https://www.facebook.com/barbadostoday">Facebook</a></li><li id="menu-item-142205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142205"><a href="https://www.youtube.com/user/barbadostoday?&#038;ab_channel=BarbadosToday">YouTube</a></li><li id="menu-item-142203" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142203"><a href="https://twitter.com/barbadostoday">Twitter</a></li><li id="menu-item-142201" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142201"><a href="https://instagram.com/barbadostoday/">Instagram</a></li></ul><div class="search"><form class="gabfire_search_style1" action="https://www.barbadostoday.bb/"><fieldset> <input type="text" class="gab_search_text" name="s" value="Search in site..." onfocus="if (this.value == 'Search in site...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search in site...';}" /> <input type="submit"  value="" class="submit_style1" /><div class="clearfix"></div></fieldset></form></div></div><div id="header"> <a href="https://www.barbadostoday.bb/" title="News you can trust."> <img  src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/09/BT-7th-ANn-Website-Header-2017-01-1.jpg" id="header_banner" alt="Barbados Today" title="Barbados Today"/> </a></div><div id="mainmenu"><ul class="mainnav dropdown"><li class="first"><a href="https://www.barbadostoday.bb/" title="News you can trust.">Home</a></li><li id="menu-item-157940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157940"><a href="https://www.barbadostoday.bb/category/local-news/">Local News</a><ul class="sub-menu"><li id="menu-item-157948" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157948"><a href="https://www.barbadostoday.bb/category/local-news/agriculture/">Agriculture</a></li><li id="menu-item-157949" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157949"><a href="https://www.barbadostoday.bb/category/local-news/church/">Church</a></li><li id="menu-item-157951" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-157951"><a href="https://www.barbadostoday.bb/category/court/">Court</a></li><li id="menu-item-157952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157952"><a href="https://www.barbadostoday.bb/category/local-news/crime/">Crime</a></li><li id="menu-item-157953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157953"><a href="https://www.barbadostoday.bb/category/local-news/culture/">Culture</a></li><li id="menu-item-157954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157954"><a href="https://www.barbadostoday.bb/category/local-news/economy/">Economy</a></li><li id="menu-item-157955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157955"><a href="https://www.barbadostoday.bb/category/local-news/education/">Education</a></li><li id="menu-item-157957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157957"><a href="https://www.barbadostoday.bb/category/local-news/energy/">Energy</a></li><li id="menu-item-157958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157958"><a href="https://www.barbadostoday.bb/category/local-news/environment/">Environment</a></li><li id="menu-item-157959" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157959"><a href="https://www.barbadostoday.bb/category/local-news/health-care/">Health Care</a></li><li id="menu-item-157961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157961"><a href="https://www.barbadostoday.bb/category/local-news/transportation/">Transportation</a></li></ul></li><li id="menu-item-157941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157941"><a href="https://www.barbadostoday.bb/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-157962" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157962"><a href="https://www.barbadostoday.bb/category/sports/cricket/">Cricket</a></li><li id="menu-item-157963" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157963"><a href="https://www.barbadostoday.bb/category/sports/athletics/">Athletics</a></li><li id="menu-item-157964" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157964"><a href="https://www.barbadostoday.bb/category/sports/basketball/">Basketball</a></li><li id="menu-item-157965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157965"><a href="https://www.barbadostoday.bb/category/sports/football/">Football</a></li><li id="menu-item-157966" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157966"><a href="https://www.barbadostoday.bb/category/sports/motor-sport/">Motor Sport</a></li><li id="menu-item-157967" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157967"><a href="https://www.barbadostoday.bb/category/sports/netball/">Netball</a></li><li id="menu-item-157968" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157968"><a href="https://www.barbadostoday.bb/category/sports/school/">School</a></li><li id="menu-item-157969" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157969"><a href="https://www.barbadostoday.bb/category/sports/tennis/">Tennis</a></li><li id="menu-item-157970" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157970"><a href="https://www.barbadostoday.bb/category/sports/road-tennis/">Road Tennis</a></li><li id="menu-item-157971" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157971"><a href="https://www.barbadostoday.bb/category/sports/track-and-field/">Track and Field</a></li></ul></li><li id="menu-item-157944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157944"><a href="https://www.barbadostoday.bb/category/business/">Business</a><ul class="sub-menu"><li id="menu-item-157978" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157978"><a href="https://www.barbadostoday.bb/category/business/banking/">Banking</a></li><li id="menu-item-157975" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157975"><a href="https://www.barbadostoday.bb/category/business/entrepreneurship/">Entrepreneurship</a></li><li id="menu-item-157974" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157974"><a href="https://www.barbadostoday.bb/category/business/industrial-relations/">Indus. Relations</a></li><li id="menu-item-157976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157976"><a href="https://www.barbadostoday.bb/category/business/international-business/">Int&#8217;l Business</a></li><li id="menu-item-157973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157973"><a href="https://www.barbadostoday.bb/category/business/social-partnership/">Social Partnership</a></li><li id="menu-item-157977" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157977"><a href="https://www.barbadostoday.bb/category/business/stock-exchange/">Stock Exchange</a></li><li id="menu-item-157979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157979"><a href="https://www.barbadostoday.bb/category/local-news/telecommunications/">Telecommunications</a></li><li id="menu-item-157972" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157972"><a href="https://www.barbadostoday.bb/category/business/tourism/">Tourism</a></li></ul></li><li id="menu-item-158027" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-158027"><a href="https://www.barbadostoday.bb/category/leisure/entertainment/">Entertainment</a><ul class="sub-menu"><li id="menu-item-158029" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158029"><a href="https://www.barbadostoday.bb/category/leisure/entertainment/music/">Music</a></li><li id="menu-item-158005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-158005"><a href="https://www.barbadostoday.bb/category/leisure/cropover/">Crop Over</a><ul class="sub-menu"><li id="menu-item-158010" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158010"><a href="https://www.barbadostoday.bb/category/leisure/cropover/kadooment-day/">Kadooment Day</a></li><li id="menu-item-158006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158006"><a href="https://www.barbadostoday.bb/category/leisure/cropover/foreday-mornin/">Foreday Mornin&#8217;</a></li><li id="menu-item-158009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158009"><a href="https://www.barbadostoday.bb/category/leisure/cropover/pic-o-de-crop/">Pic-O-De-Crop</a></li><li id="menu-item-158007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158007"><a href="https://www.barbadostoday.bb/category/leisure/cropover/junior-kadooment/">Junior Kadooment</a></li><li id="menu-item-158008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158008"><a href="https://www.barbadostoday.bb/category/leisure/cropover/junior-monarch/">Junior Monarch</a></li></ul></li><li id="menu-item-157945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157945"><a href="https://www.barbadostoday.bb/category/leisure/">Leisure</a><ul class="sub-menu"><li id="menu-item-158002" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158002"><a href="https://www.barbadostoday.bb/category/lifestyle/recipes/">Recipes</a></li></ul></li><li id="menu-item-158028" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158028"><a href="https://www.barbadostoday.bb/category/lifestyle/">Lifestyle</a></li></ul></li><li id="menu-item-157946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157946"><a href="https://www.barbadostoday.bb/category/politics/">Politics</a><ul class="sub-menu"><li id="menu-item-157981" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157981"><a href="https://www.barbadostoday.bb/category/politics/house-of-assembly/">House of Assembly</a></li><li id="menu-item-157980" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157980"><a href="https://www.barbadostoday.bb/category/politics/senate/">Senate</a></li><li id="menu-item-157982" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157982"><a href="https://www.barbadostoday.bb/category/politics/elections-2013/">Elections 2013</a></li></ul></li><li id="menu-item-157942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157942"><a href="https://www.barbadostoday.bb/category/regional/">Regional</a><ul class="sub-menu"><li id="menu-item-157997" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157997"><a href="https://www.barbadostoday.bb/category/regional/bahamas/">Bahamas</a></li><li id="menu-item-157996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157996"><a href="https://www.barbadostoday.bb/category/regional/ccj/">CCJ</a></li><li id="menu-item-157985" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157985"><a href="https://www.barbadostoday.bb/category/regional/grenada/">Grenada</a></li><li id="menu-item-157986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157986"><a href="https://www.barbadostoday.bb/category/regional/haiti/">Haiti</a></li><li id="menu-item-157998" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157998"><a href="https://www.barbadostoday.bb/category/regional/liat/">LIAT</a></li><li id="menu-item-157988" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157988"><a href="https://www.barbadostoday.bb/category/regional/st-kitts-nevis/">St Kitts &#038; Nevis</a></li><li id="menu-item-157989" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157989"><a href="https://www.barbadostoday.bb/category/regional/st-lucia/">St Lucia</a></li><li id="menu-item-157990" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157990"><a href="https://www.barbadostoday.bb/category/regional/st-vincent/">St Vincent</a></li><li id="menu-item-157991" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157991"><a href="https://www.barbadostoday.bb/category/regional/trinidad-and-tobago/">Trinidad &#038; Tobago</a></li><li id="menu-item-157992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157992"><a href="https://www.barbadostoday.bb/category/regional/uwi/">UWI</a></li></ul></li><li id="menu-item-157943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157943"><a href="https://www.barbadostoday.bb/category/world/">World</a><ul class="sub-menu"><li id="menu-item-158011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158011"><a href="https://www.barbadostoday.bb/category/world/africa/">Africa</a></li><li id="menu-item-158012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158012"><a href="https://www.barbadostoday.bb/category/world/asia/">Asia</a></li><li id="menu-item-158013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158013"><a href="https://www.barbadostoday.bb/category/world/australia/">Australia</a></li><li id="menu-item-158014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158014"><a href="https://www.barbadostoday.bb/category/world/canada/">Canada</a></li><li id="menu-item-158015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158015"><a href="https://www.barbadostoday.bb/category/world/europe/">Europe</a></li><li id="menu-item-158016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158016"><a href="https://www.barbadostoday.bb/category/world/india/">India</a></li><li id="menu-item-158017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158017"><a href="https://www.barbadostoday.bb/category/world/latin-america/">Latin America</a></li><li id="menu-item-158018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158018"><a href="https://www.barbadostoday.bb/category/world/middle-east/">Middle East</a></li><li id="menu-item-158019" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158019"><a href="https://www.barbadostoday.bb/category/world/uk/">United Kingdom</a></li><li id="menu-item-158020" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158020"><a href="https://www.barbadostoday.bb/category/world/usa/">USA</a></li></ul></li></ul><div class="clear"></div></div><div id="submenu"><ul class="subnav dropdown"><li id="menu-item-84876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84876"><a href="https://www.barbadostoday.bb/gallery-cats/news-updates/">Video News</a></li><li id="menu-item-84877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84877"><a href="https://www.barbadostoday.bb/gallery-cats/entertainment-weekly/">Entertainment Weekly</a></li><li id="menu-item-84878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84878"><a href="https://www.barbadostoday.bb/gallery-cats/business-minute/">Business Minute</a></li><li id="menu-item-21347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21347"><a href="https://www.barbadostoday.bb/category/editorial/">Editorial</a></li><li id="menu-item-6520" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6520"><a href="https://www.barbadostoday.bb/category/column/">Columns</a></li><li id="menu-item-21349" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21349"><a href="https://www.barbadostoday.bb/category/letters/">Letters</a></li><li class="date right"> <script type="text/javascript">/*<![CDATA[*/var mydate=new Date()
var year=mydate.getYear()
if(year<1000)
year+=1900
var day=mydate.getDay()
var month=mydate.getMonth()
var daym=mydate.getDate()
if(daym<10)
daym="0"+daym
var dayarray=new Array("Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday")
var montharray=new Array("January","February","March","April","May","June","July","August","September","October","November","December")
document.write(""+dayarray[day]+", "+montharray[month]+" "+daym+", "+year+"")/*]]>*/</script> </li></ul><div class="clear"></div></div><div id="container"><div id="content"><div id="post-198202" class="entry single-default post-198202 post type-post status-publish format-standard has-post-thumbnail hentry category-court"><h1 class="entry_title"> Patel remanded on firearm and other serious charges</h1><div class="single_postmeta"> <span class="left"> Added by <a href="https://www.barbadostoday.bb/author/bteditor/">Barbados Today</a> on April 25, 2017.<br />Saved under <a href="https://www.barbadostoday.bb/category/court/" rel="category tag">Court</a><br /> </span> <span class="right"><div id="text-11" class="widget widget_text"><div class="widgetinner"><div class="textwidget"><div class="wpsso-ssb wpsso-ssb-shortcode"><div class="ssb-buttons en_US"><div class="fb-like facebook-ssb-shortcode" id="facebook-button-post-198202"><fb:like href="https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/" send="true" layout="button_count" show_faces="false" font="arial" colorscheme="light" action="like"></fb:like></div><div class="gplusone-ssb-shortcode" id="gplusone-button-post-198202"><span class="g-plusone" data-size="medium" data-annotation="bubble" data-href="https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/"></span></div><div class="pinterest-ssb-shortcode" id="pinterest-button-post-198202"><a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.barbadostoday.bb%2F2017%2F04%2F25%2Fpatel-remanded-on-firearm-and-other-serious-charges%2F&amp;media=https%3A%2F%2F16f6e5e6d2.site.internapcdn.net%2Fwp-content%2Fuploads%2F2017%2F04%2FPatel-800x405.jpg&amp;description=Sharaz%20O%E2%80%99Brian%20Patel%20is%20the%20latest%20young%20man%20to%20be%20remanded%20to%20Her%20Majesty%E2%80%99s%20Prison%20Dodds%20on%20firearm%20and%20other%20charges.%20The%20Wavell%20Avenue%2C%20Black%20Rock%2C%20St%20Michael%20resident%20began%20his%20first%2028%20days%20at..." data-pin-do="buttonPin" data-pin-zero="true" data-pin-lang="en" data-pin-shape="rect" data-pin-color="gray" data-pin-height="20" data-pin-config="beside"><img border="0" alt="Pin It" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" width="40" height="20" /><noscript><img border="0" alt="Pin It" src="https://assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" width="40" height="20" /></noscript></a></div><div class="twitter-ssb-shortcode" id="twitter-button-post-198202"><a href="https://twitter.com/share" class="twitter-share-button" data-lang="en" data-url="https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/" data-counturl="https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/" data-text="Patel remanded on firearm and other serious charges" data-via="barbadostoday" data-related="" data-hashtags="" data-size="medium" data-dnt="true"></a></div></div></div> <script type="text/javascript" id="pinterest-script-shortcode-footer">wpsso_insert_js("pinterest-script-shortcode-footer","https://assets.pinterest.com/js/pinit.js");</script> </div></div></div> </span><div class="clear"></div></div><p class="p1">Sharaz O’Brian Patel is the latest young man to be remanded to Her Majesty’s Prison Dodds on firearm and other charges.</p><p class="p1">The Wavell Avenue, Black Rock, St Michael resident began his first 28 days at the St Philip penal institution today after appearing before Magistrate Kristie Cuffy-Sargeant accused of five indictable offences which reportedly occurred on March 20, 2017.</p><p class="p1">It is alleged that the 30-year-old unemployed man unlawfully and maliciously engaged in conduct which placed Theodore Cumberbatch in danger of death or serious bodily harm; and also had the intent to maim, disfigure or disable Brian Cumberbatch or do him some serious bodily harm.</p><p class="p1">He is also accused of damaging a glass showcase and a pastry warmer belonging to Ksree St Hill, as well as using a firearm while committing the offence of serious bodily harm.</p><p class="p1">Patel was not required to plead to any of those charges, or that of unlawfully and maliciously engaging in conduct which placed Wendy Alleyne in danger of death or serious bodily harm.</p><p class="p1">The accused, who is represent by attorney-at-law Romain Marshall, returns to court on May 22.</p><div class="wpsso-ssb wpsso-ssb-content"><div class="ssb-buttons en_US"><div class="css-button email-button"> <a href="mailto:?subject=Share:%20Patel%20remanded%20on%20firearm%20and%20other%20serious%20charges&body=Sharaz%20O%E2%80%99Brian%20Patel%20is%20the%20latest%20young%20man%20to%20be%20remanded%20to%20Her%20Majesty%E2%80%99s%20Prison%20Dodds%20on%20firearm%20and%20other%20charges.%20The%20Wavell%20Avenue%2C%20Black%20Rock%2C%20St%20Michael%20resident%20began%20his%20first%2028%20days%20at...%0D%0A%0D%0AShared%20from%20https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/%0D%0A"> <span class="ssb-icon"> <svg xmlns="http://www.w3.org/2000/svg" width="9" height="9" viewBox="0 0 28 28"> <path d="M20.11 26.147c-2.335 1.05-4.36 1.4-7.124 1.4C6.524 27.548.84 22.916.84 15.284.84 7.343 6.602.45 15.4.45c6.854 0 11.8 4.7 11.8 11.252 0 5.684-3.193 9.265-7.398 9.3-1.83 0-3.153-.934-3.347-2.997h-.077c-1.208 1.986-2.96 2.997-5.023 2.997-2.532 0-4.36-1.868-4.36-5.062 0-4.75 3.503-9.07 9.11-9.07 1.713 0 3.7.4 4.6.972l-1.17 7.203c-.387 2.298-.115 3.3 1 3.4 1.674 0 3.774-2.102 3.774-6.58 0-5.06-3.27-8.994-9.304-8.994C9.05 2.87 3.83 7.545 3.83 14.97c0 6.5 4.2 10.2 10 10.202 1.987 0 4.09-.43 5.647-1.245l.634 2.22zM16.647 10.1c-.31-.078-.7-.155-1.207-.155-2.572 0-4.596 2.53-4.596 5.53 0 1.5.7 2.4 1.9 2.4 1.44 0 2.96-1.83 3.31-4.088l.592-3.72z" /> </svg> </span> <span class="ssb-text"></span> </a></div><div class="css-button whatsapp-button"> <a href="whatsapp://send?text=Patel%20remanded%20on%20firearm%20and%20other%20serious%20charges%20https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/" data-action="share/whatsapp/share"> <span class="ssb-icon"> <svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="9" height="9" viewBox="0 0 90 90" enable-background="new 0 0 90 90;" xml:space="preserve"> <path d="M90,43.841c0,24.213-19.779,43.841-44.182,43.841c-7.747,0-15.025-1.98-21.357-5.455L0,90l7.975-23.522c-4.023-6.606-6.34-14.354-6.34-22.637C1.635,19.628,21.416,0,45.818,0C70.223,0,90,19.628,90,43.841z M45.818,6.982c-20.484,0-37.146,16.535-37.146,36.859c0,8.065,2.629,15.534,7.076,21.61L11.107,79.14l14.275-4.537c5.865,3.851,12.891,6.097,20.437,6.097c20.481,0,37.146-16.533,37.146-36.857S66.301,6.982,45.818,6.982z M68.129,53.938c-0.273-0.447-0.994-0.717-2.076-1.254c-1.084-0.537-6.41-3.138-7.4-3.495c-0.993-0.358-1.717-0.538-2.438,0.537c-0.721,1.076-2.797,3.495-3.43,4.212c-0.632,0.719-1.263,0.809-2.347,0.271c-1.082-0.537-4.571-1.673-8.708-5.333c-3.219-2.848-5.393-6.364-6.025-7.441c-0.631-1.075-0.066-1.656,0.475-2.191c0.488-0.482,1.084-1.255,1.625-1.882c0.543-0.628,0.723-1.075,1.082-1.793c0.363-0.717,0.182-1.344-0.09-1.883c-0.27-0.537-2.438-5.825-3.34-7.977c-0.902-2.15-1.803-1.792-2.436-1.792c-0.631,0-1.354-0.09-2.076-0.09c-0.722,0-1.896,0.269-2.889,1.344c-0.992,1.076-3.789,3.676-3.789,8.963c0,5.288,3.879,10.397,4.422,11.113c0.541,0.716,7.49,11.92,18.5,16.223 C58.2,65.771,58.2,64.336,60.186,64.156c1.984-0.179,6.406-2.599,7.312-5.107C68.398,56.537,68.398,54.386,68.129,53.938z"/> </svg> </span> <span class="ssb-text"></span> </a></div><div class="twitter-button" id="twitter-ssb-content-post-198202"><a href="https://twitter.com/share" class="twitter-share-button" data-lang="en" data-url="https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/" data-counturl="https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/" data-text="Patel remanded on firearm and other serious charges" data-via="barbadostoday" data-related="" data-hashtags="" data-size="medium" data-dnt="true"></a></div><div class="fb-like facebook-button" id="facebook-ssb-content-post-198202"><fb:like href="https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/" send="true" layout="button_count" show_faces="false" font="arial" colorscheme="light" action="like"></fb:like></div><div class="gplusone-button" id="gplusone-ssb-content-post-198202"><span class="g-plusone" data-size="medium" data-annotation="bubble" data-href="https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/"></span></div><div class="linkedin-button" id="linkedin-ssb-content-post-198202"><script type="IN/Share" data-url="https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/" data-counter="right" data-showzero="true"></script></div></div></div><div class="clear"></div></div><div id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.barbadostoday.bb/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p> <script>document.write(String.fromCharCode(60,105,110,112,117,116,32,116,121,112,101,61,104,105,100,100,101,110,32,110,97,109,101,61,34,90,109,78,115,55,73,56,104,34,32,118,97,108,117,101,61,34,53,48,57,53,58,57,53,100,102,101,54,53,98,56,97,51,55,102,57,51,54,54,100,101,56,55,56,101,51,49,99,99,98,101,99,52,97,98,49,55,48,52,55,50,57,34,62));</script><noscript><strong><font color=red>Please enable JavaScript</font></strong></noscript><div style="display:none;"><input type="text" name="Wuu2y" value="" /></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='198202' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="f707f40085" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="211"/></p></form></div></div></div><div id="sidebar"><div class="sidebarinner"><div class="widget"> <script>broadstreet.zone(50041);</script> <br> <br> <script>broadstreet.zone(51631);</script></div><div id="popular-widget-5" class="widget popular-widget"><div class="widgetinner"><h3 class="widgettitle">Popular (Last 7 Days)</h3><div class="pop-layout-v"><ul id="pop-widget-tabs-5" class="pop-widget-tabs pop-widget-tabs-3" ><li><a href="#recent" rel="nofollow">Recent Posts</a></li><li><a href="#commented" rel="nofollow">Most Commented</a></li><li><a href="#viewed" rel="nofollow">Most Viewed</a></li></ul><div class="pop-inside-5 pop-inside"><ul id="pop-widget-recent-5"><li><a href="https://www.barbadostoday.bb/2017/04/25/patel-remanded-on-firearm-and-other-serious-charges/" title="Patel remanded on firearm and other serious charges" rel="bookmark"><img width="900" height="456" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel-650x329.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel-768x389.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel-160x81.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel-640x324.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel-800x405.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="198186" /><noscript><img width="900" height="456" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel-650x329.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel-768x389.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel-160x81.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel-640x324.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Patel-800x405.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="198186" /></noscript><span class="pop-overlay"><span class="pop-title">Patel remanded on firearm and other serious charges</span> <span class="pop-summary">Sharaz O’Brian Patel is the latest young man to be...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/04/25/habitual-thief-jailed-for-break-ins/" title="Habitual thief jailed for break-ins" rel="bookmark"><img width="900" height="444" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-650x321.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-768x379.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-160x79.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-305x150.jpg 305w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-640x316.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-800x395.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="198185" /><noscript><img width="900" height="444" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-650x321.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-768x379.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-160x79.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-305x150.jpg 305w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-640x316.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-800x395.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="198185" /></noscript><span class="pop-overlay"><span class="pop-title">Habitual thief jailed for break-ins</span> <span class="pop-summary">Magistrate Kristie Cuffy-Sargeant today sentenced a 48-year-old thief to 18...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/04/25/teenager-grounded-after-assaulting-policewoman/" title="Teenager grounded after assaulting policewoman" rel="bookmark"><img width="900" height="444" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell.jpg" class="attachment-post-thumbnail size-post-thumbnail" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-650x321.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-768x379.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-160x79.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-305x150.jpg 305w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-640x316.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Worrell-800x395.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="198185" /><span class="pop-overlay"><span class="pop-title">Teenager grounded after assaulting policewoman</span> <span class="pop-summary">A Barbadian teen who was scheduled to leave the island...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/04/25/wish-granted-2/" title="Wish granted" rel="bookmark"><img width="900" height="508" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis-650x367.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis-768x433.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis-160x90.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis-480x270.jpg 480w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis-640x361.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis-800x452.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="198188" /><noscript><img width="900" height="508" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis-650x367.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis-768x433.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis-160x90.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis-480x270.jpg 480w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis-640x361.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Innis-800x452.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="198188" /></noscript><span class="pop-overlay"><span class="pop-title">Wish granted</span> <span class="pop-summary">A request by a young man that he be remanded...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/04/25/cavs-sweep-pacers-4-0/" title="Cavs sweep Pacers 4-0" rel="bookmark"><img width="900" height="693" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/CavsXXLeBronXJamesXisXchallengedXbyXPacersXXPaulXGeorgeXasXheXgoesXtoXtheXbasket.X.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/CavsXXLeBronXJamesXisXchallengedXbyXPacersXXPaulXGeorgeXasXheXgoesXtoXtheXbasket.X.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/CavsXXLeBronXJamesXisXchallengedXbyXPacersXXPaulXGeorgeXasXheXgoesXtoXtheXbasket.X-650x501.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/CavsXXLeBronXJamesXisXchallengedXbyXPacersXXPaulXGeorgeXasXheXgoesXtoXtheXbasket.X-768x591.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/CavsXXLeBronXJamesXisXchallengedXbyXPacersXXPaulXGeorgeXasXheXgoesXtoXtheXbasket.X-160x123.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/CavsXXLeBronXJamesXisXchallengedXbyXPacersXXPaulXGeorgeXasXheXgoesXtoXtheXbasket.X-640x493.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/CavsXXLeBronXJamesXisXchallengedXbyXPacersXXPaulXGeorgeXasXheXgoesXtoXtheXbasket.X-800x616.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="198162" /><noscript><img width="900" height="693" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/CavsXXLeBronXJamesXisXchallengedXbyXPacersXXPaulXGeorgeXasXheXgoesXtoXtheXbasket.X.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/CavsXXLeBronXJamesXisXchallengedXbyXPacersXXPaulXGeorgeXasXheXgoesXtoXtheXbasket.X.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/CavsXXLeBronXJamesXisXchallengedXbyXPacersXXPaulXGeorgeXasXheXgoesXtoXtheXbasket.X-650x501.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/CavsXXLeBronXJamesXisXchallengedXbyXPacersXXPaulXGeorgeXasXheXgoesXtoXtheXbasket.X-768x591.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/CavsXXLeBronXJamesXisXchallengedXbyXPacersXXPaulXGeorgeXasXheXgoesXtoXtheXbasket.X-160x123.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/CavsXXLeBronXJamesXisXchallengedXbyXPacersXXPaulXGeorgeXasXheXgoesXtoXtheXbasket.X-640x493.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/CavsXXLeBronXJamesXisXchallengedXbyXPacersXXPaulXGeorgeXasXheXgoesXtoXtheXbasket.X-800x616.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="198162" /></noscript><span class="pop-overlay"><span class="pop-title">Cavs sweep Pacers 4-0</span> <span class="pop-summary">INDIANA - LeBron James made a 3-pointer with 68 seconds...</span></span></a><br class="pop-cl" /></li></ul><ul id="pop-widget-commented-5"><li><a href="https://www.barbadostoday.bb/2017/04/20/stuart-has-wisdom-of-god/" title="Stuart has wisdom of God" rel="bookmark"><img width="900" height="422" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_7509a-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_7509a-1.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_7509a-1-650x305.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_7509a-1-768x360.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_7509a-1-160x75.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_7509a-1-640x300.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_7509a-1-800x375.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="193167" /><noscript><img width="900" height="422" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_7509a-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_7509a-1.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_7509a-1-650x305.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_7509a-1-768x360.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_7509a-1-160x75.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_7509a-1-640x300.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_7509a-1-800x375.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="193167" /></noscript><span class="pop-overlay"><span class="pop-title">Stuart has wisdom of God</span> <span class="pop-summary">Whenever the question of leadership arises, I think of King...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/04/23/williams-says-he-was-called-by-god-to-serve/" title="Williams says he was called by God to serve" rel="bookmark"><img width="640" height="428" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/HendersonXWilliams.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/HendersonXWilliams.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/HendersonXWilliams-160x106.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/HendersonXWilliams-450x300.jpg 450w" data-lazy-sizes="(max-width: 640px) 100vw, 640px" data-wp-pid="198056" /><noscript><img width="640" height="428" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/HendersonXWilliams.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/HendersonXWilliams.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/HendersonXWilliams-160x106.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/HendersonXWilliams-450x300.jpg 450w" sizes="(max-width: 640px) 100vw, 640px" data-wp-pid="198056" /></noscript><span class="pop-overlay"><span class="pop-title">Williams says he was called by God to serve</span> <span class="pop-summary">The Democratic Labour Party (DLP's) new City candidate Henderson Williams...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/04/23/dont-be-distracted-by-the-huff-and-puff-warns-pm/" title="Don&#039;t be distracted by the &#039;huff and puff&#039;, warns PM" rel="bookmark"><img width="618" height="407" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/IMG_8038-e1492999036723.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/IMG_8038-e1492999036723.jpg 618w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/IMG_8038-e1492999036723-70x45.jpg 70w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/IMG_8038-e1492999036723-160x106.jpg 160w" data-lazy-sizes="(max-width: 618px) 100vw, 618px" data-wp-pid="198074" /><noscript><img width="618" height="407" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/IMG_8038-e1492999036723.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/IMG_8038-e1492999036723.jpg 618w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/IMG_8038-e1492999036723-70x45.jpg 70w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/IMG_8038-e1492999036723-160x106.jpg 160w" sizes="(max-width: 618px) 100vw, 618px" data-wp-pid="198074" /></noscript><span class="pop-overlay"><span class="pop-title">Don't be distracted by the 'huff and puff', warns PM</span> <span class="pop-summary">"Ignore the high winds, ignore the fires and listen to...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/04/21/ninja-man-pepper-sprayed/" title="Ninja Man pepper sprayed" rel="bookmark"><img width="405" height="247" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/ScreenXShotX2017-04-20XatX7.56.43XPM.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/ScreenXShotX2017-04-20XatX7.56.43XPM.png 405w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/ScreenXShotX2017-04-20XatX7.56.43XPM-160x98.png 160w" data-lazy-sizes="(max-width: 405px) 100vw, 405px" data-wp-pid="197864" /><noscript><img width="405" height="247" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/ScreenXShotX2017-04-20XatX7.56.43XPM.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/ScreenXShotX2017-04-20XatX7.56.43XPM.png 405w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/ScreenXShotX2017-04-20XatX7.56.43XPM-160x98.png 160w" sizes="(max-width: 405px) 100vw, 405px" data-wp-pid="197864" /></noscript><span class="pop-overlay"><span class="pop-title">Ninja Man pepper sprayed</span> <span class="pop-summary">An apparent pepper spray attack on Ninja Man, one of...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/04/22/solutions-nine/" title="Solutions&#039; nine" rel="bookmark"><img width="638" height="304" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/SolutionsXBarbados-1-e1492899264122.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/SolutionsXBarbados-1-e1492899264122.png 638w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/SolutionsXBarbados-1-e1492899264122-160x76.png 160w" data-lazy-sizes="(max-width: 638px) 100vw, 638px" data-wp-pid="198025" /><noscript><img width="638" height="304" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/SolutionsXBarbados-1-e1492899264122.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/SolutionsXBarbados-1-e1492899264122.png 638w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/SolutionsXBarbados-1-e1492899264122-160x76.png 160w" sizes="(max-width: 638px) 100vw, 638px" data-wp-pid="198025" /></noscript><span class="pop-overlay"><span class="pop-title">Solutions' nine</span> <span class="pop-summary">Further to this week's announcement of nine candidates to contest...</span></span></a><br class="pop-cl" /></li></ul><ul id="pop-widget-viewed-5"><li><a href="https://www.barbadostoday.bb/2017/04/19/plumber-drops-dead/" title="Plumber drops dead" rel="bookmark"><img width="900" height="470" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1-650x339.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1-768x401.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1-93x50.jpg 93w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1-160x84.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1-640x334.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1-800x418.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="197726" /><noscript><img width="900" height="470" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1-650x339.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1-768x401.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1-93x50.jpg 93w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1-160x84.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1-640x334.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/Untitled-2-1-800x418.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="197726" /></noscript><span class="pop-overlay"><span class="pop-title">Plumber drops dead</span> <span class="pop-summary">Family and friends of 57-year-old Michael Plumber Alleyne today said...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/04/21/cashier-charged-with-stealing-28000/" title="Cashier charged with stealing $28,000" rel="bookmark"><img width="900" height="401" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/JanilaXWilloughbyXcopy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/JanilaXWilloughbyXcopy.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/JanilaXWilloughbyXcopy-650x290.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/JanilaXWilloughbyXcopy-768x342.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/JanilaXWilloughbyXcopy-160x71.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/JanilaXWilloughbyXcopy-640x285.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/JanilaXWilloughbyXcopy-800x356.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="197980" /><noscript><img width="900" height="401" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/JanilaXWilloughbyXcopy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/JanilaXWilloughbyXcopy.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/JanilaXWilloughbyXcopy-650x290.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/JanilaXWilloughbyXcopy-768x342.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/JanilaXWilloughbyXcopy-160x71.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/JanilaXWilloughbyXcopy-640x285.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/JanilaXWilloughbyXcopy-800x356.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="197980" /></noscript><span class="pop-overlay"><span class="pop-title">Cashier charged with stealing $28,000</span> <span class="pop-summary">A cashier was granted bail Friday after appearing in the District...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/04/21/ninja-man-pepper-sprayed/" title="Ninja Man pepper sprayed" rel="bookmark"><img width="405" height="247" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/ScreenXShotX2017-04-20XatX7.56.43XPM.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/ScreenXShotX2017-04-20XatX7.56.43XPM.png 405w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/ScreenXShotX2017-04-20XatX7.56.43XPM-160x98.png 160w" data-lazy-sizes="(max-width: 405px) 100vw, 405px" data-wp-pid="197864" /><noscript><img width="405" height="247" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/ScreenXShotX2017-04-20XatX7.56.43XPM.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/ScreenXShotX2017-04-20XatX7.56.43XPM.png 405w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/ScreenXShotX2017-04-20XatX7.56.43XPM-160x98.png 160w" sizes="(max-width: 405px) 100vw, 405px" data-wp-pid="197864" /></noscript><span class="pop-overlay"><span class="pop-title">Ninja Man pepper sprayed</span> <span class="pop-summary">An apparent pepper spray attack on Ninja Man, one of...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/04/25/too-lewd/" title="Too lewd" rel="bookmark"><img width="900" height="395" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/backpage-3.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/backpage-3.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/backpage-3-650x285.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/backpage-3-768x337.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/backpage-3-160x70.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/backpage-3-640x281.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/backpage-3-800x351.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="198222" /><noscript><img width="900" height="395" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/backpage-3.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/backpage-3.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/backpage-3-650x285.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/backpage-3-768x337.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/backpage-3-160x70.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/backpage-3-640x281.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/backpage-3-800x351.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="198222" /></noscript><span class="pop-overlay"><span class="pop-title">Too lewd</span> <span class="pop-summary">Local entertainment promoter FAS Promotions is being accused of promoting...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/04/21/sharefas-back/" title="Sharefa&#039;s back" rel="bookmark"><img width="900" height="404" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/DSC_0298Xcopy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/DSC_0298Xcopy.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/DSC_0298Xcopy-650x292.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/DSC_0298Xcopy-768x345.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/DSC_0298Xcopy-160x72.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/DSC_0298Xcopy-640x287.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/DSC_0298Xcopy-800x359.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="197991" /><noscript><img width="900" height="404" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/DSC_0298Xcopy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/DSC_0298Xcopy.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/DSC_0298Xcopy-650x292.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/DSC_0298Xcopy-768x345.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/DSC_0298Xcopy-160x72.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/DSC_0298Xcopy-640x287.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/04/DSC_0298Xcopy-800x359.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="197991" /></noscript><span class="pop-overlay"><span class="pop-title">Sharefa's back</span> <span class="pop-summary">After suffering through three years of restless nights and intolerable...</span></span></a><br class="pop-cl" /></li></ul></div></div></div></div><div id="gabfire_archive_widget-3" class="widget gabfire_archive_widget"><div class="widgetinner"><h3 class="widgettitle">Search in Archive</h3><div style="background:transparent"><form action="https://www.barbadostoday.bb/"  method="get" > <label>Select a Month</label> <select name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'><option value="">Click to Select</option><option value='https://www.barbadostoday.bb/2017/04/'> April 2017</option><option value='https://www.barbadostoday.bb/2017/03/'> March 2017</option><option value='https://www.barbadostoday.bb/2017/02/'> February 2017</option><option value='https://www.barbadostoday.bb/2017/01/'> January 2017</option><option value='https://www.barbadostoday.bb/2016/12/'> December 2016</option><option value='https://www.barbadostoday.bb/2016/11/'> November 2016</option><option value='https://www.barbadostoday.bb/2016/10/'> October 2016</option><option value='https://www.barbadostoday.bb/2016/09/'> September 2016</option><option value='https://www.barbadostoday.bb/2016/08/'> August 2016</option><option value='https://www.barbadostoday.bb/2016/07/'> July 2016</option><option value='https://www.barbadostoday.bb/2016/06/'> June 2016</option><option value='https://www.barbadostoday.bb/2016/05/'> May 2016</option><option value='https://www.barbadostoday.bb/2016/04/'> April 2016</option><option value='https://www.barbadostoday.bb/2016/03/'> March 2016</option><option value='https://www.barbadostoday.bb/2016/02/'> February 2016</option><option value='https://www.barbadostoday.bb/2016/01/'> January 2016</option><option value='https://www.barbadostoday.bb/2015/12/'> December 2015</option><option value='https://www.barbadostoday.bb/2015/11/'> November 2015</option><option value='https://www.barbadostoday.bb/2015/10/'> October 2015</option><option value='https://www.barbadostoday.bb/2015/09/'> September 2015</option><option value='https://www.barbadostoday.bb/2015/08/'> August 2015</option><option value='https://www.barbadostoday.bb/2015/07/'> July 2015</option><option value='https://www.barbadostoday.bb/2015/06/'> June 2015</option><option value='https://www.barbadostoday.bb/2015/05/'> May 2015</option><option value='https://www.barbadostoday.bb/2015/04/'> April 2015</option><option value='https://www.barbadostoday.bb/2015/03/'> March 2015</option><option value='https://www.barbadostoday.bb/2015/02/'> February 2015</option><option value='https://www.barbadostoday.bb/2015/01/'> January 2015</option><option value='https://www.barbadostoday.bb/2014/12/'> December 2014</option><option value='https://www.barbadostoday.bb/2014/11/'> November 2014</option><option value='https://www.barbadostoday.bb/2014/10/'> October 2014</option><option value='https://www.barbadostoday.bb/2014/09/'> September 2014</option><option value='https://www.barbadostoday.bb/2014/08/'> August 2014</option><option value='https://www.barbadostoday.bb/2014/07/'> July 2014</option><option value='https://www.barbadostoday.bb/2014/06/'> June 2014</option><option value='https://www.barbadostoday.bb/2014/05/'> May 2014</option><option value='https://www.barbadostoday.bb/2014/04/'> April 2014</option><option value='https://www.barbadostoday.bb/2014/03/'> March 2014</option><option value='https://www.barbadostoday.bb/2014/02/'> February 2014</option><option value='https://www.barbadostoday.bb/2014/01/'> January 2014</option><option value='https://www.barbadostoday.bb/2013/12/'> December 2013</option><option value='https://www.barbadostoday.bb/2013/11/'> November 2013</option><option value='https://www.barbadostoday.bb/2013/10/'> October 2013</option><option value='https://www.barbadostoday.bb/2013/09/'> September 2013</option><option value='https://www.barbadostoday.bb/2013/08/'> August 2013</option><option value='https://www.barbadostoday.bb/2013/07/'> July 2013</option><option value='https://www.barbadostoday.bb/2013/06/'> June 2013</option><option value='https://www.barbadostoday.bb/2013/05/'> May 2013</option><option value='https://www.barbadostoday.bb/2013/04/'> April 2013</option><option value='https://www.barbadostoday.bb/2013/03/'> March 2013</option><option value='https://www.barbadostoday.bb/2013/02/'> February 2013</option><option value='https://www.barbadostoday.bb/2013/01/'> January 2013</option><option value='https://www.barbadostoday.bb/2012/12/'> December 2012</option><option value='https://www.barbadostoday.bb/2012/11/'> November 2012</option><option value='https://www.barbadostoday.bb/2012/10/'> October 2012</option><option value='https://www.barbadostoday.bb/2012/09/'> September 2012</option><option value='https://www.barbadostoday.bb/2012/08/'> August 2012</option><option value='https://www.barbadostoday.bb/2012/07/'> July 2012</option> </select></form><form action="https://www.barbadostoday.bb/"  method="get" > <label>Select a Category</label> <select  name='cat' id='cat' class='postform' ><option value='-1'>Click to Select</option><option class="level-0" value="1241">Add</option><option class="level-0" value="1166">Baseball</option><option class="level-0" value="91">Business</option><option class="level-1" value="1152">&nbsp;&nbsp;&nbsp;Banking</option><option class="level-1" value="204">&nbsp;&nbsp;&nbsp;Entrepreneurship</option><option class="level-1" value="231">&nbsp;&nbsp;&nbsp;Indus. Relations</option><option class="level-1" value="159">&nbsp;&nbsp;&nbsp;Int&#8217;l Business</option><option class="level-1" value="1124">&nbsp;&nbsp;&nbsp;Real Estate</option><option class="level-1" value="160">&nbsp;&nbsp;&nbsp;Social Partnership</option><option class="level-1" value="161">&nbsp;&nbsp;&nbsp;Stock Exchange</option><option class="level-1" value="162">&nbsp;&nbsp;&nbsp;Tourism</option><option class="level-0" value="1221">CARICOM</option><option class="level-0" value="92">Column</option><option class="level-0" value="1171">Court</option><option class="level-0" value="1234">Cricket</option><option class="level-0" value="1238">Crime</option><option class="level-0" value="1213">Culture</option><option class="level-0" value="1240">Dominica</option><option class="level-0" value="93">Editorial</option><option class="level-0" value="1231">Entertainment</option><option class="level-0" value="1225">Feature</option><option class="level-0" value="96">Features</option><option class="level-0" value="825">Focus</option><option class="level-0" value="1226">Global</option><option class="level-0" value="1243">Health</option><option class="level-0" value="1172">Independence Feature</option><option class="level-0" value="1227">International</option><option class="level-0" value="1222">Jamaica</option><option class="level-0" value="94">Leisure</option><option class="level-1" value="192">&nbsp;&nbsp;&nbsp;Crop Over</option><option class="level-2" value="223">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Foreday Mornin&#8217;</option><option class="level-2" value="221">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Junior Kadooment</option><option class="level-2" value="1119">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Junior Monarch</option><option class="level-2" value="220">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Kadooment Day</option><option class="level-2" value="222">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Pic-O-De-Crop</option><option class="level-1" value="107">&nbsp;&nbsp;&nbsp;Entertainment</option><option class="level-2" value="1193">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Music</option><option class="level-1" value="912">&nbsp;&nbsp;&nbsp;NIFCA</option><option class="level-0" value="97">Letters</option><option class="level-0" value="98">Lifestyle</option><option class="level-1" value="179">&nbsp;&nbsp;&nbsp;Body</option><option class="level-1" value="195">&nbsp;&nbsp;&nbsp;Food</option><option class="level-1" value="189">&nbsp;&nbsp;&nbsp;Mind</option><option class="level-1" value="163">&nbsp;&nbsp;&nbsp;Recipes</option><option class="level-1" value="190">&nbsp;&nbsp;&nbsp;Spirit</option><option class="level-0" value="1236">Local</option><option class="level-0" value="1230">Local HNews</option><option class="level-0" value="99">Local News</option><option class="level-1" value="440">&nbsp;&nbsp;&nbsp;Agriculture</option><option class="level-1" value="920">&nbsp;&nbsp;&nbsp;Church</option><option class="level-1" value="1118">&nbsp;&nbsp;&nbsp;CLICO</option><option class="level-1" value="205">&nbsp;&nbsp;&nbsp;Crime</option><option class="level-1" value="571">&nbsp;&nbsp;&nbsp;Culture</option><option class="level-1" value="233">&nbsp;&nbsp;&nbsp;Economy</option><option class="level-1" value="206">&nbsp;&nbsp;&nbsp;Education</option><option class="level-1" value="809">&nbsp;&nbsp;&nbsp;Emergency</option><option class="level-1" value="226">&nbsp;&nbsp;&nbsp;Energy</option><option class="level-1" value="227">&nbsp;&nbsp;&nbsp;Environment</option><option class="level-1" value="977">&nbsp;&nbsp;&nbsp;Foreign Affairs</option><option class="level-1" value="207">&nbsp;&nbsp;&nbsp;Health Care</option><option class="level-1" value="214">&nbsp;&nbsp;&nbsp;Housing</option><option class="level-1" value="1220">&nbsp;&nbsp;&nbsp;Immigration</option><option class="level-1" value="869">&nbsp;&nbsp;&nbsp;Judicial</option><option class="level-1" value="1126">&nbsp;&nbsp;&nbsp;Legistlature</option><option class="level-1" value="1117">&nbsp;&nbsp;&nbsp;National Insurance</option><option class="level-1" value="1153">&nbsp;&nbsp;&nbsp;Social Care</option><option class="level-1" value="658">&nbsp;&nbsp;&nbsp;Technology</option><option class="level-1" value="913">&nbsp;&nbsp;&nbsp;Telecommunications</option><option class="level-1" value="213">&nbsp;&nbsp;&nbsp;Transportation</option><option class="level-1" value="441">&nbsp;&nbsp;&nbsp;Work force</option><option class="level-0" value="1229">Local Newsc</option><option class="level-0" value="1232">Locsl News</option><option class="level-0" value="1237">News</option><option class="level-0" value="883">Off-beat</option><option class="level-0" value="102">Politics</option><option class="level-1" value="1219">&nbsp;&nbsp;&nbsp;Budget</option><option class="level-1" value="212">&nbsp;&nbsp;&nbsp;Elections 2013</option><option class="level-1" value="211">&nbsp;&nbsp;&nbsp;House of Assembly</option><option class="level-1" value="210">&nbsp;&nbsp;&nbsp;Senate</option><option class="level-0" value="430">Public Relations</option><option class="level-0" value="1202">Region</option><option class="level-0" value="103">Regional</option><option class="level-1" value="180">&nbsp;&nbsp;&nbsp;Antigua</option><option class="level-1" value="184">&nbsp;&nbsp;&nbsp;Bahamas</option><option class="level-1" value="657">&nbsp;&nbsp;&nbsp;Bermuda</option><option class="level-1" value="1165">&nbsp;&nbsp;&nbsp;British Virgin Islands</option><option class="level-1" value="187">&nbsp;&nbsp;&nbsp;CARICOM</option><option class="level-1" value="846">&nbsp;&nbsp;&nbsp;Cayman Islands</option><option class="level-1" value="188">&nbsp;&nbsp;&nbsp;CCJ</option><option class="level-1" value="1157">&nbsp;&nbsp;&nbsp;Cuba</option><option class="level-1" value="845">&nbsp;&nbsp;&nbsp;Dominica</option><option class="level-1" value="907">&nbsp;&nbsp;&nbsp;Grenada</option><option class="level-1" value="804">&nbsp;&nbsp;&nbsp;Guyana</option><option class="level-1" value="829">&nbsp;&nbsp;&nbsp;Haiti</option><option class="level-1" value="183">&nbsp;&nbsp;&nbsp;Jamaica</option><option class="level-1" value="186">&nbsp;&nbsp;&nbsp;LIAT</option><option class="level-1" value="1102">&nbsp;&nbsp;&nbsp;St Kitts &amp; Nevis</option><option class="level-1" value="741">&nbsp;&nbsp;&nbsp;St Lucia</option><option class="level-1" value="659">&nbsp;&nbsp;&nbsp;St Vincent</option><option class="level-1" value="182">&nbsp;&nbsp;&nbsp;Trinidad &amp; Tobago</option><option class="level-1" value="185">&nbsp;&nbsp;&nbsp;UWI</option><option class="level-0" value="104">Slider</option><option class="level-0" value="95">Special Events</option><option class="level-0" value="1244">Sport</option><option class="level-0" value="105">Sports</option><option class="level-1" value="837">&nbsp;&nbsp;&nbsp;Athletics</option><option class="level-1" value="842">&nbsp;&nbsp;&nbsp;Badminton</option><option class="level-1" value="717">&nbsp;&nbsp;&nbsp;Basketball</option><option class="level-1" value="1120">&nbsp;&nbsp;&nbsp;Beach Soccer</option><option class="level-1" value="858">&nbsp;&nbsp;&nbsp;Body building</option><option class="level-1" value="616">&nbsp;&nbsp;&nbsp;Boxing</option><option class="level-1" value="1169">&nbsp;&nbsp;&nbsp;Chess</option><option class="level-1" value="164">&nbsp;&nbsp;&nbsp;Cricket</option><option class="level-1" value="916">&nbsp;&nbsp;&nbsp;Cycling</option><option class="level-1" value="1164">&nbsp;&nbsp;&nbsp;Draughts</option><option class="level-1" value="165">&nbsp;&nbsp;&nbsp;Field Hockey</option><option class="level-1" value="442">&nbsp;&nbsp;&nbsp;Fishing</option><option class="level-1" value="577">&nbsp;&nbsp;&nbsp;Fitness</option><option class="level-1" value="166">&nbsp;&nbsp;&nbsp;Football</option><option class="level-1" value="470">&nbsp;&nbsp;&nbsp;Golf</option><option class="level-1" value="1170">&nbsp;&nbsp;&nbsp;Gymnastics</option><option class="level-1" value="919">&nbsp;&nbsp;&nbsp;Hockey</option><option class="level-1" value="196">&nbsp;&nbsp;&nbsp;Horse Racing</option><option class="level-1" value="617">&nbsp;&nbsp;&nbsp;Martial Arts</option><option class="level-1" value="167">&nbsp;&nbsp;&nbsp;Motor Sport</option><option class="level-1" value="168">&nbsp;&nbsp;&nbsp;Netball</option><option class="level-1" value="1217">&nbsp;&nbsp;&nbsp;Olympics</option><option class="level-1" value="432">&nbsp;&nbsp;&nbsp;Polo</option><option class="level-1" value="169">&nbsp;&nbsp;&nbsp;Road Tennis</option><option class="level-1" value="554">&nbsp;&nbsp;&nbsp;Rugby</option><option class="level-1" value="848">&nbsp;&nbsp;&nbsp;Sailing</option><option class="level-1" value="922">&nbsp;&nbsp;&nbsp;School</option><option class="level-1" value="1167">&nbsp;&nbsp;&nbsp;Shooting</option><option class="level-1" value="863">&nbsp;&nbsp;&nbsp;Squash</option><option class="level-1" value="917">&nbsp;&nbsp;&nbsp;Surfing</option><option class="level-1" value="433">&nbsp;&nbsp;&nbsp;Swimming</option><option class="level-1" value="651">&nbsp;&nbsp;&nbsp;Tennis</option><option class="level-1" value="170">&nbsp;&nbsp;&nbsp;Track and Field</option><option class="level-1" value="921">&nbsp;&nbsp;&nbsp;Volleyball</option><option class="level-1" value="718">&nbsp;&nbsp;&nbsp;Weightlifting</option><option class="level-1" value="826">&nbsp;&nbsp;&nbsp;Yachting</option><option class="level-0" value="1223">St Vincent</option><option class="level-0" value="1228">Tourism</option><option class="level-0" value="1233">Trinidad</option><option class="level-0" value="1214">UK</option><option class="level-0" value="1">Uncategorized</option><option class="level-0" value="1235">United States</option><option class="level-0" value="1205">Venezuela</option><option class="level-0" value="106">World</option><option class="level-1" value="203">&nbsp;&nbsp;&nbsp;Africa</option><option class="level-1" value="201">&nbsp;&nbsp;&nbsp;Asia</option><option class="level-1" value="1188">&nbsp;&nbsp;&nbsp;Australia</option><option class="level-1" value="198">&nbsp;&nbsp;&nbsp;Canada</option><option class="level-1" value="200">&nbsp;&nbsp;&nbsp;Europe</option><option class="level-1" value="805">&nbsp;&nbsp;&nbsp;India</option><option class="level-1" value="1125">&nbsp;&nbsp;&nbsp;Latin America</option><option class="level-1" value="1121">&nbsp;&nbsp;&nbsp;Middle East</option><option class="level-1" value="202">&nbsp;&nbsp;&nbsp;United Kingdom</option><option class="level-1" value="199">&nbsp;&nbsp;&nbsp;USA</option><option class="level-0" value="1242">ws</option> </select></form> <script type="text/javascript">var dropdown=document.getElementById("cat");function onCatChange(){if(dropdown.options[dropdown.selectedIndex].value>0){location.href="https://www.barbadostoday.bb/?cat="+dropdown.options[dropdown.selectedIndex].value;}}
dropdown.onchange=onCatChange;</script> <form method="get" action="//www.google.com/search"> <label>Search with Google</label> <input name="q" class="google" value="Write keyword and hit return" onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;" /> <input type="hidden" name="sitesearch" value="https://www.barbadostoday.bb/" /></form></div><div class='clear'></div></div></div><div class="widget"> <script>broadstreet.zone(51860);</script> <br> <br> <script>broadstreet.zone(50036);</script> </div></div></div></div></div><div id="footer"><div id="foo_widget1"><div id="gab_about_widget-2" class="widget gab_about_widget"><div class="widgetinner"><h3 class="widgettitle">Barbados Today</h3><p>Our <a href="/about-us">mission</a> is to keep you informed. Do you have news, know of an event or a personality deserving of coverage? <a href="/contact-us">Contact us</a> today! Nothing or no one is too big or too small for us at Barbados Today to highlight. You can also take your own good quality photographs of community events <a href="/contact-us/">and drop us a note</a> with the details.</p><div class="clear clearfix"></div><div class='clear'></div></div></div><div id="text-6" class="widget widget_text"><div class="widgetinner"><div class="textwidget"><p>Mr Peter Harris<br /> Chairman</p><p>Ms Kaymar Jordan<br /> Chief Executive Officer & Editor-in-Chief<br /> Tel:(246) 417- 1000</p><p>Mrs Sandy Deane<br /> Editorial Coordinator<br /> Tel:(246) 417- 1000</p><p>Mr Wade Gibbons<br /> Sports Coordinator<br /> Tel:(246) 417- 1000</p><p>Mr David Williams<br /> Advertising / Sales Manager<br /> Tel:(246) 417- 1005</p><p>Mr Henry Richards<br /> Creative / Technical Manager<br /> Tel:(246) 417- 1032</p></div></div></div></div><div id="foo_widget2"><div id="gabfire_social_widget-3" class="widget gabfire_social_widget"><div class="widgetinner"><h3 class="widgettitle">Connect</h3> <a target="_blank" class="facebook" href="https://www.facebook.com/BarbadosToday" rel="nofollow">Facebook</a><a target="_blank" class="twitter" href="https://twitter.com/barbadostoday" rel="nofollow">Twitter</a><a target="_blank" class="feed" href="https://www.barbadostoday.bb/feed" rel="nofollow">RSS Feed</a><a target="_blank" class="instagram" href="https://www.instagram.com/barbadostoday" rel="nofollow">instagram</a><a target="_blank" class="plus1" href="https://plus.google.com/+barbadostoday" rel="nofollow">Google +1</a><a target="_blank" class="youtube" href="https://www.youtube.com/user/barbadostoday" rel="nofollow">Youtube</a><div class="clear clearfix"></div><div class='clear'></div></div></div><div id="text-8" class="widget widget_text"><div class="widgetinner"><div class="textwidget">Barbados Today<br> Suite F3, Building 3,<br> Manor Lodge Complex,<br> Lodge Hill, St. Michael.<br> +1 (246) 417-1000<br> editor@barbadostoday.bb</div></div></div></div></div><div id="footer_data"><ul class="footerpages"><li class="first"><a href="https://www.barbadostoday.bb/" title="News you can trust.">Home</a></li><li id="menu-item-49906" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49906"><a href="https://www.barbadostoday.bb/about-us/">About Us</a></li><li id="menu-item-49907" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49907"><a href="https://www.barbadostoday.bb/contact-us/">Contact Us</a></li><li id="menu-item-49908" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49908"><a href="https://www.barbadostoday.bb/privacy-policy/">Privacy Policy</a></li><li id="menu-item-49909" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49909"><a href="https://www.barbadostoday.bb/terms-of-service/">Terms of Service</a></li><li id="menu-item-152108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152108"><a href="https://www.barbadostoday.bb/advertising/">Advertising</a></li><li><a rel="nofollow" href="https://www.barbadostoday.bb/feed/">RSS</a></li><li class="right"><a href="#top" title="Barbados Today" rel="home"><strong>&uarr;</strong> Barbados Today</a></li></ul><div class="clear"></div><p id="footer-left-side"> <a href="https://www.barbadostoday.bb/" title="Barbados Today" rel="home">Barbados Today</a></p><p id="footer-right-side"> <a href="https://www.barbadostoday.bb/wp-login.php">Log in</a> - <a href="http://wordpress.org/" title="Semantic Personal Publishing Platform" rel="generator">Powered by WordPress</a> -
Designed by <a href="http://www.gabfirethemes.com/" title="Premium WordPress Themes">Gabfire Themes</a> <script type="text/javascript">analytics.track("Viewed Post",{"title":"Patel remanded on firearm and other serious charges","category":"Court","noninteraction":true},{"library":"analytics-wordpress"});</script> <script>broadstreet.watch({})</script> <div id="fb-root"></div> <script type='text/javascript'>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_US/all.js#xfbml=1";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script> <script type='text/javascript'>var popwid={"postid":"198202","ajaxurl":"https:\/\/www.barbadostoday.bb\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://16f6e5e6d2.site.internapcdn.net/wp-content/plugins/popular-widget/_js/pop-widget.js?ver=1.7.0'></script>  <script src="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/8ee7ea802006a49b1c4f792b5d023cec.js" data-minify="1"></script> </p></div></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1493126367 -->