<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head profile="http://gmpg.org/xfn/11"><link rel="stylesheet" href="//fonts.googleapis.com/css?family=Open+Sans%3A400%2C300" /><link rel="stylesheet" href="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/d24ce6e35fda1deb76128d6d192e7348.css" data-minify="1"/><link rel="stylesheet" href="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/7a26329767cf585c809b15a0ac895d35.css" data-minify="1"/><script type='text/javascript' data-cfasync='false' src='https://cdn.broadstreetads.com/init-2.min.js?ver=4.7.3'></script><script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js?ver=4.7.3'></script><script src="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/800281c99935d9aafd7b39f99cedda03.js" data-minify="1"></script><script src="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/b78ab7ebe977a13d37f848a6a272837f.js" data-minify="1"></script><script src="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/fd6a7471b5afebabb860d1e638e3e040.js" data-minify="1"></script> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><title> New laws coming to protect abandoned elderly citizens | Barbados Today</title><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://www.barbadostoday.bb/feed/" /><link rel="pingback" href="https://www.barbadostoday.bb/xmlrpc.php" /> <script type="text/javascript">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</script> <meta name="robots" content="noodp,noydir" /><meta name="description" content="New laws coming to protect abandoned elderly citizens | Barbadians who abandon their elderly relatives to the mercy of the state, or worse yet, to the&#8230;" /><link rel="canonical" href="https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/" /><link rel='dns-prefetch' href='//cdn.broadstreetads.com' /><link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel='dns-prefetch' href='//16f6e5e6d2.site.internapcdn.net' /><link rel="alternate" type="application/rss+xml" title="Barbados Today &raquo; Feed" href="https://www.barbadostoday.bb/feed/" /><link rel="alternate" type="application/rss+xml" title="Barbados Today &raquo; Comments Feed" href="https://www.barbadostoday.bb/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Barbados Today &raquo; New laws coming to protect abandoned elderly citizens Comments Feed" href="https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/16f6e5e6d2.site.internapcdn.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><style id='awesome-weather-inline-css' type='text/css'>.awesome-weather-wrap{font-family:'Open Sans',sans-serif;font-weight:400;font-size:14px;line-height:14px}</style> <script type="text/javascript">/*<![CDATA[*/!function(){var analytics=window.analytics=window.analytics||[];if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.0.0";window.analytics.load("vky0x5mb1o");window.analytics.page();}}();/*]]>*/</script> <link rel='https://api.w.org/' href='https://www.barbadostoday.bb/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.barbadostoday.bb/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.barbadostoday.bb/wp-includes/wlwmanifest.xml" /><link rel="alternate" type="application/json+oembed" href="https://www.barbadostoday.bb/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.barbadostoday.bb%2F2017%2F03%2F27%2Fnew-laws-coming-to-protect-abandoned-elderly-citizens%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.barbadostoday.bb/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.barbadostoday.bb%2F2017%2F03%2F27%2Fnew-laws-coming-to-protect-abandoned-elderly-citizens%2F&#038;format=xml" /><style type="text/css">.ad728{height:90px}.mastheadnav{width:580px;margin-top:10px}#gabfire_social_widget-2.widget.gabfire_social_widget{width:165px;height:53px}.gabfire_social_widget
a{margin:3px
3px}#content .single-default
p{line-height:1.5;margin-bottom:1.7em}#foo_widget1{font-size:12px}.news_wrapper{margin-bottom:15px}#mainmenu{display:block;background:#27aae1;border-top:1px solid #082133}#footer{background:#17478E}#footer
.widgettitle{border-bottom:1px dotted #fff}.newsblock .right .posttitle
a{color:#1282C4}#respond .form-submit
#submit{height:30px}#footer-left-side{display:none}#footer-right-side{display:none}div.pop-inside ul li .pop-summary{color:#555}.wp-caption-text{line-height:1.2;margin-top:7px}</style> <script type='text/javascript'>(function($){$(document).ready(function(){$('a[href="#top"]').click(function(){$('html, body').animate({scrollTop:0},'slow');return false;});$('#slides').slides({autoHeight:true});$("ul.tabs").tabs("div.panes > div");$("ul.sc_tabs").tabs("div.sc_tabs-content > div");});})(jQuery);</script> <link rel="shortcut icon" href="https://www.barbadostoday.bb/wp-content/uploads/2011/12/favicon.gif"/><meta name="wpsso:mark:begin" content="wpsso meta tags begin"/><meta name="generator" content="WPSSO Pro 3.40.6-1/L"/><meta name="generator" content="WPSSO SSB Pro 2.3.12-1/L"/><meta name="generator" content="WPSSO UM 1.5.18-1/G"/><link rel="publisher" href="https://plus.google.com/+barbadostoday/"/><link rel="shortlink" href="https://www.barbadostoday.bb/?p=195183"/><meta property="fb:app_id" content="613718815307708"/><meta property="og:url" content="https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/"/><meta property="og:type" content="article"/><meta property="og:locale" content="en_US"/><meta property="og:site_name" content="Barbados Today"/><meta property="og:title" content="New laws coming to protect abandoned elderly citizens"/><meta property="og:description" content="Barbadians who abandon their elderly relatives to the mercy of the state, or worse yet, to the elements, will be prevented from receiving pension cheques belonging to the abandoned relatives under new..."/><meta property="og:image" content="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2015/01/page-9-Senator-Reverend-David-Durant.jpg"/><meta property="og:image:width" content="400"/><meta property="og:image:height" content="311"/><meta property="article:publisher" content="https://www.facebook.com/BarbadosToday"/><meta property="article:published_time" content="2017-03-28T03:19:05+00:00"/><meta property="article:modified_time" content="2017-03-28T02:17:52+00:00"/><meta property="og:updated_time" content="2017-03-28T02:17:52+00:00"/><meta name="weibo:article:create_at" content="2017-03-28 03:19:05"/><meta name="weibo:article:update_at" content="2017-03-28 02:17:52"/><meta name="twitter:domain" content="www.barbadostoday.bb"/><meta name="twitter:site" content="@barbadostoday"/><meta name="twitter:title" content="New laws coming to protect abandoned elderly citizens"/><meta name="twitter:description" content="Barbadians who abandon their elderly relatives to the mercy of the state, or worse yet, to the elements, will be prevented from receiving pension cheques belonging to the abandoned relatives under..."/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2015/01/page-9-Senator-Reverend-David-Durant.jpg"/><meta itemprop="url" content="https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/"/><meta itemprop="name" content="New laws coming to protect abandoned elderly citizens"/><meta itemprop="description" content="Barbadians who abandon their elderly relatives to the mercy of the state, or worse yet, to the elements, will be prevented from receiving pension cheques belonging to the abandoned relatives under new..."/><meta name="author" content="Colville Mounsey"/> <noscript itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Colville Mounsey"/> </noscript><meta name="wpsso:mark:end" content="wpsso meta tags end"/> <script type="text/javascript" id="wpssossb-header-script">window.___gcfg={lang:"en-US"};function wpsso_insert_js(script_id,url,async){if(document.getElementById(script_id+"-js"))return;var async=typeof async!=="undefined"?async:true;var script_pos=document.getElementById(script_id);var js=document.createElement("script");js.id=script_id+"-js";js.async=async;js.type="text/javascript";js.language="JavaScript";js.src=url;script_pos.parentNode.insertBefore(js,script_pos);};</script> 
 <script type="text/javascript" id="fb-script-header">/*<![CDATA[*/wpsso_insert_js("fb-script-header","https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=613718815307708");/*]]>*/</script> <script type="text/javascript" id="gplus-script-header">wpsso_insert_js("gplus-script-header","https://apis.google.com/js/plusone.js");</script> <script type="text/javascript" id="linkedin-script-header">wpsso_insert_js("linkedin-script-header","https://platform.linkedin.com/in.js");</script> <script type="text/javascript" id="twitter-script-header">wpsso_insert_js("twitter-script-header","https://platform.twitter.com/widgets.js");</script>  <script data-no-minify="1" data-cfasync="false">(function(w,d){function a(){var b=d.createElement("script");b.async=!0;b.src="https://16f6e5e6d2.site.internapcdn.net/wp-content/plugins/wp-rocket/inc/front/js/lazyload.1.0.5.min.js";var a=d.getElementsByTagName("script")[0];a.parentNode.insertBefore(b,a)}w.attachEvent?w.attachEvent("onload",a):w.addEventListener("load",a,!1)})(window,document);</script> <style type="text/css" media="screen">body{font-size:14px;font-family:arial;font-weight:normal;color:#555}a{color:#27aae1}h2.posttitle{font-size:18px;font-family:arial;font-weight:normal;color:#555}h2.posttitle
a{color:#034693}.widgettitle{font-size:14px;font-family:arial;font-weight:normal;color:#555}.catname
span{font-size:22px;font-family:arial;font-weight:normal;color:#555}</style><broadstreet-zone zone-id="54052"></broadstreet-zone> <broadstreet-zone zone-id="51273"></broadstreet-zone> <broadstreet-zone zone-id="51634"></broadstreet-zone> <broadstreet-zone zone-id="51320"></broadstreet-zone></head><body class="post-template-default single single-post postid-195183 single-format-standard"><div class="ad728"> <script>broadstreet.zone(50028);</script> </div><div class="wrapper"><div id="masthead"><ul class="mastheadnav dropdown"><li class="first"><a href="https://www.barbadostoday.bb/" title="News you can trust.">Home</a></li><li id="menu-item-50433" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50433"><a title="Our Print-Style Publication" href="http://epaper.barbadostoday.bb">ePaper</a></li><li id="menu-item-142207" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142207"><a href="https://www.barbadostoday.bb/download-todays-news-app/">Mobile App</a></li><li id="menu-item-142206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142206"><a href="https://www.barbadostoday.bb/newsletters/">Newsletters</a></li><li id="menu-item-142202" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142202"><a href="https://www.facebook.com/barbadostoday">Facebook</a></li><li id="menu-item-142205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142205"><a href="https://www.youtube.com/user/barbadostoday?&#038;ab_channel=BarbadosToday">YouTube</a></li><li id="menu-item-142203" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142203"><a href="https://twitter.com/barbadostoday">Twitter</a></li><li id="menu-item-142201" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142201"><a href="https://instagram.com/barbadostoday/">Instagram</a></li></ul><div class="search"><form class="gabfire_search_style1" action="https://www.barbadostoday.bb/"><fieldset> <input type="text" class="gab_search_text" name="s" value="Search in site..." onfocus="if (this.value == 'Search in site...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search in site...';}" /> <input type="submit"  value="" class="submit_style1" /><div class="clearfix"></div></fieldset></form></div></div><div id="header"> <a href="https://www.barbadostoday.bb/" title="News you can trust."> <img  src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/09/BT-7th-ANn-Website-Header-2017-01-1.jpg" id="header_banner" alt="Barbados Today" title="Barbados Today"/> </a></div><div id="mainmenu"><ul class="mainnav dropdown"><li class="first"><a href="https://www.barbadostoday.bb/" title="News you can trust.">Home</a></li><li id="menu-item-157940" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-157940"><a href="https://www.barbadostoday.bb/category/local-news/">Local News</a><ul class="sub-menu"><li id="menu-item-157948" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157948"><a href="https://www.barbadostoday.bb/category/local-news/agriculture/">Agriculture</a></li><li id="menu-item-157949" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157949"><a href="https://www.barbadostoday.bb/category/local-news/church/">Church</a></li><li id="menu-item-157951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157951"><a href="https://www.barbadostoday.bb/category/court/">Court</a></li><li id="menu-item-157952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157952"><a href="https://www.barbadostoday.bb/category/local-news/crime/">Crime</a></li><li id="menu-item-157953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157953"><a href="https://www.barbadostoday.bb/category/local-news/culture/">Culture</a></li><li id="menu-item-157954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157954"><a href="https://www.barbadostoday.bb/category/local-news/economy/">Economy</a></li><li id="menu-item-157955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157955"><a href="https://www.barbadostoday.bb/category/local-news/education/">Education</a></li><li id="menu-item-157957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157957"><a href="https://www.barbadostoday.bb/category/local-news/energy/">Energy</a></li><li id="menu-item-157958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157958"><a href="https://www.barbadostoday.bb/category/local-news/environment/">Environment</a></li><li id="menu-item-157959" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157959"><a href="https://www.barbadostoday.bb/category/local-news/health-care/">Health Care</a></li><li id="menu-item-157961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157961"><a href="https://www.barbadostoday.bb/category/local-news/transportation/">Transportation</a></li></ul></li><li id="menu-item-157941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157941"><a href="https://www.barbadostoday.bb/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-157962" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157962"><a href="https://www.barbadostoday.bb/category/sports/cricket/">Cricket</a></li><li id="menu-item-157963" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157963"><a href="https://www.barbadostoday.bb/category/sports/athletics/">Athletics</a></li><li id="menu-item-157964" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157964"><a href="https://www.barbadostoday.bb/category/sports/basketball/">Basketball</a></li><li id="menu-item-157965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157965"><a href="https://www.barbadostoday.bb/category/sports/football/">Football</a></li><li id="menu-item-157966" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157966"><a href="https://www.barbadostoday.bb/category/sports/motor-sport/">Motor Sport</a></li><li id="menu-item-157967" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157967"><a href="https://www.barbadostoday.bb/category/sports/netball/">Netball</a></li><li id="menu-item-157968" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157968"><a href="https://www.barbadostoday.bb/category/sports/school/">School</a></li><li id="menu-item-157969" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157969"><a href="https://www.barbadostoday.bb/category/sports/tennis/">Tennis</a></li><li id="menu-item-157970" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157970"><a href="https://www.barbadostoday.bb/category/sports/road-tennis/">Road Tennis</a></li><li id="menu-item-157971" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157971"><a href="https://www.barbadostoday.bb/category/sports/track-and-field/">Track and Field</a></li></ul></li><li id="menu-item-157944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157944"><a href="https://www.barbadostoday.bb/category/business/">Business</a><ul class="sub-menu"><li id="menu-item-157978" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157978"><a href="https://www.barbadostoday.bb/category/business/banking/">Banking</a></li><li id="menu-item-157975" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157975"><a href="https://www.barbadostoday.bb/category/business/entrepreneurship/">Entrepreneurship</a></li><li id="menu-item-157974" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157974"><a href="https://www.barbadostoday.bb/category/business/industrial-relations/">Indus. Relations</a></li><li id="menu-item-157976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157976"><a href="https://www.barbadostoday.bb/category/business/international-business/">Int&#8217;l Business</a></li><li id="menu-item-157973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157973"><a href="https://www.barbadostoday.bb/category/business/social-partnership/">Social Partnership</a></li><li id="menu-item-157977" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157977"><a href="https://www.barbadostoday.bb/category/business/stock-exchange/">Stock Exchange</a></li><li id="menu-item-157979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157979"><a href="https://www.barbadostoday.bb/category/local-news/telecommunications/">Telecommunications</a></li><li id="menu-item-157972" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157972"><a href="https://www.barbadostoday.bb/category/business/tourism/">Tourism</a></li></ul></li><li id="menu-item-158027" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-158027"><a href="https://www.barbadostoday.bb/category/leisure/entertainment/">Entertainment</a><ul class="sub-menu"><li id="menu-item-158029" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158029"><a href="https://www.barbadostoday.bb/category/leisure/entertainment/music/">Music</a></li><li id="menu-item-158005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-158005"><a href="https://www.barbadostoday.bb/category/leisure/cropover/">Crop Over</a><ul class="sub-menu"><li id="menu-item-158010" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158010"><a href="https://www.barbadostoday.bb/category/leisure/cropover/kadooment-day/">Kadooment Day</a></li><li id="menu-item-158006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158006"><a href="https://www.barbadostoday.bb/category/leisure/cropover/foreday-mornin/">Foreday Mornin&#8217;</a></li><li id="menu-item-158009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158009"><a href="https://www.barbadostoday.bb/category/leisure/cropover/pic-o-de-crop/">Pic-O-De-Crop</a></li><li id="menu-item-158007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158007"><a href="https://www.barbadostoday.bb/category/leisure/cropover/junior-kadooment/">Junior Kadooment</a></li><li id="menu-item-158008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158008"><a href="https://www.barbadostoday.bb/category/leisure/cropover/junior-monarch/">Junior Monarch</a></li></ul></li><li id="menu-item-157945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157945"><a href="https://www.barbadostoday.bb/category/leisure/">Leisure</a><ul class="sub-menu"><li id="menu-item-158002" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158002"><a href="https://www.barbadostoday.bb/category/lifestyle/recipes/">Recipes</a></li></ul></li><li id="menu-item-158028" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158028"><a href="https://www.barbadostoday.bb/category/lifestyle/">Lifestyle</a></li></ul></li><li id="menu-item-157946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157946"><a href="https://www.barbadostoday.bb/category/politics/">Politics</a><ul class="sub-menu"><li id="menu-item-157981" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157981"><a href="https://www.barbadostoday.bb/category/politics/house-of-assembly/">House of Assembly</a></li><li id="menu-item-157980" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157980"><a href="https://www.barbadostoday.bb/category/politics/senate/">Senate</a></li><li id="menu-item-157982" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157982"><a href="https://www.barbadostoday.bb/category/politics/elections-2013/">Elections 2013</a></li></ul></li><li id="menu-item-157942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157942"><a href="https://www.barbadostoday.bb/category/regional/">Regional</a><ul class="sub-menu"><li id="menu-item-157997" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157997"><a href="https://www.barbadostoday.bb/category/regional/bahamas/">Bahamas</a></li><li id="menu-item-157996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157996"><a href="https://www.barbadostoday.bb/category/regional/ccj/">CCJ</a></li><li id="menu-item-157985" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157985"><a href="https://www.barbadostoday.bb/category/regional/grenada/">Grenada</a></li><li id="menu-item-157986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157986"><a href="https://www.barbadostoday.bb/category/regional/haiti/">Haiti</a></li><li id="menu-item-157998" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157998"><a href="https://www.barbadostoday.bb/category/regional/liat/">LIAT</a></li><li id="menu-item-157988" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157988"><a href="https://www.barbadostoday.bb/category/regional/st-kitts-nevis/">St Kitts &#038; Nevis</a></li><li id="menu-item-157989" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157989"><a href="https://www.barbadostoday.bb/category/regional/st-lucia/">St Lucia</a></li><li id="menu-item-157990" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157990"><a href="https://www.barbadostoday.bb/category/regional/st-vincent/">St Vincent</a></li><li id="menu-item-157991" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157991"><a href="https://www.barbadostoday.bb/category/regional/trinidad-and-tobago/">Trinidad &#038; Tobago</a></li><li id="menu-item-157992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157992"><a href="https://www.barbadostoday.bb/category/regional/uwi/">UWI</a></li></ul></li><li id="menu-item-157943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157943"><a href="https://www.barbadostoday.bb/category/world/">World</a><ul class="sub-menu"><li id="menu-item-158011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158011"><a href="https://www.barbadostoday.bb/category/world/africa/">Africa</a></li><li id="menu-item-158012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158012"><a href="https://www.barbadostoday.bb/category/world/asia/">Asia</a></li><li id="menu-item-158013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158013"><a href="https://www.barbadostoday.bb/category/world/australia/">Australia</a></li><li id="menu-item-158014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158014"><a href="https://www.barbadostoday.bb/category/world/canada/">Canada</a></li><li id="menu-item-158015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158015"><a href="https://www.barbadostoday.bb/category/world/europe/">Europe</a></li><li id="menu-item-158016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158016"><a href="https://www.barbadostoday.bb/category/world/india/">India</a></li><li id="menu-item-158017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158017"><a href="https://www.barbadostoday.bb/category/world/latin-america/">Latin America</a></li><li id="menu-item-158018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158018"><a href="https://www.barbadostoday.bb/category/world/middle-east/">Middle East</a></li><li id="menu-item-158019" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158019"><a href="https://www.barbadostoday.bb/category/world/uk/">United Kingdom</a></li><li id="menu-item-158020" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158020"><a href="https://www.barbadostoday.bb/category/world/usa/">USA</a></li></ul></li></ul><div class="clear"></div></div><div id="submenu"><ul class="subnav dropdown"><li id="menu-item-84876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84876"><a href="https://www.barbadostoday.bb/gallery-cats/news-updates/">Video News</a></li><li id="menu-item-84877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84877"><a href="https://www.barbadostoday.bb/gallery-cats/entertainment-weekly/">Entertainment Weekly</a></li><li id="menu-item-84878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84878"><a href="https://www.barbadostoday.bb/gallery-cats/business-minute/">Business Minute</a></li><li id="menu-item-21347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21347"><a href="https://www.barbadostoday.bb/category/editorial/">Editorial</a></li><li id="menu-item-6520" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6520"><a href="https://www.barbadostoday.bb/category/column/">Columns</a></li><li id="menu-item-21349" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21349"><a href="https://www.barbadostoday.bb/category/letters/">Letters</a></li><li class="date right"> <script type="text/javascript">/*<![CDATA[*/var mydate=new Date()
var year=mydate.getYear()
if(year<1000)
year+=1900
var day=mydate.getDay()
var month=mydate.getMonth()
var daym=mydate.getDate()
if(daym<10)
daym="0"+daym
var dayarray=new Array("Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday")
var montharray=new Array("January","February","March","April","May","June","July","August","September","October","November","December")
document.write(""+dayarray[day]+", "+montharray[month]+" "+daym+", "+year+"")/*]]>*/</script> </li></ul><div class="clear"></div></div><div id="container"><div id="content"><div id="post-195183" class="entry single-default post-195183 post type-post status-publish format-standard has-post-thumbnail hentry category-local-news category-social-care"><h1 class="entry_title"> New laws coming to protect abandoned elderly citizens</h1><div class="single_postmeta"> <span class="left"> Added by <a href="https://www.barbadostoday.bb/author/colville-mounsey/">Colville Mounsey</a> on March 27, 2017.<br />Saved under <a href="https://www.barbadostoday.bb/category/local-news/" rel="category tag">Local News</a>, <a href="https://www.barbadostoday.bb/category/local-news/social-care/" rel="category tag">Social Care</a><br /> </span> <span class="right"><div id="text-11" class="widget widget_text"><div class="widgetinner"><div class="textwidget"><div class="wpsso-ssb wpsso-ssb-shortcode"><div class="ssb-buttons en_US"><div class="fb-like facebook-ssb-shortcode" id="facebook-button-post-195183"><fb:like href="https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/" send="true" layout="button_count" show_faces="false" font="arial" colorscheme="light" action="like"></fb:like></div><div class="gplusone-ssb-shortcode" id="gplusone-button-post-195183"><span class="g-plusone" data-size="medium" data-annotation="bubble" data-href="https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/"></span></div><div class="pinterest-ssb-shortcode" id="pinterest-button-post-195183"><a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.barbadostoday.bb%2F2017%2F03%2F27%2Fnew-laws-coming-to-protect-abandoned-elderly-citizens%2F&amp;media=https%3A%2F%2F16f6e5e6d2.site.internapcdn.net%2Fwp-content%2Fuploads%2F2015%2F01%2Fpage-9-Senator-Reverend-David-Durant.jpg&amp;description=Barbadians%20who%20abandon%20their%20elderly%20relatives%20to%20the%20mercy%20of%20the%20state%2C%20or%20worse%20yet%2C%20to%20the%20elements%2C%20will%20be%20prevented%20from%20receiving%20pension%20cheques%20belonging%20to%20the%20abandoned%20relatives%20under%20new..." data-pin-do="buttonPin" data-pin-zero="true" data-pin-lang="en" data-pin-shape="rect" data-pin-color="gray" data-pin-height="20" data-pin-config="beside"><img border="0" alt="Pin It" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" width="40" height="20" /><noscript><img border="0" alt="Pin It" src="https://assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" width="40" height="20" /></noscript></a></div><div class="twitter-ssb-shortcode" id="twitter-button-post-195183"><a href="https://twitter.com/share" class="twitter-share-button" data-lang="en" data-url="https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/" data-counturl="https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/" data-text="New laws coming to protect abandoned elderly citizens" data-via="barbadostoday" data-related="" data-hashtags="" data-size="medium" data-dnt="true"></a></div></div></div> <script type="text/javascript" id="pinterest-script-shortcode-footer">wpsso_insert_js("pinterest-script-shortcode-footer","https://assets.pinterest.com/js/pinit.js");</script> </div></div></div> </span><div class="clear"></div></div><p class="p1">Barbadians who abandon their elderly relatives to the mercy of the state, or worse yet, to the elements, will be prevented from receiving pension cheques belonging to the abandoned relatives under new legislation, Chairman of the National Assistance Board (NAB) David Durant has assured.</p><p class="p1">The legislation “is already drafted and would be going before parliament this year”, Durant said while delivering last Friday’s Democratic Labour Party lunchtime lecture at the party’s George Street headquarters.</p><p class="p1">The Government Senator explained that the measure would make it mandatory for the pension funds to go towards the care of the elderly person, and not to unscrupulous relatives.</p><p class="p1">“We will be able to stop that cheque from going to the family member because they have no more care of the elderly, and it will be a matter of notifying the National Insurance Scheme. I spoke to the Minister [of Social Care Steve Blackett] just a few days ago and he has a few meetings to be at, then he is going to bring it to Parliament. So it’s close, it’s going to be this year definitely. Trust me on that one,” Durant said.</p><p class="p1">The legislation to guide the use of contributory pensions was initially considered as a remedy for the growing number of elderly people abandoned at the Queen Elizabeth Hospital. However, Durant said while Government had clamped down on the practice, people were now leaving vulnerable senior relatives to fend for themselves in squalid conditions, while forcing them to sign over their pension cheques.</p><p class="p1">And many of these relatives, who sometimes cannot be found, often show up from out of nowhere to claim the pension cheques or to possess homes constructed for ailing senior citizens by the NAB, he charged.</p><p class="p1">“A number of these relatives are hiding, but if, for example, we build a new home or rebuild the place for the elderly person, relatives begin to come forward and sometimes want to even stay in the house. So we have to also look at the legislation to see if we could include that as well because we would prefer them not to be there. They also pop up when that person’s pension arrives and they take it and don’t even return to give that elderly person a glass of water, “ he complained.</p><p class="p1">In the meantime the NAB Chairman said he was petitioning Government for four acres of land upon which to construct 20 houses so that his organization would be better able to provide temporary relief for the direst circumstances.</p><div class="wpsso-ssb wpsso-ssb-content"><div class="ssb-buttons en_US"><div class="css-button email-button"> <a href="mailto:?subject=Share:%20New%20laws%20coming%20to%20protect%20abandoned%20elderly%20citizens&body=Barbadians%20who%20abandon%20their%20elderly%20relatives%20to%20the%20mercy%20of%20the%20state%2C%20or%20worse%20yet%2C%20to%20the%20elements%2C%20will%20be%20prevented%20from%20receiving%20pension%20cheques%20belonging%20to%20the%20abandoned%20relatives%20under%20new...%0D%0A%0D%0AShared%20from%20https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/%0D%0A"> <span class="ssb-icon"> <svg xmlns="http://www.w3.org/2000/svg" width="9" height="9" viewBox="0 0 28 28"> <path d="M20.11 26.147c-2.335 1.05-4.36 1.4-7.124 1.4C6.524 27.548.84 22.916.84 15.284.84 7.343 6.602.45 15.4.45c6.854 0 11.8 4.7 11.8 11.252 0 5.684-3.193 9.265-7.398 9.3-1.83 0-3.153-.934-3.347-2.997h-.077c-1.208 1.986-2.96 2.997-5.023 2.997-2.532 0-4.36-1.868-4.36-5.062 0-4.75 3.503-9.07 9.11-9.07 1.713 0 3.7.4 4.6.972l-1.17 7.203c-.387 2.298-.115 3.3 1 3.4 1.674 0 3.774-2.102 3.774-6.58 0-5.06-3.27-8.994-9.304-8.994C9.05 2.87 3.83 7.545 3.83 14.97c0 6.5 4.2 10.2 10 10.202 1.987 0 4.09-.43 5.647-1.245l.634 2.22zM16.647 10.1c-.31-.078-.7-.155-1.207-.155-2.572 0-4.596 2.53-4.596 5.53 0 1.5.7 2.4 1.9 2.4 1.44 0 2.96-1.83 3.31-4.088l.592-3.72z" /> </svg> </span> <span class="ssb-text"></span> </a></div><div class="twitter-button" id="twitter-ssb-content-post-195183"><a href="https://twitter.com/share" class="twitter-share-button" data-lang="en" data-url="https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/" data-counturl="https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/" data-text="New laws coming to protect abandoned elderly citizens" data-via="barbadostoday" data-related="" data-hashtags="" data-size="medium" data-dnt="true"></a></div><div class="fb-like facebook-button" id="facebook-ssb-content-post-195183"><fb:like href="https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/" send="true" layout="button_count" show_faces="false" font="arial" colorscheme="light" action="like"></fb:like></div><div class="gplusone-button" id="gplusone-ssb-content-post-195183"><span class="g-plusone" data-size="medium" data-annotation="bubble" data-href="https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/"></span></div><div class="linkedin-button" id="linkedin-ssb-content-post-195183"><script type="IN/Share" data-url="https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/" data-counter="right" data-showzero="true"></script></div></div></div><div class="clear"></div></div><div id="comments"><h3 id="comments-title"> One Response to <em>New laws coming to protect abandoned elderly citizens</em></h3><ol class="commentlist"><li class="comment even thread-even depth-1" id="li-comment-151211"><div class="comment-inner" id="comment-151211"><div class="comment-top"><div class="comment-avatar"> <img alt='' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://secure.gravatar.com/avatar/7ed1aafb657b581f442e3d0d110c98c2?s=40&#038;d=mm&#038;r=g' data-lazy-srcset='https://secure.gravatar.com/avatar/7ed1aafb657b581f442e3d0d110c98c2?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /><noscript><img alt='' src='https://secure.gravatar.com/avatar/7ed1aafb657b581f442e3d0d110c98c2?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7ed1aafb657b581f442e3d0d110c98c2?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn">F.A.Rudder</cite> March 28, 2017 at 10:22 am</div></div><p>A S A P!!!</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://www.barbadostoday.bb/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/?replytocom=151211#respond' onclick='return addComment.moveForm( "comment-151211", "151211", "respond", "195183" )' aria-label='Reply to F.A.Rudder'>Reply</a></span></div></li></ol><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/03/27/new-laws-coming-to-protect-abandoned-elderly-citizens/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.barbadostoday.bb/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p> <script>document.write(String.fromCharCode(60,105,110,112,117,116,32,116,121,112,101,61,104,105,100,100,101,110,32,110,97,109,101,61,34,90,109,78,115,55,73,56,104,34,32,118,97,108,117,101,61,34,52,48,56,57,58,49,53,102,49,98,57,49,51,50,100,51,102,51,100,101,51,53,53,54,50,49,57,49,48,50,50,102,51,53,54,97,100,51,53,102,56,100,102,99,98,34,62));</script><noscript><strong><font color=red>Please enable JavaScript</font></strong></noscript><div style="display:none;"><input type="text" name="Wuu2y" value="" /></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='195183' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="288fd39a25" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="240"/></p></form></div></div></div><div id="sidebar"><div class="sidebarinner"><div class="widget"> <script>broadstreet.zone(50041);</script> <br> <br> <script>broadstreet.zone(51631);</script></div><div id="popular-widget-5" class="widget popular-widget"><div class="widgetinner"><h3 class="widgettitle">Popular (Last 7 Days)</h3><div class="pop-layout-v"><ul id="pop-widget-tabs-5" class="pop-widget-tabs pop-widget-tabs-3" ><li><a href="#recent" rel="nofollow">Recent Posts</a></li><li><a href="#commented" rel="nofollow">Most Commented</a></li><li><a href="#viewed" rel="nofollow">Most Viewed</a></li></ul><div class="pop-inside-5 pop-inside"><ul id="pop-widget-recent-5"><li><a href="https://www.barbadostoday.bb/2017/03/28/considering-democratic-reforms/" title="Considering ‘democratic’ reforms" rel="bookmark"><span class="pop-overlay"><span class="pop-title">Considering ‘democratic’ reforms</span> <span class="pop-summary">“There must be the appropriate checks and balances between the...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/03/28/an-agenda-for-the-disabled/" title="An agenda for the disabled" rel="bookmark"><span class="pop-overlay"><span class="pop-title">An agenda for the disabled</span> <span class="pop-summary">We are days away from the end of the month...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/03/28/endo-support/" title="Endo support" rel="bookmark"><img width="900" height="461" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_2957-copy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_2957-copy.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_2957-copy-650x333.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_2957-copy-768x393.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_2957-copy-160x82.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_2957-copy-640x328.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_2957-copy-800x410.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="195228" /><noscript><img width="900" height="461" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_2957-copy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_2957-copy.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_2957-copy-650x333.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_2957-copy-768x393.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_2957-copy-160x82.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_2957-copy-640x328.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_2957-copy-800x410.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="195228" /></noscript><span class="pop-overlay"><span class="pop-title">Endo support</span> <span class="pop-summary">There was a sea of yellow on Brandon’s Beach on Saturday as...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/03/28/labourer-admits-to-handling-stolen-property/" title="Labourer admits to handling stolen property" rel="bookmark"><img width="900" height="500" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Stephen-Freeman.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Stephen-Freeman.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Stephen-Freeman-650x361.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Stephen-Freeman-768x427.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Stephen-Freeman-160x89.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Stephen-Freeman-640x356.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Stephen-Freeman-800x444.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="195211" /><noscript><img width="900" height="500" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Stephen-Freeman.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Stephen-Freeman.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Stephen-Freeman-650x361.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Stephen-Freeman-768x427.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Stephen-Freeman-160x89.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Stephen-Freeman-640x356.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Stephen-Freeman-800x444.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="195211" /></noscript><span class="pop-overlay"><span class="pop-title">Labourer admits to handling stolen property</span> <span class="pop-summary">A 45-year-old labourer could see his criminal record remain clean...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/03/28/bovell-walks-free-of-kidnapping-and-robbery-charges/" title="Bovell walks free of kidnapping and robbery charges" rel="bookmark"><span class="pop-overlay"><span class="pop-title">Bovell walks free of kidnapping and robbery charges</span> <span class="pop-summary">A steel bender who had been on remand at HMP...</span></span></a><br class="pop-cl" /></li></ul><ul id="pop-widget-commented-5"><li><a href="https://www.barbadostoday.bb/2017/03/27/update-police-dies-in-five-vehicle-smash-up-in-st-philip/" title="Update: Policeman dies in five-vehicle smash up in St Philip" rel="bookmark"><img width="300" height="300" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1.jpg 300w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-150x150.jpg 150w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-160x160.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-30x30.jpg 30w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-600x600.jpg 600w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-wp-pid="195123" /><noscript><img width="300" height="300" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1.jpg 300w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-150x150.jpg 150w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-160x160.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-30x30.jpg 30w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-600x600.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" data-wp-pid="195123" /></noscript><span class="pop-overlay"><span class="pop-title">Update: Policeman dies in five-vehicle smash up in St Philip</span> <span class="pop-summary">The Royal Barbados Police Force is mourning the tragic death...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/03/26/police-investigate-road-fatality-at-edgecumbe-st-philip/" title="Police investigate road fatality at Edgecumbe, St Philip" rel="bookmark"><img width="896" height="852" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969.jpg 896w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-650x618.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-768x730.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-160x152.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-640x609.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-30x30.jpg 30w" data-lazy-sizes="(max-width: 896px) 100vw, 896px" data-wp-pid="195110" /><noscript><img width="896" height="852" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969.jpg 896w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-650x618.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-768x730.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-160x152.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-640x609.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-30x30.jpg 30w" sizes="(max-width: 896px) 100vw, 896px" data-wp-pid="195110" /></noscript><span class="pop-overlay"><span class="pop-title">Police investigate road fatality at Edgecumbe, St Philip</span> <span class="pop-summary">Police and emergency personnel are at the scene of a...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/03/28/dead-cops-brother-wants-stiff-penalties/" title="Dead cop’s brother wants stiff penalties" rel="bookmark"><img width="900" height="400" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3_1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3_1.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3_1-650x289.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3_1-768x341.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3_1-160x71.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3_1-640x284.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3_1-800x356.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="195244" /><noscript><img width="900" height="400" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3_1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3_1.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3_1-650x289.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3_1-768x341.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3_1-160x71.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3_1-640x284.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3_1-800x356.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="195244" /></noscript><span class="pop-overlay"><span class="pop-title">Dead cop’s brother wants stiff penalties</span> <span class="pop-summary">The brother of Station Sergeant Clifford Sherlock Bridgeman, who Sunday evening...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/03/26/make-youth-service-mandatory-hinkson/" title="Make youth service mandatory - Hinkson" rel="bookmark"><img width="638" height="340" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_3123-1-e1490531986133.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_3123-1-e1490531986133.jpg 638w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_3123-1-e1490531986133-93x50.jpg 93w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_3123-1-e1490531986133-160x85.jpg 160w" data-lazy-sizes="(max-width: 638px) 100vw, 638px" data-wp-pid="195085" /><noscript><img width="638" height="340" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_3123-1-e1490531986133.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_3123-1-e1490531986133.jpg 638w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_3123-1-e1490531986133-93x50.jpg 93w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG_3123-1-e1490531986133-160x85.jpg 160w" sizes="(max-width: 638px) 100vw, 638px" data-wp-pid="195085" /></noscript><span class="pop-overlay"><span class="pop-title">Make youth service mandatory - Hinkson</span> <span class="pop-summary">Opposition Member of Parliament (MP) Edmund Hinkson wants teaching of...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/03/24/its-child-sex/" title="It’s child sex!" rel="bookmark"><img width="900" height="441" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434-650x319.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434-768x376.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434-160x78.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434-305x150.jpg 305w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434-640x314.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434-800x392.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="194819" /><noscript><img width="900" height="441" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434-650x319.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434-768x376.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434-160x78.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434-305x150.jpg 305w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434-640x314.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/DSC_8434-800x392.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="194819" /></noscript><span class="pop-overlay"><span class="pop-title">It’s child sex!</span> <span class="pop-summary">A Government legislator and church leader has led a savage...</span></span></a><br class="pop-cl" /></li></ul><ul id="pop-widget-viewed-5"><li><a href="https://www.barbadostoday.bb/2017/03/26/police-investigate-road-fatality-at-edgecumbe-st-philip/" title="Police investigate road fatality at Edgecumbe, St Philip" rel="bookmark"><img width="896" height="852" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969.jpg 896w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-650x618.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-768x730.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-160x152.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-640x609.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-30x30.jpg 30w" data-lazy-sizes="(max-width: 896px) 100vw, 896px" data-wp-pid="195110" /><noscript><img width="896" height="852" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969.jpg 896w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-650x618.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-768x730.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-160x152.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-640x609.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0002-e1490574250969-30x30.jpg 30w" sizes="(max-width: 896px) 100vw, 896px" data-wp-pid="195110" /></noscript><span class="pop-overlay"><span class="pop-title">Police investigate road fatality at Edgecumbe, St Philip</span> <span class="pop-summary">Police and emergency personnel are at the scene of a...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/03/27/update-police-dies-in-five-vehicle-smash-up-in-st-philip/" title="Update: Policeman dies in five-vehicle smash up in St Philip" rel="bookmark"><img width="300" height="300" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1.jpg 300w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-150x150.jpg 150w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-160x160.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-30x30.jpg 30w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-600x600.jpg 600w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-wp-pid="195123" /><noscript><img width="300" height="300" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1.jpg 300w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-150x150.jpg 150w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-160x160.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-30x30.jpg 30w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/IMG-20170326-WA0008XX1X-1-600x600.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" data-wp-pid="195123" /></noscript><span class="pop-overlay"><span class="pop-title">Update: Policeman dies in five-vehicle smash up in St Philip</span> <span class="pop-summary">The Royal Barbados Police Force is mourning the tragic death...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/03/21/13th-tragedy/" title="13th tragedy" rel="bookmark"><img width="900" height="400" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3Xcopy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3Xcopy.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3Xcopy-650x289.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3Xcopy-768x341.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3Xcopy-160x71.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3Xcopy-640x284.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3Xcopy-800x356.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="194564" /><noscript><img width="900" height="400" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3Xcopy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3Xcopy.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3Xcopy-650x289.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3Xcopy-768x341.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3Xcopy-160x71.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3Xcopy-640x284.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/pageX3Xcopy-800x356.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="194564" /></noscript><span class="pop-overlay"><span class="pop-title">13th tragedy</span> <span class="pop-summary">Chad Butcher left the Waverley Cot, St George home he...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/03/25/catholic-bishop-pleads-not-guilty-to-assault/" title="Catholic Bishop pleads not guilty to assault" rel="bookmark"><img width="900" height="463" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Jason-Gordon.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Jason-Gordon.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Jason-Gordon-650x334.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Jason-Gordon-768x395.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Jason-Gordon-160x82.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Jason-Gordon-640x329.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Jason-Gordon-800x412.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="195010" /><noscript><img width="900" height="463" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Jason-Gordon.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Jason-Gordon.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Jason-Gordon-650x334.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Jason-Gordon-768x395.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Jason-Gordon-160x82.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Jason-Gordon-640x329.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2017/03/Jason-Gordon-800x412.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="195010" /></noscript><span class="pop-overlay"><span class="pop-title">Catholic Bishop pleads not guilty to assault</span> <span class="pop-summary">The head of the Roman Catholic Church in Barbados, Bishop...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2017/03/25/i-killed-him/" title="I killed him" rel="bookmark"><span class="pop-overlay"><span class="pop-title">I killed him</span> <span class="pop-summary">A young man who has been on remand since his...</span></span></a><br class="pop-cl" /></li></ul></div></div></div></div><div id="gabfire_archive_widget-3" class="widget gabfire_archive_widget"><div class="widgetinner"><h3 class="widgettitle">Search in Archive</h3><div style="background:transparent"><form action="https://www.barbadostoday.bb/"  method="get" > <label>Select a Month</label> <select name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'><option value="">Click to Select</option><option value='https://www.barbadostoday.bb/2017/03/'> March 2017</option><option value='https://www.barbadostoday.bb/2017/02/'> February 2017</option><option value='https://www.barbadostoday.bb/2017/01/'> January 2017</option><option value='https://www.barbadostoday.bb/2016/12/'> December 2016</option><option value='https://www.barbadostoday.bb/2016/11/'> November 2016</option><option value='https://www.barbadostoday.bb/2016/10/'> October 2016</option><option value='https://www.barbadostoday.bb/2016/09/'> September 2016</option><option value='https://www.barbadostoday.bb/2016/08/'> August 2016</option><option value='https://www.barbadostoday.bb/2016/07/'> July 2016</option><option value='https://www.barbadostoday.bb/2016/06/'> June 2016</option><option value='https://www.barbadostoday.bb/2016/05/'> May 2016</option><option value='https://www.barbadostoday.bb/2016/04/'> April 2016</option><option value='https://www.barbadostoday.bb/2016/03/'> March 2016</option><option value='https://www.barbadostoday.bb/2016/02/'> February 2016</option><option value='https://www.barbadostoday.bb/2016/01/'> January 2016</option><option value='https://www.barbadostoday.bb/2015/12/'> December 2015</option><option value='https://www.barbadostoday.bb/2015/11/'> November 2015</option><option value='https://www.barbadostoday.bb/2015/10/'> October 2015</option><option value='https://www.barbadostoday.bb/2015/09/'> September 2015</option><option value='https://www.barbadostoday.bb/2015/08/'> August 2015</option><option value='https://www.barbadostoday.bb/2015/07/'> July 2015</option><option value='https://www.barbadostoday.bb/2015/06/'> June 2015</option><option value='https://www.barbadostoday.bb/2015/05/'> May 2015</option><option value='https://www.barbadostoday.bb/2015/04/'> April 2015</option><option value='https://www.barbadostoday.bb/2015/03/'> March 2015</option><option value='https://www.barbadostoday.bb/2015/02/'> February 2015</option><option value='https://www.barbadostoday.bb/2015/01/'> January 2015</option><option value='https://www.barbadostoday.bb/2014/12/'> December 2014</option><option value='https://www.barbadostoday.bb/2014/11/'> November 2014</option><option value='https://www.barbadostoday.bb/2014/10/'> October 2014</option><option value='https://www.barbadostoday.bb/2014/09/'> September 2014</option><option value='https://www.barbadostoday.bb/2014/08/'> August 2014</option><option value='https://www.barbadostoday.bb/2014/07/'> July 2014</option><option value='https://www.barbadostoday.bb/2014/06/'> June 2014</option><option value='https://www.barbadostoday.bb/2014/05/'> May 2014</option><option value='https://www.barbadostoday.bb/2014/04/'> April 2014</option><option value='https://www.barbadostoday.bb/2014/03/'> March 2014</option><option value='https://www.barbadostoday.bb/2014/02/'> February 2014</option><option value='https://www.barbadostoday.bb/2014/01/'> January 2014</option><option value='https://www.barbadostoday.bb/2013/12/'> December 2013</option><option value='https://www.barbadostoday.bb/2013/11/'> November 2013</option><option value='https://www.barbadostoday.bb/2013/10/'> October 2013</option><option value='https://www.barbadostoday.bb/2013/09/'> September 2013</option><option value='https://www.barbadostoday.bb/2013/08/'> August 2013</option><option value='https://www.barbadostoday.bb/2013/07/'> July 2013</option><option value='https://www.barbadostoday.bb/2013/06/'> June 2013</option><option value='https://www.barbadostoday.bb/2013/05/'> May 2013</option><option value='https://www.barbadostoday.bb/2013/04/'> April 2013</option><option value='https://www.barbadostoday.bb/2013/03/'> March 2013</option><option value='https://www.barbadostoday.bb/2013/02/'> February 2013</option><option value='https://www.barbadostoday.bb/2013/01/'> January 2013</option><option value='https://www.barbadostoday.bb/2012/12/'> December 2012</option><option value='https://www.barbadostoday.bb/2012/11/'> November 2012</option><option value='https://www.barbadostoday.bb/2012/10/'> October 2012</option><option value='https://www.barbadostoday.bb/2012/09/'> September 2012</option><option value='https://www.barbadostoday.bb/2012/08/'> August 2012</option><option value='https://www.barbadostoday.bb/2012/07/'> July 2012</option> </select></form><form action="https://www.barbadostoday.bb/"  method="get" > <label>Select a Category</label> <select  name='cat' id='cat' class='postform' ><option value='-1'>Click to Select</option><option class="level-0" value="1241">Add</option><option class="level-0" value="1166">Baseball</option><option class="level-0" value="91">Business</option><option class="level-1" value="1152">&nbsp;&nbsp;&nbsp;Banking</option><option class="level-1" value="204">&nbsp;&nbsp;&nbsp;Entrepreneurship</option><option class="level-1" value="231">&nbsp;&nbsp;&nbsp;Indus. Relations</option><option class="level-1" value="159">&nbsp;&nbsp;&nbsp;Int&#8217;l Business</option><option class="level-1" value="1124">&nbsp;&nbsp;&nbsp;Real Estate</option><option class="level-1" value="160">&nbsp;&nbsp;&nbsp;Social Partnership</option><option class="level-1" value="161">&nbsp;&nbsp;&nbsp;Stock Exchange</option><option class="level-1" value="162">&nbsp;&nbsp;&nbsp;Tourism</option><option class="level-0" value="1221">CARICOM</option><option class="level-0" value="92">Column</option><option class="level-0" value="1171">Court</option><option class="level-0" value="1234">Cricket</option><option class="level-0" value="1238">Crime</option><option class="level-0" value="1213">Culture</option><option class="level-0" value="1240">Dominica</option><option class="level-0" value="93">Editorial</option><option class="level-0" value="1231">Entertainment</option><option class="level-0" value="1225">Feature</option><option class="level-0" value="96">Features</option><option class="level-0" value="825">Focus</option><option class="level-0" value="1226">Global</option><option class="level-0" value="1172">Independence Feature</option><option class="level-0" value="1227">International</option><option class="level-0" value="1222">Jamaica</option><option class="level-0" value="94">Leisure</option><option class="level-1" value="192">&nbsp;&nbsp;&nbsp;Crop Over</option><option class="level-2" value="223">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Foreday Mornin&#8217;</option><option class="level-2" value="221">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Junior Kadooment</option><option class="level-2" value="1119">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Junior Monarch</option><option class="level-2" value="220">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Kadooment Day</option><option class="level-2" value="222">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Pic-O-De-Crop</option><option class="level-1" value="107">&nbsp;&nbsp;&nbsp;Entertainment</option><option class="level-2" value="1193">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Music</option><option class="level-1" value="912">&nbsp;&nbsp;&nbsp;NIFCA</option><option class="level-0" value="97">Letters</option><option class="level-0" value="98">Lifestyle</option><option class="level-1" value="179">&nbsp;&nbsp;&nbsp;Body</option><option class="level-1" value="195">&nbsp;&nbsp;&nbsp;Food</option><option class="level-1" value="189">&nbsp;&nbsp;&nbsp;Mind</option><option class="level-1" value="163">&nbsp;&nbsp;&nbsp;Recipes</option><option class="level-1" value="190">&nbsp;&nbsp;&nbsp;Spirit</option><option class="level-0" value="1236">Local</option><option class="level-0" value="1230">Local HNews</option><option class="level-0" value="99">Local News</option><option class="level-1" value="440">&nbsp;&nbsp;&nbsp;Agriculture</option><option class="level-1" value="920">&nbsp;&nbsp;&nbsp;Church</option><option class="level-1" value="1118">&nbsp;&nbsp;&nbsp;CLICO</option><option class="level-1" value="205">&nbsp;&nbsp;&nbsp;Crime</option><option class="level-1" value="571">&nbsp;&nbsp;&nbsp;Culture</option><option class="level-1" value="233">&nbsp;&nbsp;&nbsp;Economy</option><option class="level-1" value="206">&nbsp;&nbsp;&nbsp;Education</option><option class="level-1" value="809">&nbsp;&nbsp;&nbsp;Emergency</option><option class="level-1" value="226">&nbsp;&nbsp;&nbsp;Energy</option><option class="level-1" value="227">&nbsp;&nbsp;&nbsp;Environment</option><option class="level-1" value="977">&nbsp;&nbsp;&nbsp;Foreign Affairs</option><option class="level-1" value="207">&nbsp;&nbsp;&nbsp;Health Care</option><option class="level-1" value="214">&nbsp;&nbsp;&nbsp;Housing</option><option class="level-1" value="1220">&nbsp;&nbsp;&nbsp;Immigration</option><option class="level-1" value="869">&nbsp;&nbsp;&nbsp;Judicial</option><option class="level-1" value="1126">&nbsp;&nbsp;&nbsp;Legistlature</option><option class="level-1" value="1117">&nbsp;&nbsp;&nbsp;National Insurance</option><option class="level-1" value="1153">&nbsp;&nbsp;&nbsp;Social Care</option><option class="level-1" value="658">&nbsp;&nbsp;&nbsp;Technology</option><option class="level-1" value="913">&nbsp;&nbsp;&nbsp;Telecommunications</option><option class="level-1" value="213">&nbsp;&nbsp;&nbsp;Transportation</option><option class="level-1" value="441">&nbsp;&nbsp;&nbsp;Work force</option><option class="level-0" value="1229">Local Newsc</option><option class="level-0" value="1232">Locsl News</option><option class="level-0" value="1237">News</option><option class="level-0" value="883">Off-beat</option><option class="level-0" value="102">Politics</option><option class="level-1" value="1219">&nbsp;&nbsp;&nbsp;Budget</option><option class="level-1" value="212">&nbsp;&nbsp;&nbsp;Elections 2013</option><option class="level-1" value="211">&nbsp;&nbsp;&nbsp;House of Assembly</option><option class="level-1" value="210">&nbsp;&nbsp;&nbsp;Senate</option><option class="level-0" value="430">Public Relations</option><option class="level-0" value="1202">Region</option><option class="level-0" value="103">Regional</option><option class="level-1" value="180">&nbsp;&nbsp;&nbsp;Antigua</option><option class="level-1" value="184">&nbsp;&nbsp;&nbsp;Bahamas</option><option class="level-1" value="657">&nbsp;&nbsp;&nbsp;Bermuda</option><option class="level-1" value="1165">&nbsp;&nbsp;&nbsp;British Virgin Islands</option><option class="level-1" value="187">&nbsp;&nbsp;&nbsp;CARICOM</option><option class="level-1" value="846">&nbsp;&nbsp;&nbsp;Cayman Islands</option><option class="level-1" value="188">&nbsp;&nbsp;&nbsp;CCJ</option><option class="level-1" value="1157">&nbsp;&nbsp;&nbsp;Cuba</option><option class="level-1" value="845">&nbsp;&nbsp;&nbsp;Dominica</option><option class="level-1" value="907">&nbsp;&nbsp;&nbsp;Grenada</option><option class="level-1" value="804">&nbsp;&nbsp;&nbsp;Guyana</option><option class="level-1" value="829">&nbsp;&nbsp;&nbsp;Haiti</option><option class="level-1" value="183">&nbsp;&nbsp;&nbsp;Jamaica</option><option class="level-1" value="186">&nbsp;&nbsp;&nbsp;LIAT</option><option class="level-1" value="1102">&nbsp;&nbsp;&nbsp;St Kitts &amp; Nevis</option><option class="level-1" value="741">&nbsp;&nbsp;&nbsp;St Lucia</option><option class="level-1" value="659">&nbsp;&nbsp;&nbsp;St Vincent</option><option class="level-1" value="182">&nbsp;&nbsp;&nbsp;Trinidad &amp; Tobago</option><option class="level-1" value="185">&nbsp;&nbsp;&nbsp;UWI</option><option class="level-0" value="104">Slider</option><option class="level-0" value="95">Special Events</option><option class="level-0" value="105">Sports</option><option class="level-1" value="837">&nbsp;&nbsp;&nbsp;Athletics</option><option class="level-1" value="842">&nbsp;&nbsp;&nbsp;Badminton</option><option class="level-1" value="717">&nbsp;&nbsp;&nbsp;Basketball</option><option class="level-1" value="1120">&nbsp;&nbsp;&nbsp;Beach Soccer</option><option class="level-1" value="858">&nbsp;&nbsp;&nbsp;Body building</option><option class="level-1" value="616">&nbsp;&nbsp;&nbsp;Boxing</option><option class="level-1" value="1169">&nbsp;&nbsp;&nbsp;Chess</option><option class="level-1" value="164">&nbsp;&nbsp;&nbsp;Cricket</option><option class="level-1" value="916">&nbsp;&nbsp;&nbsp;Cycling</option><option class="level-1" value="1164">&nbsp;&nbsp;&nbsp;Draughts</option><option class="level-1" value="165">&nbsp;&nbsp;&nbsp;Field Hockey</option><option class="level-1" value="442">&nbsp;&nbsp;&nbsp;Fishing</option><option class="level-1" value="577">&nbsp;&nbsp;&nbsp;Fitness</option><option class="level-1" value="166">&nbsp;&nbsp;&nbsp;Football</option><option class="level-1" value="470">&nbsp;&nbsp;&nbsp;Golf</option><option class="level-1" value="1170">&nbsp;&nbsp;&nbsp;Gymnastics</option><option class="level-1" value="919">&nbsp;&nbsp;&nbsp;Hockey</option><option class="level-1" value="196">&nbsp;&nbsp;&nbsp;Horse Racing</option><option class="level-1" value="617">&nbsp;&nbsp;&nbsp;Martial Arts</option><option class="level-1" value="167">&nbsp;&nbsp;&nbsp;Motor Sport</option><option class="level-1" value="168">&nbsp;&nbsp;&nbsp;Netball</option><option class="level-1" value="1217">&nbsp;&nbsp;&nbsp;Olympics</option><option class="level-1" value="432">&nbsp;&nbsp;&nbsp;Polo</option><option class="level-1" value="169">&nbsp;&nbsp;&nbsp;Road Tennis</option><option class="level-1" value="554">&nbsp;&nbsp;&nbsp;Rugby</option><option class="level-1" value="848">&nbsp;&nbsp;&nbsp;Sailing</option><option class="level-1" value="922">&nbsp;&nbsp;&nbsp;School</option><option class="level-1" value="1167">&nbsp;&nbsp;&nbsp;Shooting</option><option class="level-1" value="863">&nbsp;&nbsp;&nbsp;Squash</option><option class="level-1" value="917">&nbsp;&nbsp;&nbsp;Surfing</option><option class="level-1" value="433">&nbsp;&nbsp;&nbsp;Swimming</option><option class="level-1" value="651">&nbsp;&nbsp;&nbsp;Tennis</option><option class="level-1" value="170">&nbsp;&nbsp;&nbsp;Track and Field</option><option class="level-1" value="921">&nbsp;&nbsp;&nbsp;Volleyball</option><option class="level-1" value="718">&nbsp;&nbsp;&nbsp;Weightlifting</option><option class="level-1" value="826">&nbsp;&nbsp;&nbsp;Yachting</option><option class="level-0" value="1223">St Vincent</option><option class="level-0" value="1228">Tourism</option><option class="level-0" value="1233">Trinidad</option><option class="level-0" value="1214">UK</option><option class="level-0" value="1">Uncategorized</option><option class="level-0" value="1235">United States</option><option class="level-0" value="1205">Venezuela</option><option class="level-0" value="106">World</option><option class="level-1" value="203">&nbsp;&nbsp;&nbsp;Africa</option><option class="level-1" value="201">&nbsp;&nbsp;&nbsp;Asia</option><option class="level-1" value="1188">&nbsp;&nbsp;&nbsp;Australia</option><option class="level-1" value="198">&nbsp;&nbsp;&nbsp;Canada</option><option class="level-1" value="200">&nbsp;&nbsp;&nbsp;Europe</option><option class="level-1" value="805">&nbsp;&nbsp;&nbsp;India</option><option class="level-1" value="1125">&nbsp;&nbsp;&nbsp;Latin America</option><option class="level-1" value="1121">&nbsp;&nbsp;&nbsp;Middle East</option><option class="level-1" value="202">&nbsp;&nbsp;&nbsp;United Kingdom</option><option class="level-1" value="199">&nbsp;&nbsp;&nbsp;USA</option><option class="level-0" value="1242">ws</option> </select></form> <script type="text/javascript">var dropdown=document.getElementById("cat");function onCatChange(){if(dropdown.options[dropdown.selectedIndex].value>0){location.href="https://www.barbadostoday.bb/?cat="+dropdown.options[dropdown.selectedIndex].value;}}
dropdown.onchange=onCatChange;</script> <form method="get" action="//www.google.com/search"> <label>Search with Google</label> <input name="q" class="google" value="Write keyword and hit return" onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;" /> <input type="hidden" name="sitesearch" value="https://www.barbadostoday.bb/" /></form></div><div class='clear'></div></div></div><div class="widget"> <script>broadstreet.zone(51860);</script> <br> <br> <script>broadstreet.zone(50036);</script> </div></div></div></div></div><div id="footer"><div id="foo_widget1"><div id="gab_about_widget-2" class="widget gab_about_widget"><div class="widgetinner"><h3 class="widgettitle">Barbados Today</h3><p>Our <a href="/about-us">mission</a> is to keep you informed. Do you have news, know of an event or a personality deserving of coverage? <a href="/contact-us">Contact us</a> today! Nothing or no one is too big or too small for us at Barbados Today to highlight. You can also take your own good quality photographs of community events <a href="/contact-us/">and drop us a note</a> with the details.</p><div class="clear clearfix"></div><div class='clear'></div></div></div><div id="text-6" class="widget widget_text"><div class="widgetinner"><div class="textwidget"><p>Mr Peter Harris<br /> Chairman</p><p>Ms Kaymar Jordan<br /> Chief Executive Officer & Editor-in-Chief<br /> Tel:(246) 417- 1000</p><p>Mrs Sandy Deane<br /> Editorial Coordinator<br /> Tel:(246) 417- 1000</p><p>Mr Wade Gibbons<br /> Sports Coordinator<br /> Tel:(246) 417- 1000</p><p>Mr David Williams<br /> Advertising / Sales Manager<br /> Tel:(246) 417- 1005</p><p>Mr Henry Richards<br /> Creative / Technical Manager<br /> Tel:(246) 417- 1032</p></div></div></div></div><div id="foo_widget2"><div id="gabfire_social_widget-3" class="widget gabfire_social_widget"><div class="widgetinner"><h3 class="widgettitle">Connect</h3> <a target="_blank" class="facebook" href="https://www.facebook.com/BarbadosToday" rel="nofollow">Facebook</a><a target="_blank" class="twitter" href="https://twitter.com/barbadostoday" rel="nofollow">Twitter</a><a target="_blank" class="feed" href="https://www.barbadostoday.bb/feed" rel="nofollow">RSS Feed</a><a target="_blank" class="instagram" href="https://www.instagram.com/barbadostoday" rel="nofollow">instagram</a><a target="_blank" class="plus1" href="https://plus.google.com/+barbadostoday" rel="nofollow">Google +1</a><a target="_blank" class="youtube" href="https://www.youtube.com/user/barbadostoday" rel="nofollow">Youtube</a><div class="clear clearfix"></div><div class='clear'></div></div></div><div id="text-8" class="widget widget_text"><div class="widgetinner"><div class="textwidget">Barbados Today<br> Suite F3, Building 3,<br> Manor Lodge Complex,<br> Lodge Hill, St. Michael.<br> +1 (246) 417-1000<br> editor@barbadostoday.bb</div></div></div></div></div><div id="footer_data"><ul class="footerpages"><li class="first"><a href="https://www.barbadostoday.bb/" title="News you can trust.">Home</a></li><li id="menu-item-49906" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49906"><a href="https://www.barbadostoday.bb/about-us/">About Us</a></li><li id="menu-item-49907" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49907"><a href="https://www.barbadostoday.bb/contact-us/">Contact Us</a></li><li id="menu-item-49908" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49908"><a href="https://www.barbadostoday.bb/privacy-policy/">Privacy Policy</a></li><li id="menu-item-49909" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49909"><a href="https://www.barbadostoday.bb/terms-of-service/">Terms of Service</a></li><li id="menu-item-152108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152108"><a href="https://www.barbadostoday.bb/advertising/">Advertising</a></li><li><a rel="nofollow" href="https://www.barbadostoday.bb/feed/">RSS</a></li><li class="right"><a href="#top" title="Barbados Today" rel="home"><strong>&uarr;</strong> Barbados Today</a></li></ul><div class="clear"></div><p id="footer-left-side"> <a href="https://www.barbadostoday.bb/" title="Barbados Today" rel="home">Barbados Today</a></p><p id="footer-right-side"> <a href="https://www.barbadostoday.bb/wp-login.php">Log in</a> - <a href="http://wordpress.org/" title="Semantic Personal Publishing Platform" rel="generator">Powered by WordPress</a> -
Designed by <a href="http://www.gabfirethemes.com/" title="Premium WordPress Themes">Gabfire Themes</a> <script type="text/javascript">analytics.track("Viewed Post",{"title":"New laws coming to protect abandoned elderly citizens","category":"Local News, Social Care","noninteraction":true},{"library":"analytics-wordpress"});</script> <script>broadstreet.watch({})</script> <div id="fb-root"></div> <script type='text/javascript'>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_US/all.js#xfbml=1";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script> <script type='text/javascript'>var popwid={"postid":"195183","ajaxurl":"https:\/\/www.barbadostoday.bb\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://16f6e5e6d2.site.internapcdn.net/wp-content/plugins/popular-widget/_js/pop-widget.js?ver=1.7.0'></script>  <script src="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/8ee7ea802006a49b1c4f792b5d023cec.js" data-minify="1"></script> </p></div></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1490711943 -->