<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head profile="http://gmpg.org/xfn/11"><link rel="stylesheet" href="//fonts.googleapis.com/css?family=Open+Sans%3A400%2C300" /><link rel="stylesheet" href="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/6d0f93fc5d33024cbae1a8824416acea.css" data-minify="1"/><link rel="stylesheet" href="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/1dcb8a1ec2ba8008861125cc81e7f026.css" data-minify="1"/><script type='text/javascript' data-cfasync='false' src='https://cdn.broadstreetads.com/init-2.min.js?ver=4.7.0'></script><script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js?ver=4.7.0'></script><script src="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/ec150d783d537dbbf3bb350b6c8ddc3f.js" data-minify="1"></script><script src="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/1dc7fb15e5fcf2a37f6f040ec7989f60.js" data-minify="1"></script><script src="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/0b4f9bec0c9d24795a1c78c7382614e5.js" data-minify="1"></script> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><title> Convicted gas bottle thief nabbed with a stove | Barbados Today</title><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://www.barbadostoday.bb/feed/" /><link rel="pingback" href="https://www.barbadostoday.bb/xmlrpc.php" /> <script type="text/javascript">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</script> <meta name="robots" content="noodp,noydir" /><meta name="description" content="Convicted gas bottle thief nabbed with a stove | A 45-year-old man who previously served time behind bars for stealing bottles of gas, returned before the&#8230;" /><link rel="canonical" href="https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/" /> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.barbadostoday.bb\/","name":"Barbados Today","image":""}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.barbadostoday.bb\/category\/court\/","name":"Court","image":""}},{"@type":"ListItem","position":3,"item":{"@id":"https:\/\/www.barbadostoday.bb\/2016\/12\/22\/convicted-gas-bottle-thief-nabbed-with-a-stove\/","name":"Convicted gas bottle thief nabbed with a stove","image":"https:\/\/16f6e5e6d2.site.internapcdn.net\/wp-content\/uploads\/2016\/12\/WinstonXKing.jpg"}}]}</script> <link rel='dns-prefetch' href='//cdn.broadstreetads.com' /><link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel='dns-prefetch' href='//16f6e5e6d2.site.internapcdn.net' /><link rel="alternate" type="application/rss+xml" title="Barbados Today &raquo; Feed" href="https://www.barbadostoday.bb/feed/" /><link rel="alternate" type="application/rss+xml" title="Barbados Today &raquo; Comments Feed" href="https://www.barbadostoday.bb/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Barbados Today &raquo; Convicted gas bottle thief nabbed with a stove Comments Feed" href="https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/feed/" /> <script type="text/javascript">/*<![CDATA[*/window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/16f6e5e6d2.site.internapcdn.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.0"}};!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);/*]]>*/</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><style id='awesome-weather-inline-css' type='text/css'>.awesome-weather-wrap{font-family:'Open Sans',sans-serif;font-weight:400;font-size:14px;line-height:14px}</style> <script type="text/javascript">/*<![CDATA[*/!function(){var analytics=window.analytics=window.analytics||[];if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.0.0";window.analytics.load("vky0x5mb1o");window.analytics.page();}}();/*]]>*/</script> <link rel='https://api.w.org/' href='https://www.barbadostoday.bb/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.barbadostoday.bb/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.barbadostoday.bb/wp-includes/wlwmanifest.xml" /><link rel="alternate" type="application/json+oembed" href="https://www.barbadostoday.bb/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.barbadostoday.bb%2F2016%2F12%2F22%2Fconvicted-gas-bottle-thief-nabbed-with-a-stove%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.barbadostoday.bb/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.barbadostoday.bb%2F2016%2F12%2F22%2Fconvicted-gas-bottle-thief-nabbed-with-a-stove%2F&#038;format=xml" /><style type="text/css">.ad728{height:90px}.mastheadnav{width:580px;margin-top:10px}#gabfire_social_widget-2.widget.gabfire_social_widget{width:165px;height:53px}.gabfire_social_widget
a{margin:3px
3px}#content .single-default
p{line-height:1.5;margin-bottom:1.7em}#foo_widget1{font-size:12px}.news_wrapper{margin-bottom:15px}#mainmenu{display:block;background:#27aae1;border-top:1px solid #082133}#footer{background:#17478E}#footer
.widgettitle{border-bottom:1px dotted #fff}.newsblock .right .posttitle
a{color:#1282C4}#respond .form-submit
#submit{height:30px}#footer-left-side{display:none}#footer-right-side{display:none}div.pop-inside ul li .pop-summary{color:#555}.wp-caption-text{line-height:1.2;margin-top:7px}</style> <script type='text/javascript'>(function($){$(document).ready(function(){$('a[href="#top"]').click(function(){$('html, body').animate({scrollTop:0},'slow');return false;});$('#slides').slides({autoHeight:true});$("ul.tabs").tabs("div.panes > div");$("ul.sc_tabs").tabs("div.sc_tabs-content > div");});})(jQuery);</script> <link rel="shortcut icon" href="https://www.barbadostoday.bb/wp-content/uploads/2011/12/favicon.gif"/><meta name="wpsso:mark" content="wpsso meta tags begin"/><meta name="generator" content="WPSSO 3.37.8-1/G"/><meta name="generator" content="WPSSO SSB 2.3.6-1/G"/><link rel="publisher" href="https://plus.google.com/+barbadostoday/"/><link rel="shortlink" href="https://www.barbadostoday.bb/?p=184712"/><meta property="fb:app_id" content="613718815307708"/><meta property="og:url" content="https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/"/><meta property="og:type" content="article"/><meta property="article:published_time" content="2016-12-22T06:00:07+00:00"/><meta property="article:modified_time" content="2016-12-22T03:43:03+00:00"/><meta property="og:locale" content="en_US"/><meta property="og:site_name" content="Barbados Today"/><meta property="og:title" content="Convicted gas bottle thief nabbed with a stove"/><meta property="og:description" content="A 45-year-old man who previously served time behind bars for stealing bottles of gas, returned before the law courts today charged with theft of a stove. Winston Leroy King, of Thompson Land, Licorish Village, St Michael, admitted in the District &lsquo;A&rsquo; Magistrates&rsquo; Court to entering Daniel Lowe&rsquo;s..."/><meta property="article:publisher" content="https://www.facebook.com/BarbadosToday"/><meta property="og:image" content="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-600x315.jpg"/><meta property="og:image:width" content="600"/><meta property="og:image:height" content="315"/><meta name="weibo:article:create_at" content="2016-12-22 06:00:07"/><meta name="weibo:article:update_at" content="2016-12-22 03:43:03"/><meta name="twitter:domain" content="www.barbadostoday.bb"/><meta name="twitter:site" content="@barbadostoday"/><meta name="twitter:title" content="Convicted gas bottle thief nabbed with a stove"/><meta name="twitter:description" content="A 45-year-old man who previously served time behind bars for stealing bottles of gas, returned before the law courts today charged with theft of a stove. Winston Leroy King, of Thompson Land..."/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-800x436.jpg"/><meta itemprop="url" content="https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/"/><meta itemprop="name" content="Convicted gas bottle thief nabbed with a stove"/><meta itemprop="description" content="A 45-year-old man who previously served time behind bars for stealing bottles of gas, returned before the law courts today charged with theft of a stove. Winston Leroy King, of Thompson Land, Licorish Village, St Michael, admitted in the District..."/><meta name="author" content="Barbados Today"/> <noscript itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Barbados Today"/><meta itemprop="description" content="Barbados Today is the leading news service in Barbados. Founded in January 2010, with the mission to keep you informed, we aim to share news on matters of national interest, raise the level of public debate and help our readers make informed decisions in their daily lives. We do this by building confidence in our content through consistency. We strive for accuracy, accountability and maturity in our reporting at all times."/> </noscript> <noscript itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-800x436.jpg"/><meta itemprop="width" content="800"/><meta itemprop="height" content="436"/> </noscript><meta name="wpsso:mark" content="wpsso meta tags end"/>  <script type="text/javascript" id="wpssossb-header-script">window.___gcfg={lang:"en-US"};function wpsso_insert_js(script_id,url,async){if(document.getElementById(script_id+"-js"))return;var async=typeof async!=="undefined"?async:true;var script_pos=document.getElementById(script_id);var js=document.createElement("script");js.id=script_id+"-js";js.async=async;js.type="text/javascript";js.language="JavaScript";js.src=url;script_pos.parentNode.insertBefore(js,script_pos);};</script> 
 <script type="text/javascript" id="fb-script-header">/*<![CDATA[*/wpsso_insert_js("fb-script-header","https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=613718815307708");/*]]>*/</script> <script type="text/javascript" id="gplus-script-header">wpsso_insert_js("gplus-script-header","https://apis.google.com/js/plusone.js");</script> <script type="text/javascript" id="linkedin-script-header">wpsso_insert_js("linkedin-script-header","https://platform.linkedin.com/in.js");</script> <script type="text/javascript" id="twitter-script-header">wpsso_insert_js("twitter-script-header","https://platform.twitter.com/widgets.js");</script>  <script data-no-minify="1" data-cfasync="false">(function(w,d){function a(){var b=d.createElement("script");b.async=!0;b.src="https://16f6e5e6d2.site.internapcdn.net/wp-content/plugins/wp-rocket/inc/front/js/lazyload.1.0.5.min.js";var a=d.getElementsByTagName("script")[0];a.parentNode.insertBefore(b,a)}w.attachEvent?w.attachEvent("onload",a):w.addEventListener("load",a,!1)})(window,document);</script> <style type="text/css" media="screen">body{font-size:14px;font-family:arial;font-weight:normal;color:#555}a{color:#27aae1}h2.posttitle{font-size:18px;font-family:arial;font-weight:normal;color:#555}h2.posttitle
a{color:#034693}.widgettitle{font-size:14px;font-family:arial;font-weight:normal;color:#555}.catname
span{font-size:22px;font-family:arial;font-weight:normal;color:#555}</style></head><body class="post-template-default single single-post postid-184712 single-format-standard"><div class="ad728"> <script>broadstreet.zone(50034);</script> </div><div class="wrapper"><div id="masthead"><ul class="mastheadnav dropdown"><li class="first"><a href="https://www.barbadostoday.bb/" title="News you can trust.">Home</a></li><li id="menu-item-50433" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50433"><a title="Our Print-Style Publication" href="http://epaper.barbadostoday.bb">ePaper</a></li><li id="menu-item-142207" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142207"><a href="https://www.barbadostoday.bb/download-todays-news-app/">Mobile App</a></li><li id="menu-item-142206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-142206"><a href="https://www.barbadostoday.bb/newsletters/">Newsletters</a></li><li id="menu-item-142202" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142202"><a href="https://www.facebook.com/barbadostoday">Facebook</a></li><li id="menu-item-142205" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142205"><a href="https://www.youtube.com/user/barbadostoday?&#038;ab_channel=BarbadosToday">YouTube</a></li><li id="menu-item-142203" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142203"><a href="https://twitter.com/barbadostoday">Twitter</a></li><li id="menu-item-142201" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-142201"><a href="https://instagram.com/barbadostoday/">Instagram</a></li></ul><div class="search"><form class="gabfire_search_style1" action="https://www.barbadostoday.bb/"><fieldset> <input type="text" class="gab_search_text" name="s" value="Search in site..." onfocus="if (this.value == 'Search in site...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search in site...';}" /> <input type="submit"  value="" class="submit_style1" /><div class="clearfix"></div></fieldset></form></div></div><div id="header"> <a href="https://www.barbadostoday.bb/" title="News you can trust."> <img  src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/09/2016BT-Website-Christmas-Header-New-01.jpg" id="header_banner" alt="Barbados Today" title="Barbados Today"/> </a></div><div id="mainmenu"><ul class="mainnav dropdown"><li class="first"><a href="https://www.barbadostoday.bb/" title="News you can trust.">Home</a></li><li id="menu-item-157940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157940"><a href="https://www.barbadostoday.bb/category/local-news/">Local News</a><ul class="sub-menu"><li id="menu-item-157948" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157948"><a href="https://www.barbadostoday.bb/category/local-news/agriculture/">Agriculture</a></li><li id="menu-item-157949" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157949"><a href="https://www.barbadostoday.bb/category/local-news/church/">Church</a></li><li id="menu-item-157951" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-157951"><a href="https://www.barbadostoday.bb/category/court/">Court</a></li><li id="menu-item-157952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157952"><a href="https://www.barbadostoday.bb/category/local-news/crime/">Crime</a></li><li id="menu-item-157953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157953"><a href="https://www.barbadostoday.bb/category/local-news/culture/">Culture</a></li><li id="menu-item-157954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157954"><a href="https://www.barbadostoday.bb/category/local-news/economy/">Economy</a></li><li id="menu-item-157955" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157955"><a href="https://www.barbadostoday.bb/category/local-news/education/">Education</a></li><li id="menu-item-157957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157957"><a href="https://www.barbadostoday.bb/category/local-news/energy/">Energy</a></li><li id="menu-item-157958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157958"><a href="https://www.barbadostoday.bb/category/local-news/environment/">Environment</a></li><li id="menu-item-157959" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157959"><a href="https://www.barbadostoday.bb/category/local-news/health-care/">Health Care</a></li><li id="menu-item-157961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157961"><a href="https://www.barbadostoday.bb/category/local-news/transportation/">Transportation</a></li></ul></li><li id="menu-item-157941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157941"><a href="https://www.barbadostoday.bb/category/sports/">Sports</a><ul class="sub-menu"><li id="menu-item-157962" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157962"><a href="https://www.barbadostoday.bb/category/sports/cricket/">Cricket</a></li><li id="menu-item-157963" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157963"><a href="https://www.barbadostoday.bb/category/sports/athletics/">Athletics</a></li><li id="menu-item-157964" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157964"><a href="https://www.barbadostoday.bb/category/sports/basketball/">Basketball</a></li><li id="menu-item-157965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157965"><a href="https://www.barbadostoday.bb/category/sports/football/">Football</a></li><li id="menu-item-157966" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157966"><a href="https://www.barbadostoday.bb/category/sports/motor-sport/">Motor Sport</a></li><li id="menu-item-157967" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157967"><a href="https://www.barbadostoday.bb/category/sports/netball/">Netball</a></li><li id="menu-item-157968" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157968"><a href="https://www.barbadostoday.bb/category/sports/school/">School</a></li><li id="menu-item-157969" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157969"><a href="https://www.barbadostoday.bb/category/sports/tennis/">Tennis</a></li><li id="menu-item-157970" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157970"><a href="https://www.barbadostoday.bb/category/sports/road-tennis/">Road Tennis</a></li><li id="menu-item-157971" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157971"><a href="https://www.barbadostoday.bb/category/sports/track-and-field/">Track and Field</a></li></ul></li><li id="menu-item-157944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157944"><a href="https://www.barbadostoday.bb/category/business/">Business</a><ul class="sub-menu"><li id="menu-item-157978" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157978"><a href="https://www.barbadostoday.bb/category/business/banking/">Banking</a></li><li id="menu-item-157975" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157975"><a href="https://www.barbadostoday.bb/category/business/entrepreneurship/">Entrepreneurship</a></li><li id="menu-item-157974" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157974"><a href="https://www.barbadostoday.bb/category/business/industrial-relations/">Indus. Relations</a></li><li id="menu-item-157976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157976"><a href="https://www.barbadostoday.bb/category/business/international-business/">Int&#8217;l Business</a></li><li id="menu-item-157973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157973"><a href="https://www.barbadostoday.bb/category/business/social-partnership/">Social Partnership</a></li><li id="menu-item-157977" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157977"><a href="https://www.barbadostoday.bb/category/business/stock-exchange/">Stock Exchange</a></li><li id="menu-item-157979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157979"><a href="https://www.barbadostoday.bb/category/local-news/telecommunications/">Telecommunications</a></li><li id="menu-item-157972" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157972"><a href="https://www.barbadostoday.bb/category/business/tourism/">Tourism</a></li></ul></li><li id="menu-item-158027" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-158027"><a href="https://www.barbadostoday.bb/category/leisure/entertainment/">Entertainment</a><ul class="sub-menu"><li id="menu-item-158029" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158029"><a href="https://www.barbadostoday.bb/category/leisure/entertainment/music/">Music</a></li><li id="menu-item-158005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-158005"><a href="https://www.barbadostoday.bb/category/leisure/cropover/">Crop Over</a><ul class="sub-menu"><li id="menu-item-158010" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158010"><a href="https://www.barbadostoday.bb/category/leisure/cropover/kadooment-day/">Kadooment Day</a></li><li id="menu-item-158006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158006"><a href="https://www.barbadostoday.bb/category/leisure/cropover/foreday-mornin/">Foreday Mornin&#8217;</a></li><li id="menu-item-158009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158009"><a href="https://www.barbadostoday.bb/category/leisure/cropover/pic-o-de-crop/">Pic-O-De-Crop</a></li><li id="menu-item-158007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158007"><a href="https://www.barbadostoday.bb/category/leisure/cropover/junior-kadooment/">Junior Kadooment</a></li><li id="menu-item-158008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158008"><a href="https://www.barbadostoday.bb/category/leisure/cropover/junior-monarch/">Junior Monarch</a></li></ul></li><li id="menu-item-157945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157945"><a href="https://www.barbadostoday.bb/category/leisure/">Leisure</a><ul class="sub-menu"><li id="menu-item-158002" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158002"><a href="https://www.barbadostoday.bb/category/lifestyle/recipes/">Recipes</a></li></ul></li><li id="menu-item-158028" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158028"><a href="https://www.barbadostoday.bb/category/lifestyle/">Lifestyle</a></li></ul></li><li id="menu-item-157946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157946"><a href="https://www.barbadostoday.bb/category/politics/">Politics</a><ul class="sub-menu"><li id="menu-item-157981" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157981"><a href="https://www.barbadostoday.bb/category/politics/house-of-assembly/">House of Assembly</a></li><li id="menu-item-157980" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157980"><a href="https://www.barbadostoday.bb/category/politics/senate/">Senate</a></li><li id="menu-item-157982" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157982"><a href="https://www.barbadostoday.bb/category/politics/elections-2013/">Elections 2013</a></li></ul></li><li id="menu-item-157942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157942"><a href="https://www.barbadostoday.bb/category/regional/">Regional</a><ul class="sub-menu"><li id="menu-item-157997" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157997"><a href="https://www.barbadostoday.bb/category/regional/bahamas/">Bahamas</a></li><li id="menu-item-157996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157996"><a href="https://www.barbadostoday.bb/category/regional/ccj/">CCJ</a></li><li id="menu-item-157985" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157985"><a href="https://www.barbadostoday.bb/category/regional/grenada/">Grenada</a></li><li id="menu-item-157986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157986"><a href="https://www.barbadostoday.bb/category/regional/haiti/">Haiti</a></li><li id="menu-item-157998" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157998"><a href="https://www.barbadostoday.bb/category/regional/liat/">LIAT</a></li><li id="menu-item-157988" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157988"><a href="https://www.barbadostoday.bb/category/regional/st-kitts-nevis/">St Kitts &#038; Nevis</a></li><li id="menu-item-157989" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157989"><a href="https://www.barbadostoday.bb/category/regional/st-lucia/">St Lucia</a></li><li id="menu-item-157990" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157990"><a href="https://www.barbadostoday.bb/category/regional/st-vincent/">St Vincent</a></li><li id="menu-item-157991" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157991"><a href="https://www.barbadostoday.bb/category/regional/trinidad-and-tobago/">Trinidad &#038; Tobago</a></li><li id="menu-item-157992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-157992"><a href="https://www.barbadostoday.bb/category/regional/uwi/">UWI</a></li></ul></li><li id="menu-item-157943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-157943"><a href="https://www.barbadostoday.bb/category/world/">World</a><ul class="sub-menu"><li id="menu-item-158011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158011"><a href="https://www.barbadostoday.bb/category/world/africa/">Africa</a></li><li id="menu-item-158012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158012"><a href="https://www.barbadostoday.bb/category/world/asia/">Asia</a></li><li id="menu-item-158013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158013"><a href="https://www.barbadostoday.bb/category/world/australia/">Australia</a></li><li id="menu-item-158014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158014"><a href="https://www.barbadostoday.bb/category/world/canada/">Canada</a></li><li id="menu-item-158015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158015"><a href="https://www.barbadostoday.bb/category/world/europe/">Europe</a></li><li id="menu-item-158016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158016"><a href="https://www.barbadostoday.bb/category/world/india/">India</a></li><li id="menu-item-158017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158017"><a href="https://www.barbadostoday.bb/category/world/latin-america/">Latin America</a></li><li id="menu-item-158018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158018"><a href="https://www.barbadostoday.bb/category/world/middle-east/">Middle East</a></li><li id="menu-item-158019" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158019"><a href="https://www.barbadostoday.bb/category/world/uk/">United Kingdom</a></li><li id="menu-item-158020" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-158020"><a href="https://www.barbadostoday.bb/category/world/usa/">USA</a></li></ul></li></ul><div class="clear"></div></div><div id="submenu"><ul class="subnav dropdown"><li id="menu-item-84876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84876"><a href="https://www.barbadostoday.bb/gallery-cats/news-updates/">Video News</a></li><li id="menu-item-84877" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84877"><a href="https://www.barbadostoday.bb/gallery-cats/entertainment-weekly/">Entertainment Weekly</a></li><li id="menu-item-84878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84878"><a href="https://www.barbadostoday.bb/gallery-cats/business-minute/">Business Minute</a></li><li id="menu-item-21347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21347"><a href="https://www.barbadostoday.bb/category/editorial/">Editorial</a></li><li id="menu-item-6520" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6520"><a href="https://www.barbadostoday.bb/category/column/">Columns</a></li><li id="menu-item-21349" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21349"><a href="https://www.barbadostoday.bb/category/letters/">Letters</a></li><li class="date right"> <script type="text/javascript">/*<![CDATA[*/var mydate=new Date()
var year=mydate.getYear()
if(year<1000)
year+=1900
var day=mydate.getDay()
var month=mydate.getMonth()
var daym=mydate.getDate()
if(daym<10)
daym="0"+daym
var dayarray=new Array("Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday")
var montharray=new Array("January","February","March","April","May","June","July","August","September","October","November","December")
document.write(""+dayarray[day]+", "+montharray[month]+" "+daym+", "+year+"")/*]]>*/</script> </li></ul><div class="clear"></div></div><div id="container"><div id="content"><div id="post-184712" class="entry single-default post-184712 post type-post status-publish format-standard has-post-thumbnail hentry category-court"><h1 class="entry_title"> Convicted gas bottle thief nabbed with a stove</h1><div class="single_postmeta"> <span class="left"> Added by <a href="https://www.barbadostoday.bb/author/bteditor/">Barbados Today</a> on December 22, 2016.<br />Saved under <a href="https://www.barbadostoday.bb/category/court/" rel="category tag">Court</a><br /> </span> <span class="right"><div id="text-11" class="widget widget_text"><div class="widgetinner"><div class="textwidget"><div class="wpsso-ssb wpsso-ssb-shortcode"><div class="ssb-buttons en_US"><div class="fb-like facebook-ssb-shortcode" id="facebook-button-post-184712"><fb:like href="https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/" send="true" layout="button_count" show_faces="false" font="arial" colorscheme="light" action="like"></fb:like></div><div class="gplusone-ssb-shortcode" id="gplusone-button-post-184712"><span class="g-plusone" data-size="medium" data-annotation="bubble" data-href="https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/"></span></div><div class="pinterest-ssb-shortcode" id="pinterest-button-post-184712"><a href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.barbadostoday.bb%2F2016%2F12%2F22%2Fconvicted-gas-bottle-thief-nabbed-with-a-stove%2F&amp;media=https%3A%2F%2F16f6e5e6d2.site.internapcdn.net%2Fwp-content%2Fuploads%2F2016%2F12%2FWinstonXKing-800x436.jpg&amp;description=A%2045-year-old%20man%20who%20previously%20served%20time%20behind%20bars%20for%20stealing%20bottles%20of%20gas%2C%20returned%20before%20the%20law%20courts%20today%20charged%20with%20theft%20of%20a%20stove.%20Winston%20Leroy%20King%2C%20of%20Thompson%20Land%2C%20Licorish%20Village%2C%20St%20Michael%2C%20admitted%20in%20the%20District%20%E2%80%98A%E2%80%99%20Magistrates%E2%80%99%20Court%20to%20entering%20Daniel%20Lowe%E2%80%99s%20house%20on%20December%2020%20and%20stealing%20a%20stove%20worth%20%241%2C800.%20According%20to%20the%20facts%20presented%20by%20Sergeant..." data-pin-do="buttonPin" data-pin-zero="true" data-pin-lang="en" data-pin-shape="rect" data-pin-color="gray" data-pin-height="20" data-pin-config="beside"><img border="0" alt="Pin It" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" width="40" height="20" /><noscript><img border="0" alt="Pin It" src="https://assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" width="40" height="20" /></noscript></a></div><div class="twitter-ssb-shortcode" id="twitter-button-post-184712"><a href="https://twitter.com/share" class="twitter-share-button" data-lang="en" data-url="https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/" data-counturl="https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/" data-text="Convicted gas bottle thief nabbed with a stove" data-via="barbadostoday" data-related="" data-hashtags="" data-size="medium" data-dnt="true"></a></div></div></div> <script type="text/javascript" id="pinterest-script-shortcode-footer">wpsso_insert_js("pinterest-script-shortcode-footer","https://assets.pinterest.com/js/pinit.js");</script> </div></div></div> </span><div class="clear"></div></div><p class="p1">A 45-year-old man who previously served time behind bars for stealing bottles of gas, returned before the law courts today charged with theft of a stove.</p><p class="p1">Winston Leroy King, of Thompson Land, Licorish Village, St Michael, admitted in the District ‘A’ Magistrates’ Court to entering Daniel Lowe’s house on December 20 and stealing a stove worth $1,800.</p><p class="p1">According to the facts presented by Sergeant Rudy Pilgrim, the complainant lives at another location but owns a home in 2nd Avenue, Licorish Village, which is currently unoccupied and undergoing repairs.</p><p class="p1">It was a call from one of the neighbours that alerted Lowe to the burglary and when the homeowner arrived he noticed that a kitchen window was broken and the doors open.</p><p class="p1">Lowe also observed that his stove was missing from the kitchen. The break-in was reported to police and the stove was recovered from a residence in the area where it was apparently hidden by King who is well known to the court. He was later arrested.</p><p class="p1">Today, the accused man admitted before Magistrate Douglas Frederick to entering Lowe’s house and taking the appliance.</p><p class="p1">However, he claimed that he was sent there by a lady who paid him $15 to remove the stove.</p><p class="p1">“I took the stove out of there and it was too heavy for I to go up by the track by she with the stove, so I took it by [another residence],” he said.</p><p class="p1">“Sir I was doing a job. I didn’t know. This house was already open, and I entered,” King explained, stressing that he did not break into Lowe’s place.</p><p class="p1">“Sir all I does do is work. Sir I making money and I doing foolishness with it, buying drugs. Right now Sir I on drugs, I on cocaine and I pun alcohol and I just need a little help Sir. Nothing else in the house was [taken] but the stove you know,” he said in an impassioned appeal to the magistrate.</p><p class="p1">However his plea to be remanded at the Psychiatric Hospital was denied.</p><p class="p1">Instead, King was sentenced to six months at HMP Dodds.</p><div class="wpsso-ssb wpsso-ssb-content"><div class="ssb-buttons en_US"><div class="css-button email-button"> <a href="mailto:?subject=Share:%20Convicted%20gas%20bottle%20thief%20nabbed%20with%20a%20stove&body=A%2045-year-old%20man%20who%20previously%20served%20time%20behind%20bars%20for%20stealing%20bottles%20of%20gas%2C%20returned%20before%20the%20law%20courts%20today%20charged%20with%20theft%20of%20a%20stove.%20Winston%20Leroy%20King%2C%20of%20Thompson%20Land%2C%20Licorish%20Village%2C%20St%20Michael%2C%20admitted%20in%20the%20District%20%E2%80%98A%E2%80%99%20Magistrates%E2%80%99%20Court%20to%20entering%20Daniel%20Lowe%E2%80%99s%20house%20on%20December%2020%20and%20stealing%20a%20stove%20worth%20%241%2C800.%20According%20to%20the%20facts%20presented%20by%20Sergeant%20Rudy%20Pilgrim%2C%20the%20complainant%20lives%20at%20another%20location%20but%20owns%20a%20home%20in%202nd%20Avenue%2C%20Licorish...%0D%0A%0D%0AShared%20from%20https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/%0D%0A"> <span class="ssb-icon"> <svg xmlns="http://www.w3.org/2000/svg" width="9" height="9" viewBox="0 0 28 28"> <path d="M20.11 26.147c-2.335 1.05-4.36 1.4-7.124 1.4C6.524 27.548.84 22.916.84 15.284.84 7.343 6.602.45 15.4.45c6.854 0 11.8 4.7 11.8 11.252 0 5.684-3.193 9.265-7.398 9.3-1.83 0-3.153-.934-3.347-2.997h-.077c-1.208 1.986-2.96 2.997-5.023 2.997-2.532 0-4.36-1.868-4.36-5.062 0-4.75 3.503-9.07 9.11-9.07 1.713 0 3.7.4 4.6.972l-1.17 7.203c-.387 2.298-.115 3.3 1 3.4 1.674 0 3.774-2.102 3.774-6.58 0-5.06-3.27-8.994-9.304-8.994C9.05 2.87 3.83 7.545 3.83 14.97c0 6.5 4.2 10.2 10 10.202 1.987 0 4.09-.43 5.647-1.245l.634 2.22zM16.647 10.1c-.31-.078-.7-.155-1.207-.155-2.572 0-4.596 2.53-4.596 5.53 0 1.5.7 2.4 1.9 2.4 1.44 0 2.96-1.83 3.31-4.088l.592-3.72z" /> </svg> </span> <span class="ssb-text"></span> </a></div><div class="css-button whatsapp-button"> <a href="whatsapp://send?text=Convicted%20gas%20bottle%20thief%20nabbed%20with%20a%20stove%20https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/" data-action="share/whatsapp/share"> <span class="ssb-icon"> <svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="9" height="9" viewBox="0 0 90 90" enable-background="new 0 0 90 90;" xml:space="preserve"> <path d="M90,43.841c0,24.213-19.779,43.841-44.182,43.841c-7.747,0-15.025-1.98-21.357-5.455L0,90l7.975-23.522c-4.023-6.606-6.34-14.354-6.34-22.637C1.635,19.628,21.416,0,45.818,0C70.223,0,90,19.628,90,43.841z M45.818,6.982c-20.484,0-37.146,16.535-37.146,36.859c0,8.065,2.629,15.534,7.076,21.61L11.107,79.14l14.275-4.537c5.865,3.851,12.891,6.097,20.437,6.097c20.481,0,37.146-16.533,37.146-36.857S66.301,6.982,45.818,6.982z M68.129,53.938c-0.273-0.447-0.994-0.717-2.076-1.254c-1.084-0.537-6.41-3.138-7.4-3.495c-0.993-0.358-1.717-0.538-2.438,0.537c-0.721,1.076-2.797,3.495-3.43,4.212c-0.632,0.719-1.263,0.809-2.347,0.271c-1.082-0.537-4.571-1.673-8.708-5.333c-3.219-2.848-5.393-6.364-6.025-7.441c-0.631-1.075-0.066-1.656,0.475-2.191c0.488-0.482,1.084-1.255,1.625-1.882c0.543-0.628,0.723-1.075,1.082-1.793c0.363-0.717,0.182-1.344-0.09-1.883c-0.27-0.537-2.438-5.825-3.34-7.977c-0.902-2.15-1.803-1.792-2.436-1.792c-0.631,0-1.354-0.09-2.076-0.09c-0.722,0-1.896,0.269-2.889,1.344c-0.992,1.076-3.789,3.676-3.789,8.963c0,5.288,3.879,10.397,4.422,11.113c0.541,0.716,7.49,11.92,18.5,16.223 C58.2,65.771,58.2,64.336,60.186,64.156c1.984-0.179,6.406-2.599,7.312-5.107C68.398,56.537,68.398,54.386,68.129,53.938z"/> </svg> </span> <span class="ssb-text"></span> </a></div><div class="twitter-button" id="twitter-ssb-content-post-184712"><a href="https://twitter.com/share" class="twitter-share-button" data-lang="en" data-url="https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/" data-counturl="https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/" data-text="Convicted gas bottle thief nabbed with a stove" data-via="barbadostoday" data-related="" data-hashtags="" data-size="medium" data-dnt="true"></a></div><div class="fb-like facebook-button" id="facebook-ssb-content-post-184712"><fb:like href="https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/" send="true" layout="button_count" show_faces="false" font="arial" colorscheme="light" action="like"></fb:like></div><div class="gplusone-button" id="gplusone-ssb-content-post-184712"><span class="g-plusone" data-size="medium" data-annotation="bubble" data-href="https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/"></span></div><div class="linkedin-button" id="linkedin-ssb-content-post-184712"><script type="IN/Share" data-url="https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/" data-counter="right" data-showzero="true"></script></div></div></div><div class="clear"></div></div><div id="comments"><h3 id="comments-title"> 19 Responses to <em>Convicted gas bottle thief nabbed with a stove</em></h3><ol class="commentlist"><li class="comment even thread-even depth-1" id="li-comment-131990"><div class="comment-inner" id="comment-131990"><div class="comment-top"><div class="comment-avatar"> <img alt='Chris Ghita' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/10206094201209109/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Chris Ghita' src='https://graph.facebook.com/v2.3/10206094201209109/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/10206094201209109' rel='external nofollow' class='url'>Chris Ghita</a></cite> December 22, 2016 at 4:57 am</div></div><p>Makes sense</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=131990eForm( "comment-131990", "131990", "respond", "184712" )' aria-label='Reply to Chris Ghita'>Reply</a></span></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="li-comment-131989"><div class="comment-inner" id="comment-131989"><div class="comment-top"><div class="comment-avatar"> <img alt='Carolyn Robertson' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/672534826224048/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Carolyn Robertson' src='https://graph.facebook.com/v2.3/672534826224048/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/672534826224048' rel='external nofollow' class='url'>Carolyn Robertson</a></cite> December 22, 2016 at 5:28 am</div></div><p>You don&#8217;t expect the man to cook lol</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=131989eForm( "comment-131989", "131989", "respond", "184712" )' aria-label='Reply to Carolyn Robertson'>Reply</a></span></div></li><li class="comment even thread-even depth-1" id="li-comment-132001"><div class="comment-inner" id="comment-132001"><div class="comment-top"><div class="comment-avatar"> <img alt='Cherry Amor' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/1034396456649094/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Cherry Amor' src='https://graph.facebook.com/v2.3/1034396456649094/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/1034396456649094' rel='external nofollow' class='url'>Cherry Amor</a></cite> December 22, 2016 at 5:39 am</div></div><p>Stolen gasbottle + stove = prison</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132001eForm( "comment-132001", "132001", "respond", "184712" )' aria-label='Reply to Cherry Amor'>Reply</a></span></div><ul class="children"><li class="comment odd alt depth-2" id="li-comment-132019"><div class="comment-inner" id="comment-132019"><div class="comment-top"><div class="comment-avatar"> <img alt='Cherry Amor' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/1034396456649094/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Cherry Amor' src='https://graph.facebook.com/v2.3/1034396456649094/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/1034396456649094' rel='external nofollow' class='url'>Cherry Amor</a></cite> December 22, 2016 at 6:40 am</div></div><p>Charles Mitchell LOLLL</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132019eForm( "comment-132019", "132019", "respond", "184712" )' aria-label='Reply to Cherry Amor'>Reply</a></span></div></li></ul></li><li class="comment even thread-odd thread-alt depth-1" id="li-comment-131993"><div class="comment-inner" id="comment-131993"><div class="comment-top"><div class="comment-avatar"> <img alt='' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://secure.gravatar.com/avatar/7a4a2a1d70d017201f5acee39cef7118?s=40&#038;d=mm&#038;r=g' data-lazy-srcset='https://secure.gravatar.com/avatar/7a4a2a1d70d017201f5acee39cef7118?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /><noscript><img alt='' src='https://secure.gravatar.com/avatar/7a4a2a1d70d017201f5acee39cef7118?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7a4a2a1d70d017201f5acee39cef7118?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn">Maria</cite> December 22, 2016 at 5:39 am</div></div><p>A stove? Really?</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=131993eForm( "comment-131993", "131993", "respond", "184712" )' aria-label='Reply to Maria'>Reply</a></span></div></li><li class="comment odd alt thread-even depth-1" id="li-comment-131999"><div class="comment-inner" id="comment-131999"><div class="comment-top"><div class="comment-avatar"> <img alt='Veronica Straker' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/10154142924607316/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Veronica Straker' src='https://graph.facebook.com/v2.3/10154142924607316/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/10154142924607316' rel='external nofollow' class='url'>Veronica Straker</a></cite> December 22, 2016 at 5:44 am</div></div><p>45 US??????? Man I&#8217;m 46 and he looks old enough to be my dad.</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=131999eForm( "comment-131999", "131999", "respond", "184712" )' aria-label='Reply to Veronica Straker'>Reply</a></span></div><ul class="children"><li class="comment even depth-2" id="li-comment-132014"><div class="comment-inner" id="comment-132014"><div class="comment-top"><div class="comment-avatar"> <img alt='Sherwin Patterson' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/10206812910140126/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Sherwin Patterson' src='https://graph.facebook.com/v2.3/10206812910140126/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/10206812910140126' rel='external nofollow' class='url'>Sherwin Patterson</a></cite> December 22, 2016 at 6:49 am</div></div> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132014eForm( "comment-132014", "132014", "respond", "184712" )' aria-label='Reply to Sherwin Patterson'>Reply</a></span></div></li><li class="comment odd alt depth-2" id="li-comment-132036"><div class="comment-inner" id="comment-132036"><div class="comment-top"><div class="comment-avatar"> <img alt='Cherylann Bourne-Hayes' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/10203447115208413/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Cherylann Bourne-Hayes' src='https://graph.facebook.com/v2.3/10203447115208413/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/10203447115208413' rel='external nofollow' class='url'>Cherylann Bourne-Hayes</a></cite> December 22, 2016 at 8:33 am</div></div><p>I was saying the same thing and I am 49</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132036eForm( "comment-132036", "132036", "respond", "184712" )' aria-label='Reply to Cherylann Bourne-Hayes'>Reply</a></span></div></li></ul></li><li class="comment even thread-odd thread-alt depth-1" id="li-comment-132000"><div class="comment-inner" id="comment-132000"><div class="comment-top"><div class="comment-avatar"> <img alt='Rehcra Aicram Enelra' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/939841702704533/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Rehcra Aicram Enelra' src='https://graph.facebook.com/v2.3/939841702704533/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/939841702704533' rel='external nofollow' class='url'>Rehcra Aicram Enelra</a></cite> December 22, 2016 at 6:15 am</div></div><p>You will be going home for the holidays&#8230; lol</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132000eForm( "comment-132000", "132000", "respond", "184712" )' aria-label='Reply to Rehcra Aicram Enelra'>Reply</a></span></div></li><li class="comment odd alt thread-even depth-1" id="li-comment-132022"><div class="comment-inner" id="comment-132022"><div class="comment-top"><div class="comment-avatar"> <img alt='Anfaani Henry' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/1429846900676676/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Anfaani Henry' src='https://graph.facebook.com/v2.3/1429846900676676/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/1429846900676676' rel='external nofollow' class='url'>Anfaani Henry</a></cite> December 22, 2016 at 6:41 am</div></div><p>They got heat in Dodds</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132022eForm( "comment-132022", "132022", "respond", "184712" )' aria-label='Reply to Anfaani Henry'>Reply</a></span></div></li><li class="comment even thread-odd thread-alt depth-1" id="li-comment-132008"><div class="comment-inner" id="comment-132008"><div class="comment-top"><div class="comment-avatar"> <img alt='' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://secure.gravatar.com/avatar/4d0e916c8815c56f80edd109db41ebfc?s=40&#038;d=mm&#038;r=g' data-lazy-srcset='https://secure.gravatar.com/avatar/4d0e916c8815c56f80edd109db41ebfc?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /><noscript><img alt='' src='https://secure.gravatar.com/avatar/4d0e916c8815c56f80edd109db41ebfc?s=40&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/4d0e916c8815c56f80edd109db41ebfc?s=80&amp;d=mm&amp;r=g 2x' class='avatar avatar-40 photo' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn">Alex Alleyne</cite> December 22, 2016 at 6:54 am</div></div><p>&#8220;Stove and gas bottle&#8221; go together like &#8220;hand and glove&#8221;.<br /> Must cook to eat &#8230;.and live.<br /> Sorry chap, try facing the store next time &#8230;&#8230;.with some money.</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132008eForm( "comment-132008", "132008", "respond", "184712" )' aria-label='Reply to Alex Alleyne'>Reply</a></span></div></li><li class="comment odd alt thread-even depth-1" id="li-comment-132021"><div class="comment-inner" id="comment-132021"><div class="comment-top"><div class="comment-avatar"> <img alt='Aviston Byer' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/10207341704916779/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Aviston Byer' src='https://graph.facebook.com/v2.3/10207341704916779/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/10207341704916779' rel='external nofollow' class='url'>Aviston Byer</a></cite> December 22, 2016 at 7:08 am</div></div><p>Man wanted to brew up a pot</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132021eForm( "comment-132021", "132021", "respond", "184712" )' aria-label='Reply to Aviston Byer'>Reply</a></span></div></li><li class="comment even thread-odd thread-alt depth-1" id="li-comment-132017"><div class="comment-inner" id="comment-132017"><div class="comment-top"><div class="comment-avatar"> <img alt='Adrian Allison' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/197689603988577/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Adrian Allison' src='https://graph.facebook.com/v2.3/197689603988577/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/197689603988577' rel='external nofollow' class='url'>Adrian Allison</a></cite> December 22, 2016 at 7:34 am</div></div><p>Just what I was thinking Jai.</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132017eForm( "comment-132017", "132017", "respond", "184712" )' aria-label='Reply to Adrian Allison'>Reply</a></span></div></li><li class="comment odd alt thread-even depth-1" id="li-comment-132041"><div class="comment-inner" id="comment-132041"><div class="comment-top"><div class="comment-avatar"> <img alt='Kim Ramsay' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/10152657395856324/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Kim Ramsay' src='https://graph.facebook.com/v2.3/10152657395856324/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/10152657395856324' rel='external nofollow' class='url'>Kim Ramsay</a></cite> December 22, 2016 at 7:45 am</div></div><p>45???? Never!!!!</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132041eForm( "comment-132041", "132041", "respond", "184712" )' aria-label='Reply to Kim Ramsay'>Reply</a></span></div></li><li class="comment even thread-odd thread-alt depth-1" id="li-comment-132038"><div class="comment-inner" id="comment-132038"><div class="comment-top"><div class="comment-avatar"> <img alt='Keith Forde' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/633424660169703/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Keith Forde' src='https://graph.facebook.com/v2.3/633424660169703/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/633424660169703' rel='external nofollow' class='url'>Keith Forde</a></cite> December 22, 2016 at 8:20 am</div></div><p>SO DENNIS,IS IT ALLRIGHT FOR HIM TO THEIF THE STOVE..(JUST ASKING)</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132038eForm( "comment-132038", "132038", "respond", "184712" )' aria-label='Reply to Keith Forde'>Reply</a></span></div></li><li class="comment odd alt thread-even depth-1" id="li-comment-132042"><div class="comment-inner" id="comment-132042"><div class="comment-top"><div class="comment-avatar"> <img alt='Antonio Cozier' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/1080901478601605/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Antonio Cozier' src='https://graph.facebook.com/v2.3/1080901478601605/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/1080901478601605' rel='external nofollow' class='url'>Antonio Cozier</a></cite> December 22, 2016 at 8:24 am</div></div><p>Is he on a personal mission to stop people from cooking</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132042eForm( "comment-132042", "132042", "respond", "184712" )' aria-label='Reply to Antonio Cozier'>Reply</a></span></div></li><li class="comment even thread-odd thread-alt depth-1" id="li-comment-132037"><div class="comment-inner" id="comment-132037"><div class="comment-top"><div class="comment-avatar"> <img alt='Kelly Scantlebury' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/1507222576234505/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Kelly Scantlebury' src='https://graph.facebook.com/v2.3/1507222576234505/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/1507222576234505' rel='external nofollow' class='url'>Kelly Scantlebury</a></cite> December 22, 2016 at 8:26 am</div></div><p>Between this story and the other one with the &#8216;violent foursome&#8221;. I am quite entertained . 45 years old you say ?</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132037eForm( "comment-132037", "132037", "respond", "184712" )' aria-label='Reply to Kelly Scantlebury'>Reply</a></span></div></li><li class="comment odd alt thread-even depth-1" id="li-comment-132040"><div class="comment-inner" id="comment-132040"><div class="comment-top"><div class="comment-avatar"> <img alt='Keith Forde' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/633424660169703/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Keith Forde' src='https://graph.facebook.com/v2.3/633424660169703/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/633424660169703' rel='external nofollow' class='url'>Keith Forde</a></cite> December 22, 2016 at 8:33 am</div></div><p>I KEEP SAYING THIS FOR YEARS,THE BARBADOS EDUCATIONAL SYSTEM,SHOULD TEACH PEOPLE HOW TO BE ENTREPRENEURS,AND NOT FOCUS EVERYTHING ON MATHS,ENGLISH AND SOCIAL SCIENCES,THERE IS NOTHING WRONG WITH THE ABOVE SUBJECTS..</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132040eForm( "comment-132040", "132040", "respond", "184712" )' aria-label='Reply to Keith Forde'>Reply</a></span></div></li><li class="comment even thread-odd thread-alt depth-1" id="li-comment-132039"><div class="comment-inner" id="comment-132039"><div class="comment-top"><div class="comment-avatar"> <img alt='Cherylann Bourne-Hayes' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://graph.facebook.com/v2.3/10203447115208413/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /><noscript><img alt='Cherylann Bourne-Hayes' src='https://graph.facebook.com/v2.3/10203447115208413/picture' class='avatar avatar-40 photo avatar-default' height='40' width='40' /></noscript></div><div class="commentmeta"><cite class="fn"><a href='https://www.facebook.com/10203447115208413' rel='external nofollow' class='url'>Cherylann Bourne-Hayes</a></cite> December 22, 2016 at 8:34 am</div></div><p>Well the bottle itself won&#8217;t work. Lol</p> <span class="reply"><a rel='nofollow' class='comment-reply-link' href='https://16f6e5e6d2.site.internapcdn.net/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/?replytocom=132039eForm( "comment-132039", "132039", "respond", "184712" )' aria-label='Reply to Cherylann Bourne-Hayes'>Reply</a></span></div></li></ol><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.barbadostoday.bb/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p> <script>document.write(String.fromCharCode(60,105,110,112,117,116,32,116,121,112,101,61,104,105,100,100,101,110,32,110,97,109,101,61,34,90,109,78,115,55,73,56,104,34,32,118,97,108,117,101,61,34,52,57,57,49,58,98,52,98,101,97,54,51,100,52,97,97,53,98,101,99,52,55,48,99,51,51,102,52,51,50,53,48,56,57,101,54,102,50,101,49,55,102,99,102,57,34,62));</script><noscript><strong><font color=red>Please enable JavaScript</font></strong></noscript><div style="display:none;"><input type="text" name="Wuu2y" value="" /></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='184712' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="92968dd555" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="132"/></p></form></div></div></div><div id="sidebar"><div class="sidebarinner"><div class="widget"> <script>broadstreet.zone(50041);</script> <br> <br> <script>broadstreet.zone(51631);</script></div><div id="popular-widget-5" class="widget popular-widget"><div class="widgetinner"><h3 class="widgettitle">Popular (Last 7 Days)</h3><div class="pop-layout-v"><ul id="pop-widget-tabs-5" class="pop-widget-tabs pop-widget-tabs-3" ><li><a href="#recent" rel="nofollow">Recent Posts</a></li><li><a href="#commented" rel="nofollow">Most Commented</a></li><li><a href="#viewed" rel="nofollow">Most Viewed</a></li></ul><div class="pop-inside-5 pop-inside"><ul id="pop-widget-recent-5"><li><a href="https://www.barbadostoday.bb/2016/12/22/outstanding/" title="Outstanding!" rel="bookmark"><img width="900" height="399" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/SomeXmembersXofXtheX1966XBarbadosXCricketXteamXcopy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/SomeXmembersXofXtheX1966XBarbadosXCricketXteamXcopy.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/SomeXmembersXofXtheX1966XBarbadosXCricketXteamXcopy-650x288.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/SomeXmembersXofXtheX1966XBarbadosXCricketXteamXcopy-768x340.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/SomeXmembersXofXtheX1966XBarbadosXCricketXteamXcopy-160x71.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/SomeXmembersXofXtheX1966XBarbadosXCricketXteamXcopy-640x284.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/SomeXmembersXofXtheX1966XBarbadosXCricketXteamXcopy-800x355.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="184755" /><noscript><img width="900" height="399" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/SomeXmembersXofXtheX1966XBarbadosXCricketXteamXcopy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/SomeXmembersXofXtheX1966XBarbadosXCricketXteamXcopy.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/SomeXmembersXofXtheX1966XBarbadosXCricketXteamXcopy-650x288.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/SomeXmembersXofXtheX1966XBarbadosXCricketXteamXcopy-768x340.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/SomeXmembersXofXtheX1966XBarbadosXCricketXteamXcopy-160x71.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/SomeXmembersXofXtheX1966XBarbadosXCricketXteamXcopy-640x284.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/SomeXmembersXofXtheX1966XBarbadosXCricketXteamXcopy-800x355.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="184755" /></noscript><span class="pop-overlay"><span class="pop-title">Outstanding!</span> <span class="pop-summary">The past, present and the future came together, spanning Barbados’...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2016/12/22/tokyo-2020-looks-for-savings/" title="Tokyo 2020 looks for savings" rel="bookmark"><img width="800" height="450" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/BuildingXworkXbeganXonXtheXTokyoX2020XnationalXstadiumXearlierXthisXmonth..jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/BuildingXworkXbeganXonXtheXTokyoX2020XnationalXstadiumXearlierXthisXmonth..jpg 800w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/BuildingXworkXbeganXonXtheXTokyoX2020XnationalXstadiumXearlierXthisXmonth.-650x366.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/BuildingXworkXbeganXonXtheXTokyoX2020XnationalXstadiumXearlierXthisXmonth.-768x432.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/BuildingXworkXbeganXonXtheXTokyoX2020XnationalXstadiumXearlierXthisXmonth.-160x90.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/BuildingXworkXbeganXonXtheXTokyoX2020XnationalXstadiumXearlierXthisXmonth.-480x270.jpg 480w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/BuildingXworkXbeganXonXtheXTokyoX2020XnationalXstadiumXearlierXthisXmonth.-640x360.jpg 640w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-wp-pid="184728" /><noscript><img width="800" height="450" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/BuildingXworkXbeganXonXtheXTokyoX2020XnationalXstadiumXearlierXthisXmonth..jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/BuildingXworkXbeganXonXtheXTokyoX2020XnationalXstadiumXearlierXthisXmonth..jpg 800w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/BuildingXworkXbeganXonXtheXTokyoX2020XnationalXstadiumXearlierXthisXmonth.-650x366.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/BuildingXworkXbeganXonXtheXTokyoX2020XnationalXstadiumXearlierXthisXmonth.-768x432.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/BuildingXworkXbeganXonXtheXTokyoX2020XnationalXstadiumXearlierXthisXmonth.-160x90.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/BuildingXworkXbeganXonXtheXTokyoX2020XnationalXstadiumXearlierXthisXmonth.-480x270.jpg 480w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/BuildingXworkXbeganXonXtheXTokyoX2020XnationalXstadiumXearlierXthisXmonth.-640x360.jpg 640w" sizes="(max-width: 800px) 100vw, 800px" data-wp-pid="184728" /></noscript><span class="pop-overlay"><span class="pop-title">Tokyo 2020 looks for savings</span> <span class="pop-summary">Organisers of the Tokyo 2020 Olympics have set a budget...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2016/12/22/boxing-day-buzz/" title="Boxing Day buzz" rel="bookmark"><img width="900" height="615" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JustXAXFashionXgoingXdownXtoXtheXstartXofXtheXCoolmoreXStakesX2016.-1.jpg" class="attachment-post-thumbnail size-post-thumbnail" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JustXAXFashionXgoingXdownXtoXtheXstartXofXtheXCoolmoreXStakesX2016.-1.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JustXAXFashionXgoingXdownXtoXtheXstartXofXtheXCoolmoreXStakesX2016.-1-650x444.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JustXAXFashionXgoingXdownXtoXtheXstartXofXtheXCoolmoreXStakesX2016.-1-768x525.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JustXAXFashionXgoingXdownXtoXtheXstartXofXtheXCoolmoreXStakesX2016.-1-160x109.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JustXAXFashionXgoingXdownXtoXtheXstartXofXtheXCoolmoreXStakesX2016.-1-640x437.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JustXAXFashionXgoingXdownXtoXtheXstartXofXtheXCoolmoreXStakesX2016.-1-800x547.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="184769" /><span class="pop-overlay"><span class="pop-title">Boxing Day buzz</span> <span class="pop-summary">Victor Cheeseman-trained Just A Fashion looks like the one to...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2016/12/22/bergan-denies-handling-stolen-property/" title="Bergan denies handling stolen property" rel="bookmark"><span class="pop-overlay"><span class="pop-title">Bergan denies handling stolen property</span> <span class="pop-summary">A St Michael woman was released on $5,000 bail yesterday...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2016/12/22/convicted-gas-bottle-thief-nabbed-with-a-stove/" title="Convicted gas bottle thief nabbed with a stove" rel="bookmark"><img width="900" height="490" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-650x354.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-768x418.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-93x50.jpg 93w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-160x87.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-225x123.jpg 225w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-640x348.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-800x436.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="184736" /><noscript><img width="900" height="490" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-650x354.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-768x418.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-93x50.jpg 93w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-160x87.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-225x123.jpg 225w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-640x348.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/WinstonXKing-800x436.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="184736" /></noscript><span class="pop-overlay"><span class="pop-title">Convicted gas bottle thief nabbed with a stove</span> <span class="pop-summary">A 45-year-old man who previously served time behind bars for...</span></span></a><br class="pop-cl" /></li></ul><ul id="pop-widget-commented-5"><li><a href="https://www.barbadostoday.bb/2016/12/19/five-firearms-discovered-in-food-barrel/" title="Five firearms discovered in food barrel" rel="bookmark"><img width="50" height="50" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-50x50.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-50x50.jpg 50w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-150x150.jpg 150w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-30x30.jpg 30w" data-lazy-sizes="(max-width: 50px) 100vw, 50px" data-wp-pid="154566" /><noscript><img width="50" height="50" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-50x50.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-50x50.jpg 50w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-150x150.jpg 150w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-30x30.jpg 30w" sizes="(max-width: 50px) 100vw, 50px" data-wp-pid="154566" /></noscript><span class="pop-overlay"><span class="pop-title">Five firearms discovered in food barrel</span> <span class="pop-summary">A 29-year-old woman is due to appear in the District 'A'...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2016/12/17/million-dollar-repair-of-south-coast-sewerage-system/" title="$2 million repair of South Coast sewerage system" rel="bookmark"><img width="736" height="626" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JohnXMwanza.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JohnXMwanza.jpg 736w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JohnXMwanza-650x553.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JohnXMwanza-160x136.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JohnXMwanza-640x544.jpg 640w" data-lazy-sizes="(max-width: 736px) 100vw, 736px" data-wp-pid="184272" /><noscript><img width="736" height="626" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JohnXMwanza.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JohnXMwanza.jpg 736w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JohnXMwanza-650x553.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JohnXMwanza-160x136.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JohnXMwanza-640x544.jpg 640w" sizes="(max-width: 736px) 100vw, 736px" data-wp-pid="184272" /></noscript><span class="pop-overlay"><span class="pop-title">$2 million repair of South Coast sewerage system</span> <span class="pop-summary">The Barbados Water Authority today announced it is undertaking a...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2016/12/18/sinckler-delivers-christmas-goodies-for-constituents/" title="Sinckler delivers Christmas goodies to constituents" rel="bookmark"><img width="940" height="625" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423.jpg 940w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423-650x432.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423-768x511.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423-160x106.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423-450x300.jpg 450w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423-640x426.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423-800x532.jpg 800w" data-lazy-sizes="(max-width: 940px) 100vw, 940px" data-wp-pid="184304" /><noscript><img width="940" height="625" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423.jpg 940w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423-650x432.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423-768x511.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423-160x106.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423-450x300.jpg 450w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423-640x426.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DSC_7423-800x532.jpg 800w" sizes="(max-width: 940px) 100vw, 940px" data-wp-pid="184304" /></noscript><span class="pop-overlay"><span class="pop-title">Sinckler delivers Christmas goodies to constituents</span> <span class="pop-summary">Five hundred households in the St Michael North West constituency...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2016/12/20/official-wants-urgent-attention-to-potholes/" title="Official wants urgent attention to potholes" rel="bookmark"><img width="900" height="422" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_8208.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_8208.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_8208-650x305.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_8208-768x360.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_8208-160x75.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_8208-640x300.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_8208-800x375.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="184466" /><noscript><img width="900" height="422" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_8208.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_8208.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_8208-650x305.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_8208-768x360.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_8208-160x75.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_8208-640x300.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_8208-800x375.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="184466" /></noscript><span class="pop-overlay"><span class="pop-title">Official wants urgent attention to potholes</span> <span class="pop-summary">A road safety advocate is calling on the authorities to...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2016/12/19/update-five-firearms-discovered-in-food-barrel/" title="UPDATE-Five firearms discovered in food barrel" rel="bookmark"><img width="283" height="212" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/Screen-Shot-2016-12-19-at-12.33.35-PM-e1482166392839.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/Screen-Shot-2016-12-19-at-12.33.35-PM-e1482166392839.png 283w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/Screen-Shot-2016-12-19-at-12.33.35-PM-e1482166392839-80x60.png 80w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/Screen-Shot-2016-12-19-at-12.33.35-PM-e1482166392839-118x88.png 118w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/Screen-Shot-2016-12-19-at-12.33.35-PM-e1482166392839-160x120.png 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/Screen-Shot-2016-12-19-at-12.33.35-PM-e1482166392839-600x450.png 600w" data-lazy-sizes="(max-width: 283px) 100vw, 283px" data-wp-pid="184363" /><noscript><img width="283" height="212" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/Screen-Shot-2016-12-19-at-12.33.35-PM-e1482166392839.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/Screen-Shot-2016-12-19-at-12.33.35-PM-e1482166392839.png 283w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/Screen-Shot-2016-12-19-at-12.33.35-PM-e1482166392839-80x60.png 80w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/Screen-Shot-2016-12-19-at-12.33.35-PM-e1482166392839-118x88.png 118w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/Screen-Shot-2016-12-19-at-12.33.35-PM-e1482166392839-160x120.png 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/Screen-Shot-2016-12-19-at-12.33.35-PM-e1482166392839-600x450.png 600w" sizes="(max-width: 283px) 100vw, 283px" data-wp-pid="184363" /></noscript><span class="pop-overlay"><span class="pop-title">UPDATE-Five firearms discovered in food barrel</span> <span class="pop-summary">A 29-year-old woman has been remanded to jail after she...</span></span></a><br class="pop-cl" /></li></ul><ul id="pop-widget-viewed-5"><li><a href="https://www.barbadostoday.bb/2016/12/20/bond-for-assaulting-man-over-woman/" title="Bond for assaulting man over woman" rel="bookmark"><img width="900" height="453" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DwainXLopez.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DwainXLopez.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DwainXLopez-650x327.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DwainXLopez-768x387.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DwainXLopez-160x81.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DwainXLopez-640x322.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DwainXLopez-800x403.jpg 800w" data-lazy-sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="184408" /><noscript><img width="900" height="453" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DwainXLopez.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DwainXLopez.jpg 900w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DwainXLopez-650x327.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DwainXLopez-768x387.jpg 768w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DwainXLopez-160x81.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DwainXLopez-640x322.jpg 640w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/DwainXLopez-800x403.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" data-wp-pid="184408" /></noscript><span class="pop-overlay"><span class="pop-title">Bond for assaulting man over woman</span> <span class="pop-summary">A Bridgetown magistrate has placed a Checker Hall, St Lucy...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2016/12/21/st-joseph-man-charged-with-murder/" title="St Joseph man charged with murder" rel="bookmark"><img width="450" height="300" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/shaQUON-MAYCOCK.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/shaQUON-MAYCOCK.jpg 450w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/shaQUON-MAYCOCK-160x106.jpg 160w" data-lazy-sizes="(max-width: 450px) 100vw, 450px" data-wp-pid="184632" /><noscript><img width="450" height="300" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/shaQUON-MAYCOCK.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/shaQUON-MAYCOCK.jpg 450w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/shaQUON-MAYCOCK-160x106.jpg 160w" sizes="(max-width: 450px) 100vw, 450px" data-wp-pid="184632" /></noscript><span class="pop-overlay"><span class="pop-title">St Joseph man charged with murder</span> <span class="pop-summary">A St Joseph man has been formally charged with the murder of...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2016/12/17/soldier-laid-to-rest/" title="Soldier laid to rest" rel="bookmark"><img width="500" height="666" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_7488-e1482021082339.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-wp-pid="184279" /><noscript><img width="500" height="666" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/IMG_7488-e1482021082339.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-wp-pid="184279" /></noscript><span class="pop-overlay"><span class="pop-title">Soldier laid to rest</span> <span class="pop-summary">Officers from the Barbados Defence Force gathered in the Calvary...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2016/12/17/murder-accused-on-incest-and-indecent-assault-charges/" title="Murder accused on incest and indecent assault charges" rel="bookmark"><img width="698" height="461" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JamarXPileXcopy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JamarXPileXcopy.jpg 698w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JamarXPileXcopy-650x429.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JamarXPileXcopy-70x45.jpg 70w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JamarXPileXcopy-160x106.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JamarXPileXcopy-640x423.jpg 640w" data-lazy-sizes="(max-width: 698px) 100vw, 698px" data-wp-pid="184175" /><noscript><img width="698" height="461" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JamarXPileXcopy.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JamarXPileXcopy.jpg 698w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JamarXPileXcopy-650x429.jpg 650w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JamarXPileXcopy-70x45.jpg 70w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JamarXPileXcopy-160x106.jpg 160w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/12/JamarXPileXcopy-640x423.jpg 640w" sizes="(max-width: 698px) 100vw, 698px" data-wp-pid="184175" /></noscript><span class="pop-overlay"><span class="pop-title">Murder accused on incest and indecent assault charges</span> <span class="pop-summary">Jamar Antonio Pile appeared in court Friday on charges of incest...</span></span></a><br class="pop-cl" /></li><li><a href="https://www.barbadostoday.bb/2016/12/19/five-firearms-discovered-in-food-barrel/" title="Five firearms discovered in food barrel" rel="bookmark"><img width="50" height="50" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-50x50.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" data-lazy-srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-50x50.jpg 50w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-150x150.jpg 150w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-30x30.jpg 30w" data-lazy-sizes="(max-width: 50px) 100vw, 50px" data-wp-pid="154566" /><noscript><img width="50" height="50" src="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-50x50.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-50x50.jpg 50w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-150x150.jpg 150w, https://16f6e5e6d2.site.internapcdn.net/wp-content/uploads/2016/03/IMG_3404-30x30.jpg 30w" sizes="(max-width: 50px) 100vw, 50px" data-wp-pid="154566" /></noscript><span class="pop-overlay"><span class="pop-title">Five firearms discovered in food barrel</span> <span class="pop-summary">A 29-year-old woman is due to appear in the District 'A'...</span></span></a><br class="pop-cl" /></li></ul></div></div></div></div><div id="gabfire_archive_widget-3" class="widget gabfire_archive_widget"><div class="widgetinner"><h3 class="widgettitle">Search in Archive</h3><div style="background:transparent"><form action="https://www.barbadostoday.bb/"  method="get" > <label>Select a Month</label> <select name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'><option value="">Click to Select</option><option value='https://www.barbadostoday.bb/2016/12/'> December 2016</option><option value='https://www.barbadostoday.bb/2016/11/'> November 2016</option><option value='https://www.barbadostoday.bb/2016/10/'> October 2016</option><option value='https://www.barbadostoday.bb/2016/09/'> September 2016</option><option value='https://www.barbadostoday.bb/2016/08/'> August 2016</option><option value='https://www.barbadostoday.bb/2016/07/'> July 2016</option><option value='https://www.barbadostoday.bb/2016/06/'> June 2016</option><option value='https://www.barbadostoday.bb/2016/05/'> May 2016</option><option value='https://www.barbadostoday.bb/2016/04/'> April 2016</option><option value='https://www.barbadostoday.bb/2016/03/'> March 2016</option><option value='https://www.barbadostoday.bb/2016/02/'> February 2016</option><option value='https://www.barbadostoday.bb/2016/01/'> January 2016</option><option value='https://www.barbadostoday.bb/2015/12/'> December 2015</option><option value='https://www.barbadostoday.bb/2015/11/'> November 2015</option><option value='https://www.barbadostoday.bb/2015/10/'> October 2015</option><option value='https://www.barbadostoday.bb/2015/09/'> September 2015</option><option value='https://www.barbadostoday.bb/2015/08/'> August 2015</option><option value='https://www.barbadostoday.bb/2015/07/'> July 2015</option><option value='https://www.barbadostoday.bb/2015/06/'> June 2015</option><option value='https://www.barbadostoday.bb/2015/05/'> May 2015</option><option value='https://www.barbadostoday.bb/2015/04/'> April 2015</option><option value='https://www.barbadostoday.bb/2015/03/'> March 2015</option><option value='https://www.barbadostoday.bb/2015/02/'> February 2015</option><option value='https://www.barbadostoday.bb/2015/01/'> January 2015</option><option value='https://www.barbadostoday.bb/2014/12/'> December 2014</option><option value='https://www.barbadostoday.bb/2014/11/'> November 2014</option><option value='https://www.barbadostoday.bb/2014/10/'> October 2014</option><option value='https://www.barbadostoday.bb/2014/09/'> September 2014</option><option value='https://www.barbadostoday.bb/2014/08/'> August 2014</option><option value='https://www.barbadostoday.bb/2014/07/'> July 2014</option><option value='https://www.barbadostoday.bb/2014/06/'> June 2014</option><option value='https://www.barbadostoday.bb/2014/05/'> May 2014</option><option value='https://www.barbadostoday.bb/2014/04/'> April 2014</option><option value='https://www.barbadostoday.bb/2014/03/'> March 2014</option><option value='https://www.barbadostoday.bb/2014/02/'> February 2014</option><option value='https://www.barbadostoday.bb/2014/01/'> January 2014</option><option value='https://www.barbadostoday.bb/2013/12/'> December 2013</option><option value='https://www.barbadostoday.bb/2013/11/'> November 2013</option><option value='https://www.barbadostoday.bb/2013/10/'> October 2013</option><option value='https://www.barbadostoday.bb/2013/09/'> September 2013</option><option value='https://www.barbadostoday.bb/2013/08/'> August 2013</option><option value='https://www.barbadostoday.bb/2013/07/'> July 2013</option><option value='https://www.barbadostoday.bb/2013/06/'> June 2013</option><option value='https://www.barbadostoday.bb/2013/05/'> May 2013</option><option value='https://www.barbadostoday.bb/2013/04/'> April 2013</option><option value='https://www.barbadostoday.bb/2013/03/'> March 2013</option><option value='https://www.barbadostoday.bb/2013/02/'> February 2013</option><option value='https://www.barbadostoday.bb/2013/01/'> January 2013</option><option value='https://www.barbadostoday.bb/2012/12/'> December 2012</option><option value='https://www.barbadostoday.bb/2012/11/'> November 2012</option><option value='https://www.barbadostoday.bb/2012/10/'> October 2012</option><option value='https://www.barbadostoday.bb/2012/09/'> September 2012</option><option value='https://www.barbadostoday.bb/2012/08/'> August 2012</option><option value='https://www.barbadostoday.bb/2012/07/'> July 2012</option> </select></form><form action="https://www.barbadostoday.bb/"  method="get" > <label>Select a Category</label> <select  name='cat' id='cat' class='postform' ><option value='-1'>Click to Select</option><option class="level-0" value="1166">Baseball</option><option class="level-0" value="91">Business</option><option class="level-1" value="1152">&nbsp;&nbsp;&nbsp;Banking</option><option class="level-1" value="204">&nbsp;&nbsp;&nbsp;Entrepreneurship</option><option class="level-1" value="231">&nbsp;&nbsp;&nbsp;Indus. Relations</option><option class="level-1" value="159">&nbsp;&nbsp;&nbsp;Int&#8217;l Business</option><option class="level-1" value="1124">&nbsp;&nbsp;&nbsp;Real Estate</option><option class="level-1" value="160">&nbsp;&nbsp;&nbsp;Social Partnership</option><option class="level-1" value="161">&nbsp;&nbsp;&nbsp;Stock Exchange</option><option class="level-1" value="162">&nbsp;&nbsp;&nbsp;Tourism</option><option class="level-0" value="1221">CARICOM</option><option class="level-0" value="92">Column</option><option class="level-0" value="1171">Court</option><option class="level-0" value="1234">Cricket</option><option class="level-0" value="1213">Culture</option><option class="level-0" value="93">Editorial</option><option class="level-0" value="1231">Entertainment</option><option class="level-0" value="1225">Feature</option><option class="level-0" value="96">Features</option><option class="level-0" value="825">Focus</option><option class="level-0" value="1226">Global</option><option class="level-0" value="1172">Independence Feature</option><option class="level-0" value="1227">International</option><option class="level-0" value="1222">Jamaica</option><option class="level-0" value="94">Leisure</option><option class="level-1" value="192">&nbsp;&nbsp;&nbsp;Crop Over</option><option class="level-2" value="223">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Foreday Mornin&#8217;</option><option class="level-2" value="221">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Junior Kadooment</option><option class="level-2" value="1119">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Junior Monarch</option><option class="level-2" value="220">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Kadooment Day</option><option class="level-2" value="222">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Pic-O-De-Crop</option><option class="level-1" value="107">&nbsp;&nbsp;&nbsp;Entertainment</option><option class="level-2" value="1193">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Music</option><option class="level-1" value="912">&nbsp;&nbsp;&nbsp;NIFCA</option><option class="level-0" value="97">Letters</option><option class="level-0" value="98">Lifestyle</option><option class="level-1" value="179">&nbsp;&nbsp;&nbsp;Body</option><option class="level-1" value="195">&nbsp;&nbsp;&nbsp;Food</option><option class="level-1" value="189">&nbsp;&nbsp;&nbsp;Mind</option><option class="level-1" value="163">&nbsp;&nbsp;&nbsp;Recipes</option><option class="level-1" value="190">&nbsp;&nbsp;&nbsp;Spirit</option><option class="level-0" value="1230">Local HNews</option><option class="level-0" value="99">Local News</option><option class="level-1" value="440">&nbsp;&nbsp;&nbsp;Agriculture</option><option class="level-1" value="920">&nbsp;&nbsp;&nbsp;Church</option><option class="level-1" value="1118">&nbsp;&nbsp;&nbsp;CLICO</option><option class="level-1" value="205">&nbsp;&nbsp;&nbsp;Crime</option><option class="level-1" value="571">&nbsp;&nbsp;&nbsp;Culture</option><option class="level-1" value="233">&nbsp;&nbsp;&nbsp;Economy</option><option class="level-1" value="206">&nbsp;&nbsp;&nbsp;Education</option><option class="level-1" value="809">&nbsp;&nbsp;&nbsp;Emergency</option><option class="level-1" value="226">&nbsp;&nbsp;&nbsp;Energy</option><option class="level-1" value="227">&nbsp;&nbsp;&nbsp;Environment</option><option class="level-1" value="977">&nbsp;&nbsp;&nbsp;Foreign Affairs</option><option class="level-1" value="207">&nbsp;&nbsp;&nbsp;Health Care</option><option class="level-1" value="214">&nbsp;&nbsp;&nbsp;Housing</option><option class="level-1" value="1220">&nbsp;&nbsp;&nbsp;Immigration</option><option class="level-1" value="869">&nbsp;&nbsp;&nbsp;Judicial</option><option class="level-1" value="1126">&nbsp;&nbsp;&nbsp;Legistlature</option><option class="level-1" value="1117">&nbsp;&nbsp;&nbsp;National Insurance</option><option class="level-1" value="1153">&nbsp;&nbsp;&nbsp;Social Care</option><option class="level-1" value="658">&nbsp;&nbsp;&nbsp;Technology</option><option class="level-1" value="913">&nbsp;&nbsp;&nbsp;Telecommunications</option><option class="level-1" value="213">&nbsp;&nbsp;&nbsp;Transportation</option><option class="level-1" value="441">&nbsp;&nbsp;&nbsp;Work force</option><option class="level-0" value="1229">Local Newsc</option><option class="level-0" value="1232">Locsl News</option><option class="level-0" value="883">Off-beat</option><option class="level-0" value="102">Politics</option><option class="level-1" value="1219">&nbsp;&nbsp;&nbsp;Budget</option><option class="level-1" value="212">&nbsp;&nbsp;&nbsp;Elections 2013</option><option class="level-1" value="211">&nbsp;&nbsp;&nbsp;House of Assembly</option><option class="level-1" value="210">&nbsp;&nbsp;&nbsp;Senate</option><option class="level-0" value="430">Public Relations</option><option class="level-0" value="1202">Region</option><option class="level-0" value="103">Regional</option><option class="level-1" value="180">&nbsp;&nbsp;&nbsp;Antigua</option><option class="level-1" value="184">&nbsp;&nbsp;&nbsp;Bahamas</option><option class="level-1" value="657">&nbsp;&nbsp;&nbsp;Bermuda</option><option class="level-1" value="1165">&nbsp;&nbsp;&nbsp;British Virgin Islands</option><option class="level-1" value="187">&nbsp;&nbsp;&nbsp;CARICOM</option><option class="level-1" value="846">&nbsp;&nbsp;&nbsp;Cayman Islands</option><option class="level-1" value="188">&nbsp;&nbsp;&nbsp;CCJ</option><option class="level-1" value="1157">&nbsp;&nbsp;&nbsp;Cuba</option><option class="level-1" value="845">&nbsp;&nbsp;&nbsp;Dominica</option><option class="level-1" value="907">&nbsp;&nbsp;&nbsp;Grenada</option><option class="level-1" value="804">&nbsp;&nbsp;&nbsp;Guyana</option><option class="level-1" value="829">&nbsp;&nbsp;&nbsp;Haiti</option><option class="level-1" value="183">&nbsp;&nbsp;&nbsp;Jamaica</option><option class="level-1" value="186">&nbsp;&nbsp;&nbsp;LIAT</option><option class="level-1" value="1102">&nbsp;&nbsp;&nbsp;St Kitts &amp; Nevis</option><option class="level-1" value="741">&nbsp;&nbsp;&nbsp;St Lucia</option><option class="level-1" value="659">&nbsp;&nbsp;&nbsp;St Vincent</option><option class="level-1" value="182">&nbsp;&nbsp;&nbsp;Trinidad &amp; Tobago</option><option class="level-1" value="185">&nbsp;&nbsp;&nbsp;UWI</option><option class="level-0" value="104">Slider</option><option class="level-0" value="95">Special Events</option><option class="level-0" value="105">Sports</option><option class="level-1" value="837">&nbsp;&nbsp;&nbsp;Athletics</option><option class="level-1" value="842">&nbsp;&nbsp;&nbsp;Badminton</option><option class="level-1" value="717">&nbsp;&nbsp;&nbsp;Basketball</option><option class="level-1" value="1120">&nbsp;&nbsp;&nbsp;Beach Soccer</option><option class="level-1" value="858">&nbsp;&nbsp;&nbsp;Body building</option><option class="level-1" value="616">&nbsp;&nbsp;&nbsp;Boxing</option><option class="level-1" value="1169">&nbsp;&nbsp;&nbsp;Chess</option><option class="level-1" value="164">&nbsp;&nbsp;&nbsp;Cricket</option><option class="level-1" value="916">&nbsp;&nbsp;&nbsp;Cycling</option><option class="level-1" value="1164">&nbsp;&nbsp;&nbsp;Draughts</option><option class="level-1" value="165">&nbsp;&nbsp;&nbsp;Field Hockey</option><option class="level-1" value="442">&nbsp;&nbsp;&nbsp;Fishing</option><option class="level-1" value="577">&nbsp;&nbsp;&nbsp;Fitness</option><option class="level-1" value="166">&nbsp;&nbsp;&nbsp;Football</option><option class="level-1" value="470">&nbsp;&nbsp;&nbsp;Golf</option><option class="level-1" value="1170">&nbsp;&nbsp;&nbsp;Gymnastics</option><option class="level-1" value="919">&nbsp;&nbsp;&nbsp;Hockey</option><option class="level-1" value="196">&nbsp;&nbsp;&nbsp;Horse Racing</option><option class="level-1" value="617">&nbsp;&nbsp;&nbsp;Martial Arts</option><option class="level-1" value="167">&nbsp;&nbsp;&nbsp;Motor Sport</option><option class="level-1" value="168">&nbsp;&nbsp;&nbsp;Netball</option><option class="level-1" value="1217">&nbsp;&nbsp;&nbsp;Olympics</option><option class="level-1" value="432">&nbsp;&nbsp;&nbsp;Polo</option><option class="level-1" value="169">&nbsp;&nbsp;&nbsp;Road Tennis</option><option class="level-1" value="554">&nbsp;&nbsp;&nbsp;Rugby</option><option class="level-1" value="848">&nbsp;&nbsp;&nbsp;Sailing</option><option class="level-1" value="922">&nbsp;&nbsp;&nbsp;School</option><option class="level-1" value="1167">&nbsp;&nbsp;&nbsp;Shooting</option><option class="level-1" value="863">&nbsp;&nbsp;&nbsp;Squash</option><option class="level-1" value="917">&nbsp;&nbsp;&nbsp;Surfing</option><option class="level-1" value="433">&nbsp;&nbsp;&nbsp;Swimming</option><option class="level-1" value="651">&nbsp;&nbsp;&nbsp;Tennis</option><option class="level-1" value="170">&nbsp;&nbsp;&nbsp;Track and Field</option><option class="level-1" value="921">&nbsp;&nbsp;&nbsp;Volleyball</option><option class="level-1" value="718">&nbsp;&nbsp;&nbsp;Weightlifting</option><option class="level-1" value="826">&nbsp;&nbsp;&nbsp;Yachting</option><option class="level-0" value="1223">St Vincent</option><option class="level-0" value="1228">Tourism</option><option class="level-0" value="1233">Trinidad</option><option class="level-0" value="1214">UK</option><option class="level-0" value="1">Uncategorized</option><option class="level-0" value="1205">Venezuela</option><option class="level-0" value="106">World</option><option class="level-1" value="203">&nbsp;&nbsp;&nbsp;Africa</option><option class="level-1" value="201">&nbsp;&nbsp;&nbsp;Asia</option><option class="level-1" value="1188">&nbsp;&nbsp;&nbsp;Australia</option><option class="level-1" value="198">&nbsp;&nbsp;&nbsp;Canada</option><option class="level-1" value="200">&nbsp;&nbsp;&nbsp;Europe</option><option class="level-1" value="805">&nbsp;&nbsp;&nbsp;India</option><option class="level-1" value="1125">&nbsp;&nbsp;&nbsp;Latin America</option><option class="level-1" value="1121">&nbsp;&nbsp;&nbsp;Middle East</option><option class="level-1" value="202">&nbsp;&nbsp;&nbsp;United Kingdom</option><option class="level-1" value="199">&nbsp;&nbsp;&nbsp;USA</option> </select></form> <script type="text/javascript">var dropdown=document.getElementById("cat");function onCatChange(){if(dropdown.options[dropdown.selectedIndex].value>0){location.href="https://www.barbadostoday.bb/?cat="+dropdown.options[dropdown.selectedIndex].value;}}
dropdown.onchange=onCatChange;</script> <form method="get" action="//www.google.com/search"> <label>Search with Google</label> <input name="q" class="google" value="Write keyword and hit return" onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;" /> <input type="hidden" name="sitesearch" value="https://www.barbadostoday.bb/" /></form></div><div class='clear'></div></div></div><div class="widget"> <script>broadstreet.zone(50036);</script> <br> <br> <script>broadstreet.zone(51860);</script></div></div></div></div></div><div id="footer"><div id="foo_widget1"><div id="gab_about_widget-2" class="widget gab_about_widget"><div class="widgetinner"><h3 class="widgettitle">Barbados Today</h3><p>Our <a href="/about-us">mission</a> is to keep you informed. Do you have news, know of an event or a personality deserving of coverage? <a href="/contact-us">Contact us</a> today! Nothing or no one is too big or too small for us at Barbados Today to highlight. You can also take your own good quality photographs of community events <a href="/contact-us/">and drop us a note</a> with the details.</p><div class="clear clearfix"></div><div class='clear'></div></div></div><div id="text-6" class="widget widget_text"><div class="widgetinner"><div class="textwidget"><p>Mr Peter Harris<br /> Chairman</p><p>Ms Kaymar Jordan<br /> Chief Executive Officer & Editor-in-Chief<br /> Tel:(246) 417- 1000</p><p>Mrs Sandy Deane<br /> Editorial Coordinator<br /> Tel:(246) 417- 1000</p><p>Mr Wade Gibbons<br /> Sports Coordinator<br /> Tel:(246) 417- 1000</p><p>Mr David Williams<br /> Advertising / Sales Manager<br /> Tel:(246) 417- 1005</p><p>Mr Henry Richards<br /> Creative / Technical Manager<br /> Tel:(246) 417- 1032</p></div></div></div></div><div id="foo_widget2"><div id="gabfire_social_widget-3" class="widget gabfire_social_widget"><div class="widgetinner"><h3 class="widgettitle">Connect</h3> <a target="_blank" class="facebook" href="https://www.facebook.com/BarbadosToday" rel="nofollow">Facebook</a><a target="_blank" class="twitter" href="https://twitter.com/barbadostoday" rel="nofollow">Twitter</a><a target="_blank" class="feed" href="https://www.barbadostoday.bb/feed" rel="nofollow">RSS Feed</a><a target="_blank" class="instagram" href="https://www.instagram.com/barbadostoday" rel="nofollow">instagram</a><a target="_blank" class="plus1" href="https://plus.google.com/+barbadostoday" rel="nofollow">Google +1</a><a target="_blank" class="youtube" href="https://www.youtube.com/user/barbadostoday" rel="nofollow">Youtube</a><div class="clear clearfix"></div><div class='clear'></div></div></div><div id="text-8" class="widget widget_text"><div class="widgetinner"><div class="textwidget">Barbados Today<br> Unit 22, Warrens Industrial Park<br> Warrens,<br> St. Michael BB22026<br> Barbados<br> +1 (246) 417-1000<br> editor@barbadostoday.bb</div></div></div></div></div><div id="footer_data"><ul class="footerpages"><li class="first"><a href="https://www.barbadostoday.bb/" title="News you can trust.">Home</a></li><li id="menu-item-49906" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49906"><a href="https://www.barbadostoday.bb/about-us/">About Us</a></li><li id="menu-item-49907" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49907"><a href="https://www.barbadostoday.bb/contact-us/">Contact Us</a></li><li id="menu-item-49908" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49908"><a href="https://www.barbadostoday.bb/privacy-policy/">Privacy Policy</a></li><li id="menu-item-49909" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49909"><a href="https://www.barbadostoday.bb/terms-of-service/">Terms of Service</a></li><li id="menu-item-152108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152108"><a href="https://www.barbadostoday.bb/advertising/">Advertising</a></li><li><a rel="nofollow" href="https://www.barbadostoday.bb/feed/">RSS</a></li><li class="right"><a href="#top" title="Barbados Today" rel="home"><strong>&uarr;</strong> Barbados Today</a></li></ul><div class="clear"></div><p id="footer-left-side"> <a href="https://www.barbadostoday.bb/" title="Barbados Today" rel="home">Barbados Today</a></p><p id="footer-right-side"> <a href="https://www.barbadostoday.bb/wp-login.php">Log in</a> - <a href="http://wordpress.org/" title="Semantic Personal Publishing Platform" rel="generator">Powered by WordPress</a> -
Designed by <a href="http://www.gabfirethemes.com/" title="Premium WordPress Themes">Gabfire Themes</a> <script type="text/javascript">analytics.track("Viewed Post",{"title":"Convicted gas bottle thief nabbed with a stove","category":"Court","noninteraction":true},{"library":"analytics-wordpress"});</script> <script>broadstreet.watch({})</script> <div id="fb-root"></div> <script type='text/javascript'>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_US/all.js#xfbml=1";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script> <script type='text/javascript'>var popwid={"postid":"184712","ajaxurl":"https:\/\/www.barbadostoday.bb\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://16f6e5e6d2.site.internapcdn.net/wp-content/plugins/popular-widget/_js/pop-widget.js?ver=1.7.0'></script>  <script src="https://16f6e5e6d2.site.internapcdn.net/wp-content/cache/min/1/b949af48e8bd0134f5990bae0f5863a8.js" data-minify="1"></script> </p></div></body></html>
<!-- This website is like a Rocket, isn't it ? Performance optimized by WP Rocket. Learn more: http://wp-rocket.me - Debug: cached@1482410231 -->